Digi Mode not keying transmitter

  • 1
  • Question
  • Updated 3 years ago
I am using SSDR v1.6.21 and fldigi v3.23.08. The DAX control panel shows signals sending and receiving on the meters. When I tune from fldigi it shows signals on the Level meter on my Flex 6700. The radio does not seem to be keying and transmitting when I send a message from fldigi. I have searched and I am sure the information is somewhere but, I can't find anything updated with the latest versions of either software. There must be a simple fix for this and I am just overlooking something. I am trying to get into the digital modes and I am stuck at this point.
Photo of Hugh Sanderson

Hugh Sanderson

  • 11 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Jon  W1JDB

Jon W1JDB

  • 146 Posts
  • 35 Reply Likes
Do you have a separate COM Port created to handle the PTT in SmartCAT.
Photo of Hugh Sanderson

Hugh Sanderson

  • 11 Posts
  • 0 Reply Likes
COM4 shows Slice:A  (Auto Switch TX)  Process: (None) in SmartSDR CAT.  I created COM5 and it shows the same as 4. I listed it under device in RigCAT in Fldigi.  No luck.
When I go to the Windows playback and recording devices, the Recording shows DAX Audio RX 1 as Not Plugged in and the properties shows The Device is Working Properly.
Please see my comments to Dudley below.  Thanks!
Photo of Dudley - WA5QPZ

Dudley - WA5QPZ

  • 212 Posts
  • 45 Reply Likes
Check that you have SmartCAT running,  I am will to bet that you are not seeing the frequency of the radio in FlDigi either.   Make sure that you have the SmartSDR "Rig"  profile , xml file in Rig Cat.. 
Photo of Hugh Sanderson

Hugh Sanderson

  • 11 Posts
  • 0 Reply Likes
I downloaded the file (it is an XML Document file) and I opened it in RigCAT for the Rig Description file (fldigi_def.xml) in Fldigi.  I can move the slider up and down the waterfall and click on a signal and Fldigi shows the frequency in what I am assuming is the logging panel.  The larger number frequency on the far left of the screen never changes.
Please see my comments to Jon above.  Thanks!
Photo of DrTeeth

DrTeeth

  • 1687 Posts
  • 387 Reply Likes
Fldigi_def.XML is the config file for fldigi. You need the XML files for the Flex itself https://sourceforge.net/projects/fldi.... Start with the one for slice A for basic working. Good luck.
Photo of Hugh Sanderson

Hugh Sanderson

  • 11 Posts
  • 0 Reply Likes
Thank you Guy.  After more instruction from various Elmers, I learned how to properly download the file by right clicking it and saving it. Then you open this saved file in Fldigi.
Photo of Alex - DH2ID

Alex - DH2ID, Elmer

  • 891 Posts
  • 166 Reply Likes
Hugh, create an extra CAT port in SmartCAT if you're using other programs in
parallel, which also need CAT ports.



Note that my CAT port is 25, as I am running some other programs
in parallel. The PTT port will not be used!

In fldigi use this setup:


Note that I use "CAT command for PTT" !

There is also my tutorial:
https://community.flexradio.com/flexradio/topics/tutorial-setting-up-fldigi-with-smartsdr

good luck with fldigi !

Alex - DH2ID
(Edited)
Photo of Hugh Sanderson

Hugh Sanderson

  • 11 Posts
  • 0 Reply Likes
Alex,
Thank you very much.  I now have the Fldigi and PSK31 working.  I will be moving on to RTTY an JT65 (WSJT) next.  Please stay tuned!  I am confident I will need another tutorial. 
This is a GREAT help to those like myself that are not quite as computer savy and I comend you and all of the others for helping those of us that are challenged.
73,
Hugh
Photo of rich

rich

  • 37 Posts
  • 3 Reply Likes

I've also see this problem here at K3VAT using Flex6300 and JTX (V. 1.6.0).  Happened 3 times in two days.  I resolve it by closing DAX and reopening it.  I use Windows 10 and several days ago MS had a rather large upgrade.  If it happens again, I'll open a trouble-ticket.


73, Rich, K3VAT

Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3466 Reply Likes
DAX has absolutely nothing to do with keying the radio as it only handles audio transfer.  Keying is done with SmartSDR CAT.  I would also recommend trying a different digital mode program than WSJT apps as an issue validator, as there have been numerous reports of keying problems like this specific with WSJT.  If the problems continue, please do open a HelpDesk ticket so we can assist in identifying what component is not working properly.