Device Description Incorrect

  • 1
  • Problem
  • Updated 4 years ago
  • In Progress
I recently obtained a Flex5000A. This particular radio has probably not been used at all in the last 7-8 years. I downloaded the latest version of PowerSDR (2.7.2) with the integrated installer.

When I run the FlexRadio program my Device Description shows my radio as a FlexRadio Systems FLEX-3000.

When I try to run PowerSDR it tells me I need a firmware upgrade. When I answer yes to that upgrade the firmware update window appears but just hangs.

I am assuming the firmware in this box is really really out of date so I tried following the instruction for a manual install through the Flex Radio app. When I locate and try to install the latest 5000 firmware I receive messages stating this is not allowed because my product IDs don't match.

I don't want to proceed any further without some instruction since I am afraid I might brick the  radio. Any help is appreciated.

73 de Bob (KI6DY)
Photo of Bob Ruvolo

Bob Ruvolo

  • 4 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Jim Jerzycke

Jim Jerzycke

  • 93 Posts
  • 19 Reply Likes
IIRC, the firmware requires being "sequentially" updated.

That is, if what's installed in the radio is too far out of sync with the version of PSDR you're trying to use, it won't load the newer version.

I hope somebody corrects me if I'm wrong, or posts of a utility to get around this.

Sorry I can't be of more help!

73, Jim
(Edited)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9204 Posts
  • 3568 Reply Likes
Official Response
I have changed this post to a problem topic and converted this topic to a support HelpDesk ticket (http://helpdesk.flexradio.com) for expedited issue resolution.  If anyone else is experiencing an issue similar to this one, please submit a HelpDesk support ticket for issue resolution.
Photo of Bob Ruvolo

Bob Ruvolo

  • 4 Posts
  • 0 Reply Likes
This was all fixed by Dudley over the phone and with Teamviewer. What great customer service, I'm very impressed. I have alot to learn but have already made several contacts. Thanks Tim and Dudley

Bob (KI6DY)
Photo of DrTeeth

DrTeeth

  • 1687 Posts
  • 389 Reply Likes
Just out of interest, what was the problem?
Photo of Bob Ruvolo

Bob Ruvolo

  • 4 Posts
  • 0 Reply Likes

The problem was, as I expected, a very old and out of date firmware version in the radio, something from 2008 or so when the radio was purchased. 

I not sure I followed everything that Dudley did but I believe this was the fix:

1. Roll back the firewire driver to some earlier version.

2. Flash the latest firmware into the radio.

3. Install the latest firewire driver.

He then went into the Flexradio App and SDR and made sure everything looked good and was set correctly.

Then he proceeded to give me half hour tutorial on PowerSDR.

As an aside, I am an exclusively digital operator, JT65, JT9, and RTTY mostly. However, after hearing the SSB audio that came out of this rig, I am seriously considering hooking up a microphone if I can find  one in a drawer somewhere.

Bob (KI6DY)






Photo of DrTeeth

DrTeeth

  • 1687 Posts
  • 389 Reply Likes
Hi Bob. Thanks for getting back to us. Hope to snag you for the log. I still need to get a fellow flexer from this forum in the log, sadly.