Device Description Incorrect

  • 1
  • Problem
  • Updated 2 years ago
  • In Progress
I recently obtained a Flex5000A. This particular radio has probably not been used at all in the last 7-8 years. I downloaded the latest version of PowerSDR (2.7.2) with the integrated installer.

When I run the FlexRadio program my Device Description shows my radio as a FlexRadio Systems FLEX-3000.

When I try to run PowerSDR it tells me I need a firmware upgrade. When I answer yes to that upgrade the firmware update window appears but just hangs.

I am assuming the firmware in this box is really really out of date so I tried following the instruction for a manual install through the Flex Radio app. When I locate and try to install the latest 5000 firmware I receive messages stating this is not allowed because my product IDs don't match.

I don't want to proceed any further without some instruction since I am afraid I might brick the  radio. Any help is appreciated.

73 de Bob (KI6DY)
Photo of Bob Ruvolo

Bob Ruvolo

  • 4 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9052 Posts
  • 3435 Reply Likes
Official Response
I have changed this post to a problem topic and converted this topic to a support HelpDesk ticket (http://helpdesk.flexradio.com) for expedited issue resolution.  If anyone else is experiencing an issue similar to this one, please submit a HelpDesk support ticket for issue resolution.