Degrade software message question

  • 1
  • Question
  • Updated 4 years ago
  • Answered
Got my brand new, shiny, nice smelling 6300 yesterday. Got it unpacked, set it on the shelf and since I don't have an antennae up yet that was as far as I got. Called a friend that has a 6300 to let him know mine was here. He offered to make sure it would run so I took it over to his place. We unplugged his unit and plugged mine in and fired it off. Pretty green  light comes on but no glory. Message came up asking if we wanted to degrade software. Hmmmm - no, I don't think we want to do this! I figure his firmware might have been out of date and I don't want to go degrading anything right now.
I better get to the point I guess - is my guess about his software being older than mine correct?
I can tell this microphone isn't going to last long, too short - what is a decent desk type mike without breaking the bank guys?
Photo of plain ol Bill

plain ol Bill

  • 5 Posts
  • 2 Reply Likes

Posted 4 years ago

  • 1
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9199 Posts
  • 3560 Reply Likes
Official Response
You received two answers that may seem confusing.  Let me see if I can clarify for you.

When you run a version of SmartSDR for Windows, there is a specific firmware version of software that must be loaded into the radio hardware.  Essentially the software running on your PC must be in sync with the firmware inside the radio.  

You will get a downgrade or upgrade firmware message if the software you are running is out of sync.

In your case, as Howard stated, your friend is running an older version of SmartSDR and your radio has a newer version.  They are out of sync and you would have to downgrade to use his software.  As Jon indicated, this is just fine.  I downgrade firmware in my radio daily for testing and support purposes.  So essentially both answers, while seemly contradictory, are correct.

I agree with Howard that your friend needs to upgrade to the latest version of SmartSDR as well as you need to download it and run it too.