DDutil v3 and SmartSDR v3 - DDutil keeps shutting down on TX

  • 1
  • Question
  • Updated 5 months ago
I had DDutil v 3 and SSDR v3 working together with my 6700 for some time.  Basically I use it for one purpose - the autodrive power function when my Alpha 87a amp is on or off.  All was well until a major Win10 update.  Nothing worked including SSDR/CAT/DAX.  I did a complete uninstall including hidden ports, then reinstalled.  My 6700 worked fine after that but kept getting  DDutil error with config file, so I did a complete unstall of DDutil including the files located in Users/Appdata both under DDutil and Roaming.    So DDutil works fine and communicates and controls my 6700 but every 2nd or 3rd time I hit the SSDR Tune button or do it from the DDutil panel, DDutil closes abruptly.  If I restart it it comes up with a config file error and I have to shut SSDR and restart.  Then DDUtil works for a while and shuts down.  There is nothing in itds errorlog.txt.  Its not RFI because I can have the RF power down to 0 W and toggle Tune and it will happen.  Weird.  Any advice appreciated.  
Photo of jerry stern

jerry stern

  • 23 Posts
  • 12 Reply Likes

Posted 5 months ago

  • 1
Photo of Erika - KØDD

Erika - KØDD

  • 112 Posts
  • 36 Reply Likes
Jerry, For SSDR v3, you need to be utilizing DDUtil v4.  I just had during the last week, a multiple AFCI pop right in a row due to RFI telling the breaker feeding the radio and computer the house was on fire.  WOW the shack gets dark really fast.

Well all that software was fragged and I was already on v4 DDUtil. On top of it ALL there was a continuous reboot on my Win10 Pro x64 workstation...  Girl needs a UPS on the computer I'd say.

When I finally got the computer back up I installed the latest prevue version (windows insider v1909) and noticed the radio had all the com ports scrambled just as a lot of the peeps have mentioned happening.  10 connected to 111, 11 connected to 112...  Things like that what a mess.

First you will want to uninstall DDUtil completely...  Including the repair procedure of deleting the user file as directed in the instruction for troubleshooting.

THEN go out to the website and download the latest version of DDUtil that was v4.0.1.09 and install that.  DO NOT USE a backup configuratiuon file from any version...  RELOAD all your configuration from scratch.  I'd make sure all your other software is OK before redoing DDUtil.  The good news for me is I got DDUtil v 4.01.09 where I had .07 previously.  While I was in there, I uninstalled all v3 and cleaned out its config file too.  Its a bit of work.  BUT simple compared to what I had to do.

Starting with a conventional Circuit Breaker in the shack...  Uninstalling SSDR completely and reinstalling.  and Reinstalling WSJT-X becuase it was blown up too.  at least my HRD didn't frag itself.  Hope that helps, ERIKA DD
(Edited)
Photo of jerry stern

jerry stern

  • 23 Posts
  • 12 Reply Likes
I searched and cannot find a download for v4 beta.  Can you email me a link?
email: k1jos [at] att [dot]net
Photo of Erik Carling

Erik Carling

  • 12 Posts
  • 1 Reply Like
I think you will find it is actually
http://www.k5fr.com/binary/DDUtil40109_Setup.zip
Photo of Erika - KØDD

Erika - KØDD

  • 112 Posts
  • 36 Reply Likes
I emailed it direct to Jerry before 9 my time.  I hope by now he's got it running.  Whatever...  YES, The link you put up Erik is the correct link.  I'm now taking my lunch, and see everybody has been busy.
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3806 Posts
  • 1658 Reply Likes
The latest version of DDUTIL  is 4,02.00 which fixed multi client disconnects of SSDR V3.18. 

I would wait for Steve to post the official link. 
Photo of jerry stern

jerry stern

  • 23 Posts
  • 12 Reply Likes
I uninstalled DDutil v3 and then went into USers/Appdata and deleted everything that had Dutil and K5FR folders.  Installed DDutil v 4 and somehow if still found the previous user config and said it had problems loading,  Where ekse and under what pseudonymns could this config  file reside?  Registry?

Photo of Erika - KØDD

Erika - KØDD

  • 112 Posts
  • 36 Reply Likes
Did you reboot before loading the new stuff?  Just asking Jerry, I've found its sort of procedure around here... and I'd just started my first wake up coffee when I posted that...  Using the windows uninstall is only 1/2 of the removal.  need to reload the registry.  Hope that fixes it.  Cleaned it right up for me anyway. You should not need to edit the registry...

and that's very neat Howard that Steve has an even newer update in the works.  Looking forward to seeing that... Erika DD