DAX won't communicate with laptop

  • 2
  • Question
  • Updated 5 months ago
My 6500 works just fine with a Windows 10 PC in my basement shack but I had the idea to have it work on my laptop (also Windows 10) so I can sit on a porch on a nice summer day. I loaded SSDR 1.11.12 and it receives just fine on the laptop but I cannot transmit. I do have remote selected in SSDR and the headphones or speaker work fine. I have CAT control as I can change frequency and mode or other selections. But I cannot transmit via MOX nor VOX. SSDR does not recognize a mic or other input. When I bring the DAX panel up TX stream TX is red saying "not connected" MIC stream is red "not connected" and Rx stream is red "Not connected and finally, in IQ streams, all show "not connected"
In Windows Settings, 'sounds', Output device is Speakers (Logitech USB Headset) Input device is Microphone (Logitech USB Headset) and in "Test your MIC", when I speak it shows on the blue bar so the computer is seeing mic audio.
I can select MOX in AM mode and key the transmitter (from the laptop) and it puts out a carrier.

The same is true of FLDIGI where I can receive just fine but not transmit as no audio from FLDIGI is getting to SSDR.    What am I overlooking?    I have compared settings and config from the PC to the laptop for each application.    Best 73, Jim     KD1I
Photo of James Del Principe

James Del Principe

  • 278 Posts
  • 28 Reply Likes

Posted 5 months ago

  • 2
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2971 Posts
  • 653 Reply Likes
I don't believe DAX works on remote
On the laptop make sure the default sound devices are sellected
(Edited)
Photo of WW1SS - Steve

WW1SS - Steve

  • 636 Posts
  • 192 Reply Likes
Dax does not work on remote. Are you on the same network on the porch? If you are you don't need "remote" on. What are you using for a mic input on your laptop. Might not transmit without audio device selected? Can you hit tune and does it tune??
Photo of NX6D Dave

NX6D Dave

  • 303 Posts
  • 91 Reply Likes
There are lots of ways this can go wrong, but they usually don't happen.  First of all, this is not a remote operation.  Unfortunately, the word "remote" was used in a confusing way in earlier documentation.   These days "remote" refers to operation of a radio that is not in your local area net (LAN).  SmartLink is used for this purpose.  Unfortunately, the button that is now labeled "PC Audio" used to be labeled "Remote" or something like that.  It may still be labeled that way in the version 1 software.

But all of this is beside the point.  You are seeing the radio and making a connection to it from your front porch, so the problem isn't a local v. remote issue.

Check the MIC input pull-down menu in SmartSDR.  It needs to be set to "PC", indicating that the SSDR program should open the default sound source device to find sound to transmit.  This control is often overlooked.

Let's ignore the DAX/FLDIGI issues until we get your SSB transmissions working.
Photo of James Del Principe

James Del Principe

  • 278 Posts
  • 28 Reply Likes
Dave, you are exactly correct !!!   You wrote: "   It needs to be set to "PC"  "    That solved the mic problem. I had not considered that.   After spending hours of grief, you solved it in a single stroke.    THANK YOU !!!    I am betting that will also solve the FLDIGI issue as the audio also needs to be set to PC, I am sure.
I will check that shortly.     Very Best, Jim
Photo of James Del Principe

James Del Principe

  • 278 Posts
  • 28 Reply Likes
I turned on remote so that the headset works plugged into the laptop. It is my understanding that this is necessary.   In any event it works for receive but not transmit audio. I have a USB heaset for phones and mic. The mic audio is recognized by Windows so that much works.

Perhaps I need to switch off remote for FLDIGI to work but that also receives well with Remote on.
I have tried so many combinations, I am frankly confused. 

The network is this: The Flex 6500 and the PC it works with are both plugged into a switch in the shack.    The laptop works via WiFi (wireless) to my DSL modem/switch which is connected via ethernet (copper) to the switch in the shack. Pretty straightforward.    It mostly works well as I have CAT control of the Flex for mode, frequency and more.

It seems transmit audio is the issue.    Thanks for the fast replies.    Jim
Photo of James Del Principe

James Del Principe

  • 278 Posts
  • 28 Reply Likes
See my reply to Dave, NX6D.    His advice was correct.      Thanks to all, Jim
Photo of NX6D Dave

NX6D Dave

  • 303 Posts
  • 91 Reply Likes
This doesn't explain the DAX channel problem.  Although it can be confusing, the DAX channels are controlled differently from the conventional audio channels.

In the case of the digital mode programs, check your configuration and verify that the Slice Receiver that holds the Transmitter has a DAX channel selected for input, and that DAX is selected as the audio source going to the transmitter.  It's messy.  One is a drop-down from the Slice Receiver flag (all of this is in SmartSDR for Windows), the other is a push button in the P/CW sub-panel.
Photo of James Del Principe

James Del Principe

  • 278 Posts
  • 28 Reply Likes
Dave, as of late last night I was still battling the FLDIGI/DAX issue.  I finally went to bed and will resume today. Thanks again for your input.   
Right now I have phone working in AM and SSB (into a dummy load so as not to cause interference) AM can be switched with MOX but SSB can only use VOX and not MOX, Not sure why but it may be normal. I would prefer manual switching of T/R but can live with it.

Today I will review settings and config for FLDIGI and check once again for the DAX selections, although I did enable DAX (channel 1) on the slice flag, on the left hand selections and on the P/CW sub panel.
I will also disable the "remote" button (which is not remote operation but PC speakers in rel 1 systems)
 I love a challenge.   73, Jim
Photo of James Del Principe

James Del Principe

  • 278 Posts
  • 28 Reply Likes
OK, there is a happy ending to all this. First, thanks to Dave, NX6D whose info really helped.   It really is possible to have FLDIGI work on a laptop on a wireless connection as well as Phone.

If anyone would care to know and save hours of grief, here it is:
1. DAX ch 1 on slice flag
2. DAX enabled on P/CW panel
3. PC selected as audio source on P/CW (very important - Thanks, Dave)
4. VOX selected on PHNE panel - VOX level should be set low so mic on headset does not trigger transmit.
5. Equalizer off for digital.
6. On DAX panel, set Tx Stream, Tx gain so as not to overdrive.
7. In FLDIGI, RIG/RIG CAT - need proper rig description file (of course)
8. Device: I used com 5 & 38400 baud.
9. Audio/devices capture: DAX Audio Rx1 ( FRS Dax audio) & playback: DAX Audio Tx (FRS DAX Tx)
10. Remote button must be on to use the USB headset on a laptop - top right on release 1.11.12
11. In all modes, audio source is PC & VOX must be on to transmit.

I realize this may be old hat for some but this is what worked in the end. Some replied this could not be done remotely.....   YEP, it can.

I set a global profile for AM, SSB and digital; something I had never tried before. It is a time saver and avoids potential errors.

Hope this helps someone.     73 to All,   Jim     KD1I 
Photo of James Del Principe

James Del Principe

  • 278 Posts
  • 28 Reply Likes
PS.  Just to prove it works, I just had a very nice PSK QSO with a station on a small island in Alliance Ohio running 25 watts using a tractor battery. He carried his rig to the island on his kayak !!
My typing was very rusty but it worked !!!     73, Jim
Photo of James Del Principe

James Del Principe

  • 278 Posts
  • 28 Reply Likes
The story continues.   I am now able to use my laptop for remote operation for AM, SSB and FLDIGI. However, I got an ugly surprise this morning when I tried to use the Flex with my PC in the shack. Now I can receive and key a carrier but try as I may, I cannot transmit any modulation.   The mic is selected as the source of audio and when I ht the PTT on the mic, I get carrier only but no modulation.   (AM) Back to the drawing board, I guess.     Jim
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3478 Reply Likes
You have to click the DAX button on the P/CW panel on the right-hand side of SmartSDR -Win. And make sure the DAX TX channel is enabled in the DAX control panel.
Photo of James Del Principe

James Del Principe

  • 278 Posts
  • 28 Reply Likes
Tim, Thanks for your input but I passed that point long ago.   It does not modulate for phone when used on the PC which is connected to the Flex in the shack via copper to a switch. All other functions work fine from both computers. After getting the Flex to work with my laptop via wireless, my local PC no longer will modulate a carrier. The laptop audio input is set to PC and the local  PC is set to mic as the mic and headphones are connected to the 6500 directly.  I will need to dig into it further today. Thanks for the reply.  Jim