Dax "stuttering" since 1.3.8 SSDR install

  • 4
  • Problem
  • Updated 5 years ago
  • Acknowledged

Since updating to 1.3.8 I am experiencing some "Stuttering" in Dax RX that seems intermittent and perhaps related to throughput in the network. Here are some particulars:

Running Flex 6300 usually with one panadaptor and 1 slice.

Quad core intel chip and motherboard SSD and PCIE Video HDMI to Monitor.

    Uninstalled old version of SSDR, Dax, And CAT. Rebooted and confirmed removal.

     Installed 1.3.8 with new Dax and Cat. Updated wireless card from a 54 mb to a 350 mb wireless card, dual band. No issues with previous version of SSDR or Dax or Cat.  New Version I have noticed a bit of a "Stuttering" in the Dax Audio RX which has been coming and going, sometimes correcting itself and sometimes been correctable by clicking Dax off then back on from the Dax Console. It seems also to be related to the network throughput because it happens a Lot less at 300 mb than when I first ran the new version with the 54 mb card.   Any Thoughts?  tnx in advance.

Photo of Jim  KJ7S

Jim KJ7S

  • 184 Posts
  • 33 Reply Likes

Posted 5 years ago

  • 4
Photo of Bob Wright, N7ZO

Bob Wright, N7ZO

  • 279 Posts
  • 76 Reply Likes
Hi Jim,

This sounds like the same thing I have been experiencing and has caused me to drop back to 1.3.0, which does not have this problem. (Digital apps would not decode well with the repetitive stuttering.)

My DAX RX audio stuttering sometimes corrected itself, but mostly I had to toggle the blue channel enable button on the DAX panel to correct it.

I have already sent an email with a sample mp3 file to Steve, but have not heard anything back.

It would be interesting to hear how many others are having this problem.
Photo of Jim  KJ7S

Jim KJ7S

  • 184 Posts
  • 33 Reply Likes
Yes I believe it is the same Problem. What I found odd was that it seemed to do much better with the BWidth increase when I changed to the faster N card but especially odd that it was apparent in 1.3.8. but not 1.3.0.
Photo of Peter Kirsop

Peter Kirsop

  • 36 Posts
  • 4 Reply Likes
I too have this issue with DAX. I can also clear the problem with stopping and restarting DAX but the stuttering soon returns. I have ended up feeding audio to the PC via cable. Really hope this problem goes when 1.4 is released. Using a 6300 with Dell optiplex 790 i5 / 8GB. 6300 is connected via router and otherwise works well.
Photo of np2g

np2g

  • 271 Posts
  • 30 Reply Likes
Do not have this issue.
However I did use REVO to remove the old issue Flex programs.  It did locate and ask to delete the DAX Driver . Which I obliged . Re install was clean ..

Possible solution ???
Photo of DrTeeth

DrTeeth

  • 1687 Posts
  • 389 Reply Likes
I did a straight upgrade and no problems. Possible solution?
(Edited)
Photo of Iain McLachlan

Iain McLachlan

  • 39 Posts
  • 2 Reply Likes
I have just the same. Toggling the channel off and on clears, but not for long. Audio is fine via headphones. Glad to see this thread, I've been ripping up the place thinking that it was my setup.

Using fast i7 PC with a new Win 7 install, done only last week.
(Edited)
Photo of Dick / KC9YRA

Dick / KC9YRA

  • 11 Posts
  • 3 Reply Likes

I too have this problem with DAX on V1.3.8. Switching back to V1.3.0 the problem does not appear. I have a Flex 6500 that can run on 2 different computers (Laptop i7-3612QM and Desktop i7-4790) both running Win 7 Home Premium. Each connected directly to the radio when in use. Clicking off/on the DAX blue channel button clears the problem temporarily. The panadapter/waterfall does not appear to be distorted. Neither is the rear audio out or headset distorted. Changing DAX to channels 2, 3 or 4 corrects the problem only for a short period of time. Strong received signals seem to trigger or the problem only appears with strong signals.

I use WSJT-x v1.3.  Attached are 2 pictures of how this looks on the WSJT-x wallfall. It does affect the decode process. In the first pic at timestamp 00:03 bottom and 00:04 see the fallwall distortion. During 00:05 I clicked DAX 1 off/on distortion disappears. Second pic timestamp 00:09 distortion starts near the end of the minute 00:09. Hope this gets resolved with the 1.4 release as I use digital modes primarily. I will probably downgrade to SmartSDR 1.3.0 until then.

Photo of Bob Wright, N7ZO

Bob Wright, N7ZO

  • 279 Posts
  • 76 Reply Likes
Hi Dick,

Nice screen captures.  Your WSJT-X images of the stuttering spectrum match mine.

I think the reason the problem seems to be associated with stronger signals is that the stutters are signal dropouts (brief periods of zero audio).  The higher the signal audio amplitude, the more audible the difference between the audio and the dropout.  But the dropouts are still there even when the audio is weaker, just not as audible.  Crank up the volume and you will still hear them.
(Edited)
Photo of WA6FXT Mike

WA6FXT Mike

  • 223 Posts
  • 39 Reply Likes

I haven't seen stuttering with DAX Rx; but, I have been noticing a stutter, during Tx. At least when running WSJT-X or the two  of the normal JT65-HF v109.


Anybody else seeing this?


Mike

Photo of SteveM

SteveM

  • 273 Posts
  • 44 Reply Likes

Mike,

The Tx stutter is a continual problem for me. Drives my QSO's bonkers. I love my 6500 and I'm sure it'll get ironed out in due course but, in my opinion, it is wayyyyyyyy too easy to experience bad audio from this rig (either direction). I mean, what is the single most important function of a radio other than providing a rock-solid foundation for basic audio transmission, for Pete's sake? Hint to Flex developers, set the entire audio path at a higher priority than the spectrum/waterfall priority.

Anyway, if you are having issues with stuttering Tx, there are 2 problems I have found to cause this. Note that my setup involves routing headset audio from the PC using DAX (LAN remote operation). If your setup is different, this information may not apply to you.

1. Make sure you have a fat pipe between the PC and the radio. I had a network-switch issue that caused the PC network connection to silently down-shift to 10Mb/s which is simply not fat enough - even for a single panadaptor.

2. Make sure your PC is not CPU bound. My PC is running with the minimum recommended CPU, a Core2Duo. When I operate, SSDR is the only process that contributes significant CPU load - a load that averages approximately 50% (receive only) with the default panadaptor refresh rates. In my opinion the Core2Duo is marginal, at best, even for single panadaptor operation. Before I transmit I have to drop the frame rate of the spectrum graph to <10 and drop the waterfall update to 0, otherwise, I run the risk of DAX dropping a significant percentage of the Tx frames.

Here's a test you can perform, grab the spectrum display with your mouse and move it back and forth. When I do that, the CPU utilization spikes to 100%, received audio experiences massive frame drops, and the spectrum display itself goes wonky.

Yet, another test. While you operating, open the DAX control window. When I open the window, the CPU spikes and massive frame drops occur.

I have borrowed a graphics card from a buddy and will install it to see if that will relieve a good portion of the processor load (I have integrated graphics right now). If not, then I guess my only choice, at this point, is to burn more cash on a better PC. However, someone on this forum mentioned a future release that would mitigate DAX for remote operation. Even if that is so, I don't think that would help you in digital modes.

(Edited)
Photo of Howard Koenig

Howard Koenig

  • 24 Posts
  • 1 Reply Like
Im seeing this as well on the receive side. It is most noticeable when I'm using audio from a remote computer using Skype. This did not occur with the last version.
Photo of Ed, K0KC

Ed, K0KC

  • 287 Posts
  • 20 Reply Likes
Just to chime-in, I have seen this as well starting with 1.3.8. The quickest way to clear the behavior is to click the blue channel number in the DAX Control Panel off and then back on quickly.

Ed, K0KC
Photo of SteveM

SteveM

  • 273 Posts
  • 44 Reply Likes
I have this problem, as well (had to switch back to 1.3.0). I would describe it as a pitter-patter noise when the signal is strong. If I were forced to speculate, I would say that it sounds like the digital AGC algorithm is not stable. Maybe the loop gain is too high and/or the update rate is too slow?
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9186 Posts
  • 3550 Reply Likes
Official Response
I have entered this report in our bug tracker for further investigation.  Thanks to everyone for their report.
Photo of Jim  KJ7S

Jim KJ7S

  • 184 Posts
  • 33 Reply Likes
Thank You Tim. I was like some of the others in that I was tearing into the shack to see if I had something specific to fix here but to no avail. I hope your "troubleshooters" can replicate the problem as the others have here and get er fixed... Jim  KJ7S
Photo of Dick / KC9YRA

Dick / KC9YRA

  • 11 Posts
  • 3 Reply Likes

Update to my earlier reply.  I went to the Windows Control Panel, Sound setup, Recording tab, Selected DAX Audio RX1 properties, Selected Listen tab, Checked Listen to this device. When I see the distortion in the WSJT-x waterfall I hear the DAX audio being interrupted or pulsing about 3-4 times a second. This can also be heard on the audio of all signals (SSB CW RTTY PSK) whether selecting DIGU or USB modes AGC set to OFF. When cycling off/on the blue DAX 1 button, all audio on DAX RX1 is clear and uninterrupted until next distortion period begins. Good news is this DAX problem does not affect the transmit audio. I have listened to the DAX transmit audio and it is appears to be clean.

I have audio recordings (.wma format) of this DAX problem. If Flex needs these recordings contact me through my email address I will provide them.

Photo of Iain McLachlan

Iain McLachlan

  • 39 Posts
  • 2 Reply Likes
EDIT 

It seems that I can do a full install then run the older version from its directory.

How do I downgrade the "SmartSDR DAX"? I've tried the SmartSDR_v1.3.0 Installer but the options, though shown, are greyed out, so I cannot deselect SmartSDR and CAT.

http://oi60.tinypic.com/1z65n49.jpg

Thanks.
(Edited)