DAX problem

  • 2
  • Problem
  • Updated 8 months ago

DAX problem...Flex6500, DXLab Commander, WSJT-X all worked
perfectly until a few days ago...            then
the following screen shots occurred and WSJT-X
no longer Receives signals
...

Software – SDR v. 2.4.9, Windows 10 Pro with latest updates

Windows – Sound – defaults:  Recording:  DAX Audio RX1, Playback:  Speakers/Headphones

Control Panel – Device Manager – Audio devices show the correct 28 total DAX entries and NO            hidden entries...

DAX files have been removed and reinstalled multiple times without success...

SmartSDR has been completely removed and reinstalled multiple times without success...

DAX panel shows TX and RX streams working, but IQ Streams with Driver Error

WSJT-X - Settings – Radio, Test CAT and Test PTT work correctly

Help!!  Could there be some residual Windows Registry fragments that are causing this?

Thanks for any advice, Mike, K6DRY

Photo of Michael Reid

Michael Reid

  • 14 Posts
  • 1 Reply Like

Posted 8 months ago

  • 2
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1404 Posts
  • 307 Reply Likes
Hi Michael,

Looks like you are the victim of a Windows 10 update.

Please follow the steps in this post by Neil, K3NC. It will straighten out the DAX drivers.
https://community.flexradio.com/flexradio/topics/most-common-fix-for-dax-driver-errors-in-windows-spring-update-1803-you-can-do-this 

73 
Dave wo2x

Photo of YV5WZ

YV5WZ

  • 415 Posts
  • 50 Reply Likes
Show me CAT shoot screen

Thanks

George
Photo of Craig - KØCF

Craig - KØCF

  • 201 Posts
  • 69 Reply Likes
The answer is in what you wrote about Windows sound defaults. DAX devices must NOT be Windows default devices. This is what produced the DAX driver error: It was being used by Windows and is not available to WSJT-X.