DAX driver error

  • 2
  • Problem
  • Updated 3 years ago
  • Solved
Brand new PC, Win 10 64 bit, SSDR 1.7.30.  Using in conjunction with Log4OM, OmniRig, VSP Manager, WSJT-X and JTAlertX, all latest versions.  Flex 6500.  Initially worked nicely with digi modes (any initial issues due to me not being extra careful with file locations after migrating the old Log4OM database and settings and reconfiguring LOTW).

For several days following the new install all seemed fine but now I receive a report on boot up, even before loading SSDR, advising that “an error has occurred while trying to open a DAX sound device”.  Seems this is a fairly common problem.

Sometimes DAX works OK and WSJT-X, etc. are fine, although I still get a “Driver Error” in the Mic Stream setting in the DAX control panel.  Other times, nothing works and in the DAX control panel TX Stream:  Not connected.  Mic Stream:  Driver Error.  RX Stream 1:  Not connected. 

I’ve removed then reinstalled SSDR numerous times (including removing the DAX drivers), installing both as Administrator and not.  I’ve tried using SSB into a dummy load and using the monitor function it sounds find thru my headphones.  That’s despite the Mic Stream showing a driver error.  It is inconsistent.

One of the annoying things is that it was working perfectly for several days, then decided not to play ball.  Usually uninstalling and reinstalling, rebooting solves most of these inexplicable errors, but not in this case.  It may be associated with a Windows ‘Sound’ setting, I’m not sure. 

I know this has come up before and looking back thru earlier posts I’m not sure what is the definitive solution...

Any suggestions welcome!

Jeff – G4IUA

Photo of Jeff - G4IUA

Jeff - G4IUA

  • 137 Posts
  • 16 Reply Likes

Posted 3 years ago

  • 2
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9197 Posts
  • 3557 Reply Likes
Official Response
I have converted this topic to a support HelpDesk ticket (http://helpdesk.flexradio.com) for expedited issue resolution.  If anyone else is experiencing an issue similar to this one, please submit a HelpDesk support ticket for issue resolution.
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1465 Posts
  • 310 Reply Likes
Official Response
Here is the solution for anyone who runs into problems in the future.
We found both DAX and CAT issues.

CAT - VSPManager and FlexVSP were both installed. We did a complete uninstall of SmartSDR, CAT, and DAX as per the Help Desk article, I opened VSPManager and deleted all virtual port pairs then uninstalled VSPManager. Rebooted PC.

I cleaned phantom audio devices and serial ports from Device Manager and rebooted the PC.

I then installed SmartSDR 1.7.30.
After installing I found the SmartSDR DAX MIC Audio device would not install. I finally used this procedure to force the driver to install in Windows 10 x64:

Open an elevated command window Run hdwwiz.cpl to start Device Manager
Click Audio inputs and outputs
On top click Actions
Click Add legacy hardware
Click Next
Select Install the hardware that I manually select from a list
Click Next
Scroll down and select Sound, Video and game controllers
Click Next
Click Have disk
Browse to the folder with the driver INF (example C:\Program Files\FlexRadio Systems\SmartSDR v1.7.30\64-bit Drivers\MICAudio_DAX
Select the inf file (example SmartSDR_MICAUDIO_DAX.inf) and click Open
Click Next
Click Next to install driver
Click Finish

Dave wo2x