DAX Driver error

  • 3
  • Problem
  • Updated 3 months ago

Hi

I’m having problems with the DAX. It’s coming up an error message that says: DAX Driver Error. I went to the 64 bit drivers carpet and uninstalled the drivers and re installed them back and the error keep coming up. I have the version 3.0.27 and Windows 10. If someone can help me will be well appreciated.

Thanks 73



Photo of Alfredo

Alfredo

  • 19 Posts
  • 0 Reply Likes

Posted 3 months ago

  • 3
Photo of Jim Gilliam

Jim Gilliam

  • 939 Posts
  • 218 Reply Likes

This seems to be the most common problem with SmartSDR. Almost every day, I see the same post as yours. Frequently this problem is caused by Windows updating and not y naming the audio ports correctly. There seems to be a variety of cures the most common being reinstalling SmartSDR but there might be easier remedies. Also, many people end up resorting to the help desk to resolve the damnable recurring problem.


Jim, K6QE
(Edited)
Photo of N5LB - Lionel B

N5LB - Lionel B

  • 224 Posts
  • 63 Reply Likes
Alfredo, take a look at this thread where there is a lot of discussion of how to fix.  I beleive W10 somehow mangles the DAX driver names, and this is what has to be corrected.  There are several approaches that I've seen.  Do a search for the thread, last post a couple of weeks ago.

"DAX error after Windows Update 1907 and upgrade to 2.5.1"
Photo of k3Tim

k3Tim

  • 924 Posts
  • 195 Reply Likes
What Lionel said is correct. The direct link is:
https://community.flexradio.com/flexradio/topics/dax-error-after-widows-update-1907-and-upgrade-to-2-5-1?

If the DAX device names in the sound panel are incorrect, then one can do a simple edit to correct them. In sound panel, right select -> properties.  Check Eric post for details.

Upgraded two Win 10 PCs and had to do this correction; took all of two minutes.
Good Luck, and if you need further help let us know.
Photo of Alfredo

Alfredo

  • 19 Posts
  • 0 Reply Likes
I have done every recomendations found and the error still coming up. I will have to send a ticket to Flex. Thanks to everyone for sending some help. 73'
Photo of Dudley - WA5QPZ

Dudley - WA5QPZ, Elmer

  • 219 Posts
  • 33 Reply Likes
Alfredo,

Make sure that your Windows Sound Properties is set to the correct input/output devices . No DAX devices are flagged ( with a green check mark) as a default sound device . Then if you have to correct, always reboot after making changes just to make sure it’s not changing from rebooting, I would maybe suggest you uninstall SmartSDR, BE SURE to remove and not save the DAX drivers, reboot again and then re-install SSDR , check to make sure that the default sounds are still correct. This corrects manY of the DAX issues unless there are windows registry issues causing incorrect DAX devices being applied to an incorrect driver.

Sometimes Windows even straightens it out with additional reboots, there is some AI involved in the OS.

Flex Help Desk can also help, so don’t get frustrated..

Dudley
WA5QPZ
Photo of Alfredo

Alfredo

  • 19 Posts
  • 0 Reply Likes
Hi Dudley

Here at the playback I have as default speakers. In recording I have a DAX as default but I don't know how take that green checkmark off. Maybe that is what is making the error on the driver. Thanks for all the help you're giving. If you  know more info I'll receive it. Thanks!


Photo of k3Tim

k3Tim

  • 925 Posts
  • 197 Reply Likes
You can't uncheck a green flag (default device) but instead have to select some other device as the default.  
Photo of Alfredo

Alfredo

  • 19 Posts
  • 0 Reply Likes
I made a ticket and Flex already fixed the issue. Thanks everyone!