DAX and CAT applications now available for macOS

  • 14
  • Praise
  • Updated 1 year ago
Hi there,

since I’ve got my Flex-6300 last year I missed an equivalent for SmartCAT and SmartDAX on macOS. Using Dougs (K3TZR) xFlexAPI framework for macOS I have written these tools for myself and want to share them with the community.

The apps are called FlexDAX and FlexNetCAT and you can find them in image files (.dmg) here:

FlexDAX:
https://drive.google.com/open?id=0B0diG65rZz0yYmlvOHVxbWx2VEU

FlexNetCAT:
https://drive.google.com/open?id=0B0diG65rZz0yeVFrSjZSOGw2Zjg


The image files include a short PDF document which should help you in setting up and using these applications. Please read these documents to learn about the differences to the equivalent apps for Windows and if they will help you in your operating style and environment.

The applications need macOS 10.10 (Yosemite) or higher.

I hope you’ll find them usefull...

73, Mario DL3LSM

P.S. I don’t want to praise myself but this is neither a question nor a problem or idea. So... :-)
Photo of Mario - DL3LSM

Mario - DL3LSM

  • 68 Posts
  • 29 Reply Likes

Posted 2 years ago

  • 14
Photo of Mario - DL3LSM

Mario - DL3LSM

  • 68 Posts
  • 29 Reply Likes
Hi there,

as the new radio models are shipping I tried to anticipate what changes are needed to make xCAT and xDAX usable with these models (FLEX-6400(M), FLEX-6600(M)). As I don't have one of these models and I don't know someone who has and is a Mac user tI could not test these changes.

So if you are using one of the existing models there is no need to change but if you've got one of the new models it is worth a try (and please report your success/failure to me per Email). As there are no real changes I have also not updated the documentation (there is a major change in the works).

There were some reports in the community that existing versions of WSJT-X (on Windows) would not work with the new models. I guess this will be the case on macOS as well as the Hamlib version used in WSJT-X 1.8.0 does not recognize the IDs of the new models. In xCAT you can work around this if you set "Mask Flex-6300" in the "Setup" menu. With this your Flex will id as a FLEX-6500 to an asking CAT client application.

The new versions are as always available on my Blog: http://dl3lsm.blogspot.de/

Thanks and 73
Mario, DL3LSM
(Edited)
Photo of Kevin Williams - WM4J

Kevin Williams - WM4J

  • 4 Posts
  • 3 Reply Likes
Mario,

I'm using xCAT and xDAX with my 6400M / DPSDR and it works as expected with Fldigi and WSJT-X. Like you mentioned in your post I did require the "Mask Flex-6300" setting for WSJT-X.

Thanks,

Kevin (WM4J)
Photo of George Molnar, KF2T

George Molnar, KF2T, Elmer

  • 1680 Posts
  • 616 Reply Likes
Mario - same good results here. Running on a 6600 without difficulty, both xDAX and xCAT. Nice work!
Photo of Mario - DL3LSM

Mario - DL3LSM

  • 68 Posts
  • 29 Reply Likes
Great, thanks for the feedback!

73, Mario DL3LSM
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1468 Posts
  • 311 Reply Likes
Hi Mario,

I have recompiled the Windows version of WSJT-X to include the updated changes to Hamlib which supports the new models as well as 6300, 6500, 6700.

Maybe someone familiar with compiling for the Mac can do the same? As long as they pull the latest version of Hamlib it should work.

The new version of WSJT-X which includes DXPedition mode will be out in the near future and should include these Hamlib changes.

73
Dave wo2x
Photo of Mario - DL3LSM

Mario - DL3LSM

  • 68 Posts
  • 29 Reply Likes
Hi Dave,

yes, I have seen that you recompiled WSJT-X.. As I don't have (and want) a Qt environment on my Macs it's unfortunately not possible for me to recompile. But the "Mask 6300" option works well as it just changes the ID response to WSJT-X to the ID of an 6500. Internally xCAT knows what radio it is connected to. So it's a simple workaround until the new version is released.

Thanks and 73
Mario, DL3LSM
(Edited)
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1468 Posts
  • 311 Reply Likes
Excellent! No need for modified version of WSJT-X 1.8.0

Dave wo2x
Photo of Mario - DL3LSM

Mario - DL3LSM

  • 68 Posts
  • 29 Reply Likes
Hi there,

this post should have come 3 months ago but a long unplanned stay in hospital and the following regeneration delayed this release.

There are new versions of my apps available. The main addition to the apps is that they now support remote operation via SmartLink.



There are minor bug fixes as well but I did not keep a change log.

You can find the details about how to use SmartLink in the updated documentation.

The new versions are as always available on my Blog: https://dl3lsm.blogspot.de/

Thanks and 73
Mario, DL3LSM
Photo of George Molnar, KF2T

George Molnar, KF2T, Elmer

  • 1680 Posts
  • 616 Reply Likes
Thanks, Mario. Glad you’re recovering, my friend!