CWX F- Keys not working

  • 1
  • Question
  • Updated 1 year ago
In use  SmartSDR v1.10.16, CWX 
When hitting F1 . Key Google is startet and not defined Macros like cq cq cq 
Whats wrong , how be cured ? 
73 Uwe, DK1KQ
Photo of DK1KQ

DK1KQ

  • 13 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of Steve Jones

Steve Jones

  • 104 Posts
  • 23 Reply Likes
Sorry Uwe, i am not getting that problem here so cannot help. I dont often use cwx direct but i did use the f1 cq memory on 6m last weekend and it did work ok for me and using same version ssdr. Hope someone more ict techie can help you
Photo of DK1KQ

DK1KQ

  • 13 Posts
  • 0 Reply Likes
Hi, I guess it has nothing to do with Smart sdr because it worked before a win up date was done.
73
Uwe

In Meantime - I got ist . On my keyboard Fn + F12 solved the problem
(Edited)
Photo of Alex - DH2ID

Alex - DH2ID, Elmer

  • 891 Posts
  • 166 Reply Likes
Uwe, the F1-Key is not used exclusively for SmartSDR, it can be "pirated" by other programs.
Reboot, start SmartSDR only and retry. Hunt for other programs which might use the function keys.
73, Alex - DH2ID

Uwe, die Funktionstaste F1 wird nicht nur von SmartSDR benutzt, auch andere Programme
können ihn für sich vereinnahmen. Starte den Computer und SmartSDR neu und suche evtl. nach
weiteren Programmen, die die Funtionstasten benutzen können.
Du kannst mich auch jederzeit unter dh2id@darc.de kontaktien.
73, Alex - DH2ID
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 3971 Posts
  • 1226 Reply Likes
The CWX Function keys only work if SSDR is the program "in focus." If another program window is the "active one, then the CWX Function keys will not work. The currently active window's function keys will take over.

As Alex said, other programs or utilities may have redefined the F1 key so that it won't work even when SSDR is the active window.

This can be esepecially confusing when you have one set of CW macros set in CWX, and a different set in your logging program (such as N1MM). The Function keys will sent different messages depending upon which program's window is "active."

Good luck.

Ken -NM9P