CWX always transmits

  • 1
  • Problem
  • Updated 3 years ago
I am using Flexlib 1.4.16 with a Flex 6300.  I expected CWX.Send to send only if .Breakin is true, but it always transmits.  If I key down, using a key for example, and .Breakin is false, I don't actually transmit.  I would expect CWX to work the same way.
Photo of Jim Shaffer (KE5AL)

Jim Shaffer (KE5AL)

  • 37 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of W7NGA

W7NGA

  • 404 Posts
  • 166 Reply Likes
Good observation Jim. I had never noticed, but as you say, it seems beneficial to be consistent with keyer behavior, I suppose one could make the argument that using it for code practice ... turn power to zero.
Photo of Eric - KE5DTO

Eric - KE5DTO, Official Rep

  • 697 Posts
  • 205 Reply Likes
The Break In option only affects the physical Key input on the radio.  CWX always transmits if directed to do so in CW mode.

There are other ways to temporarily disable Transmit if this is the goal like unchecking the TX on the Slice control so there isn't a Transmit Slice defined.

If there is a use case where this isn't sufficient, please give us the details so we can improve the design.  Thanks for your input.
Photo of Jim Shaffer (KE5AL)

Jim Shaffer (KE5AL)

  • 37 Posts
  • 0 Reply Likes
I guess what I'm expecting is that it should work like the key works if I turn Breakin off (False).  Changing this would pose a backward compatability problem though.  How about adding something like a CWX.MonitorOnly property?  This would go through the monitor but not transmit.
Photo of Eric - KE5DTO

Eric - KE5DTO, Official Rep

  • 697 Posts
  • 205 Reply Likes
For monitor only or practice mode, I would suggest just turning the RF Power down to 0 and send away.