corrupt source file warning 2.0.19

  • 1
  • Problem
  • Updated 9 months ago
  • (Edited)
New system running Windows 10 and during install of SmartSDR 2.0.19 I get an error "C:\ProgramData\FlexRadioSystems\SmartSDR\Updates\FLEX-6x00_v2.0.19.98.ssdr" ... an error occurred - "the source file is corrupted" - abort, retry, ignore.

This happens whether Windows Defender or installed ESET antivirus is active or not.  Searched forums and not finding anything.  Any suggestions?

Update 1:  Tried "Run as admin" with no changes.  Directory path exists with no files in "Updates" folder noted above.

Cheers,
Rob - NR3O
Photo of Rob Salsgiver

Rob Salsgiver

  • 13 Posts
  • 4 Reply Likes

Posted 9 months ago

  • 1
Photo of Michael Coslo

Michael Coslo

  • 812 Posts
  • 195 Reply Likes
Did you try downloading the install file again Rob?
Photo of Rob Salsgiver

Rob Salsgiver

  • 13 Posts
  • 4 Reply Likes
3 or 4 times.  I  noticed the first couple of times I was downloading in Firefox and it hung about 2/3rds the way through.  I was able to resume the download and have it complete.  Both copies of the download that way had the unpacking error during install.  For giggles I downloaded (uninterrupted) in Chrome and that one had the same issue unfortunately. 
Photo of Rob Salsgiver

Rob Salsgiver

  • 13 Posts
  • 4 Reply Likes
Can't say I "solved" the problem, but at least managed to resolve it.  I had previously downloaded a forgotten copy of 2.0.19 onto my laptop, which is a separate computer from the new desktop I was having the problem I described above.

On a whim I copied THAT install file over to the desktop and it appeared to install fine.  Still don't know why the multiple copies downloaded directly to the desktop yesterday had the problem, but I at least got it up and going!

Cheers,
Rob
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9149 Posts
  • 3467 Reply Likes
The firmware file was corrupted.  The correct course of action is to re-download it and reinstall with a good version
Photo of Tim - G7GFW / F4VQP

Tim - G7GFW / F4VQP

  • 114 Posts
  • 38 Reply Likes
One observation - do NOT run 2 anti virus packages at the same time - it can cause havoc with the best system. I spent several years working in the anti-virus world for Dr Solomon and one of my jobs was test AV software from all the different makers so I know a little bit about the subject. I use Windows defender as an AV package and Malwarebytes for anything that is not considered a virus. 

Tim
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9149 Posts
  • 3467 Reply Likes
 I use Windows defender as an AV package and Malwarebytes for anything that is not considered a virus

Ditto.
Photo of Peter K1PGV

Peter K1PGV, Elmer

  • 541 Posts
  • 315 Reply Likes
What G7GFW said: Two A/V programs can cause trouble. In this case, two is definitely not better than one. File system filter drivers (which is what A/V programs use) can be complicated beasts to write correctly, and numerous A/V vendors have interop issues.

Find an A/V program you like and trust it. Reevaluate your choice every few years, because the programs and threats change. I’ve switched to BitDefender recently for my home systems, and find it very good. YMMV.

Peter
K1PGV
Photo of NX6D Dave

NX6D Dave

  • 296 Posts
  • 83 Reply Likes
Is the C drive in this system a spinning disk, or an SSD?
Photo of Rob Salsgiver

Rob Salsgiver

  • 13 Posts
  • 4 Reply Likes
Interestingly enough, the C: drive on the desktop (the one that had the original problem) was an SSD, and the laptop has a traditional spinning disk. 

I ended up copying the install file from the laptop/spinning disk onto the desktop/SSD, and THAT copy worked fine.  Go figure!

Cheers,
Rob