Configure for JTDX

  • 1
  • Question
  • Updated 2 years ago
  • Answered
Hi all
I have a problem which I cannot solve. Set up is Flex 6500, Win10 and JTDX.
I can receive JT65 OK, but when I want to transmit, JTDX will key the rig and put it on transmit, but there is no power output.
I previously did manage to make it work, but for some unknown reason, the global setup was lost.
I belive there are conflicts in Win10 with sound cards that get modified under some circumstances, but I could not detect which.
Anyone can help please ??
Photo of Paul F6EXV

Paul F6EXV

  • 37 Posts
  • 1 Reply Like

Posted 2 years ago

  • 1
Photo of Robert White

Robert White

  • 3 Posts
  • 0 Reply Likes
Did you turn DAX on? Is a channel streaming data?
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4025 Posts
  • 1248 Reply Likes
Check these things:

Dax button ON,
In Dax control panel - DAX TX Stream ON,
In tx panel - mode = DigU
Tx bandwidth = 25 to 3000 Hz, or 25 to 5000 Hz.
Check that the Dax tx audio stream meter is showing audio when you transmit.

In WSJT - make sure that your transmit audio device is set to the DAX TX Stream. The audio device associations sometimes get hosed whenever Windows 10 does an update, and you need to check that they are assigned correctly.

Do NOT use any of the RESERVED Dax channels.

I WSJT - check the level of the power output slider.
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4025 Posts
  • 1248 Reply Likes
Also, are you sure that it is keying the correct slice channel? Is the tx indicator active for the slice you are using?
Photo of Paul F6EXV

Paul F6EXV

  • 37 Posts
  • 1 Reply Like
Ken
DAX TX Audio is blue, but does not show audio when TX (goes TX but no output)
IQ Stream in Dax panel shows right frequency, but is red with a "driver error" message next to it.
I have slivce A on CAT com 4, shows process wsjtx and Audio Switch TX on.
Photo of Bill W2PKY

Bill W2PKY

  • 461 Posts
  • 79 Reply Likes
on JTDX app [right side] there is a power slider that is defaulted to very low power. I user full power slider setting.
Photo of Paul F6EXV

Paul F6EXV

  • 37 Posts
  • 1 Reply Like
Hi Bill
I have it full power too, to no avail
Photo of Alex - DH2ID

Alex - DH2ID, Elmer

  • 930 Posts
  • 172 Reply Likes
JTDX does not use the IQ stream. Use DAX audio in/out instead.
Photo of Paul F6EXV

Paul F6EXV

  • 37 Posts
  • 1 Reply Like
In JTDX setup, the input is DAX Audio RX 1, the Output is Dax Audio TX, both mono. I believe this is correct. In Windows Audio panel config, there are 2  DAX AUDIO RX 1 , one shows as default device, the other one cannot be modified and shows as "not connected"
(Edited)
Photo of Bill W2PKY

Bill W2PKY

  • 461 Posts
  • 79 Reply Likes
On the Windows Sound Playback tab check DAX Audio TX Levels control for 100%.
The TEST button on the Advanced tab should show up on the DAX Streaming channel Monitor.

When you transmit on JTDX the Windows Sound panel DAX Audio TX level display should light up green
Hope this helps
(Edited)
Photo of Paul F6EXV

Paul F6EXV

  • 37 Posts
  • 1 Reply Like
Slowly progressing, but one problem solved, one new problem ! Now my TX is fine (I do get power out), but I am getting no reception on JTDX (I see signals on the Flex).
The reception window on JTDX shows a repeated message saying "input signal low rms" (Windows Sound Card level is maximum)
Photo of Bill W2PKY

Bill W2PKY

  • 454 Posts
  • 79 Reply Likes
Check the DAX assignment in the slice flag is equal to the DAX channel in the JTDX audio tab. On the slice flag speaker icon check that you can hear the band activity in the ear phones. The level indicator on JTDX [right side] should be around 70. Use the AGCT slider on the slice flag to control the level on JTDX. Set DAX slider on DAX control panel to around 50.
Photo of YV5WZ

YV5WZ

  • 393 Posts
  • 48 Reply Likes
No signal on JTDX mean its not listening.....check Setting Audio.....but first check dax channel
Photo of Paul F6EXV

Paul F6EXV

  • 37 Posts
  • 1 Reply Like
Now, DAX channels don't work anymore (se above) ! I am getting fed up ! (with myself, but am grateful to you all trying to help me out)
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4025 Posts
  • 1248 Reply Likes
Your total RX slice DAX Channel needs to be on the same channel as the RX audio channel selected in jtdx settings.

Make sure your AGC-T is set so then you have good audio being received.

Make sure the same Dax channel is turned ON in the Dax control panel.

Make sure that there is audio showing in the meter for the same channel in the Dax control panel.

Turn the slider up in jtdx until receiver noise presents a 30 level on JTDX's level meter.

If none of this works, a windows update may have corrupted your Dax drivers.
Photo of Paul F6EXV

Paul F6EXV

  • 37 Posts
  • 1 Reply Like
I cannot do anything of the above, the whole DAX thing is not working now !

The very strange thing is the whole setup was working this morning (I made a contact on 6m). So I do not think a Windows update has anything to do with my problem.
Why am I now getting this DAX error message when booting Windows (it did not happen yesterday) ?

Should I uninstall DAX and reinstall ? If so, where can I find the installer (could not find it on the Flex download page)
(Edited)
Photo of Bill W2PKY

Bill W2PKY

  • 461 Posts
  • 79 Reply Likes
May need to refresh VSP driver. Windows updates have been known to corrupt the VSP drivers. Search the forum for instructions to restore VSP drivers.
Photo of Timo - OH5KW

Timo - OH5KW

  • 22 Posts
  • 0 Reply Likes
I just had same kind of problem. I tried to do various actions, but the help was new DAX channel. 
73, Timo OH5KW
Photo of Paul F6EXV

Paul F6EXV

  • 37 Posts
  • 1 Reply Like
It was working AFTER my latest Win 10 update.
Photo of Paul F6EXV

Paul F6EXV

  • 37 Posts
  • 1 Reply Like
Or let's go step by step.
In Windows sound panel configuration, which sound device should be the default ? If DAX, then how can I get sound for other programs (to listen to a youtube video for example). Which should be the communication default ?
Photo of Paul F6EXV

Paul F6EXV

  • 37 Posts
  • 1 Reply Like
When I go to my Windows sound car settings, I already have :

8 DAX Audio RX with a microphone icon in from of them (FRS DAX Audio)
8 DAX Audio RX with a two-plug icon in from of them (FRS DAX Audio - the # 1 is selected as default device)
8 DAX Audio RX with a little box in front of them
1 DAX Audio RX with a microphone in front of them (FRS DAX IQ)
2 DAX IQ RX with a microphone in front of them (FRS DAX IQ)
1 DAX RESERVED AUDIO TX with a microphone in front of it (FRS DAX IQ)
1 DAX Audio RX with a two-plug icon (FRS DAX IQ)
3 DAX IQ RX with a two-plug icon (FRS DAX IQ) (The # 1 scale on the right is moving up and down, in green color)
4 DAX Audio RX with a little box (FRS DAX IQ)
1 DAX IQ RX with a little box (FRS DAX IQ)
1 DAX MIC Audio with a microphone (FRS DAX MIC Audio)
1 DAX MIC Audio with a two-plug (FRS DAX MIC Audio)
1 DAX MIC Audio with a little box (FRS DAX MIC Audio)
1 DAX RESERVED AUDIO TX with a little microphone (FRS DAX TX)
1 DAX RESERVED AUDIO TX with a two-plug (FRS DAX TX)
1 DAX RESERVED AUDIO TX with a little box (FRS DAX TX)
1 "Microphone" with a little microphone (Realtek HD Audio)
1 Line In with a two-plug (Realtek HD Audio)
1 Stereo Mixer with a little board (Realtek HD Audio)

Why do I have 45 DAXes ? Do I need all of these ? Is this part of the cause of my problems ?
(Edited)
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4025 Posts
  • 1248 Reply Likes
Unless you are doing something via REMOTE with the remote button ON, you don't need to mess with Default Sound device and Default Communications settings in the Windows Sound panel.  

Those have to do with inputs and outputs of the Computer's own sound card.

Leave these defaulted to your computer mic and speaker devices.

DAX channels function in the same was as an ADDITIONAL sound device that you access directly, outside of the Windows Sound Panel. In effect, the 6500 has it own built-in sound card.  Actually several of them...(All those different DAX Channels)

When installed, the DAX Driver sets up a number of DAX Channels.  
Each DAX Channel is like a virtual audio cable, with two "ends,"  
  One end is the "Public" end (DAX AUDIO RX 1 through 8) that you connect to your digital program.  
The other is the "Radio" end (DAX RESERVED RX 1 through 8) which is what the radio connects to internally.

The whole list installed are as follows:

8 - DAX Audio RX (1-8) - (sends receive audio to outside programs, digital programs, etc.)
8 - DAX RESERVED AUDIO (RX 1-8) - (the radio end of those cables)
1 - DAX Audio TX - (the line used for input to the transmitter from your digital program)
1 - DAX RESERVED AUDIO TX - (The radio end of that TX input)
1 - DAX MIC Audio - (feeds your MIC audio, or whatever audio is being transmitted OUT to a computer program for recording - i.e. recording a contest Digital Voice Keyer)
1- DAX RESERVED MIC Audio - (The radio end of that cable)
4 - DAX IQ RX (1-4) - (wide-band I/Q audio data used by programs such as CW Skimmer)
4 - DAX RESERVED IQ RX (1-4) - (the radio end of those cables)




Where you need to Select your DAX devices is in the JTDX program itself.  


Set the INPUT to the DAX Audio RX Channel you prefer...Here it is set to Channel 1.  Which you also need to select on your Slice, and check that it is turned on in your DAX Control Panel.

Set the OUTPUT to the DAX Audio TX Channel.  and make sure that it is turned ON in the DAX Control Panel, and that the DAX button is ON in the TX Panel of SSDR.

Again...Do NOT use RESERVED Channels.  They are RESERVED for the Radio's internal use.

And don't mess with the Windows Sound Utility (The Record and Playback menus accessed with the little speaker icon)  They are not needed for JTDX.  Setting your DAX Channels to Default or Default Communications devices with this utility may hijack your DAX sound devices and keep them from working correctly.

Hope this helps.
Good luck,
Ken - NM9P


ADVANCED USER HINT:
Since the 6500 only has 4 slices and can only use 4 DAX Audio Channel "pairs" at the same time (One "pair" for each slice) Many operators will choose to go into Device Manager and right-click on the DAX Audio RX  Channels 5-8 and the DAX RESERVED Audio Channels 5-8 and "Disable" them.  (DON'T  Disable the MIC and TX pairs.  and DON'T disable the IQ pairs).

SOME digital programs will not list "disabled" sound devices, reducing the clutter in the audio selection screens.  Other, more archaic digital programs will only display a certain number of Audio Devices, requiring this step, or merely selecting and using a DAX Audio RX Channel that you CAN see on the list.

Good luck,

Ken - NM9P
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4025 Posts
  • 1248 Reply Likes
BTW.  The Windows Sound Utility lists both ends of each virtual cable Both in the Record tab and in the Playback tab, giving each end a different icon in each of the tabs.  This makes it look like you have twice as many virtual audio cables as are really installed.....another way that Windows is "messed up" and out of touch with some of the new technology, in the name of backwards compatibility.
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3593 Posts
  • 1446 Reply Likes
Definitely sound like DAX was corrupted

I would uninstall DAX. Reboot
Delete any and all remaining DAX devices
Reboot

Reinstall DAX
Photo of Paul F6EXV

Paul F6EXV

  • 37 Posts
  • 1 Reply Like
Hi all
That was quite a neat explanation, Ken, thanks ! Sure makes things a lot clearer.
Now, I am missing for example DAX Audio RX1 and RX8. So yes, I think I must uninstall DAX.
Can I find thge procedure somewhere (for Windows 10)
Thanks guys !
Photo of Paul F6EXV

Paul F6EXV

  • 37 Posts
  • 1 Reply Like
That worked perfectly, and all my DAXes are back to normal.
JTDX works !!!!!!!!!!
Thanks guys  + 73