Computer based voice keyer queation

  • 1
  • Question
  • Updated 3 years ago
My audio .wav file is stored in my PC and N1MM+ accesses that file when a function key is pressed in N1MM+, however, sometimes the wav file does not play cleanly. When it does this it plays at approximately 92% of full rate and sounds jittery. I can not determine what is causing this and of course how to correct it for 100% reliable playback. 

I have tried to change many settings on SSDR and N1MM+ to resolve the issue but no luck, however, this leads me to think that it may a PC based issue.

I do know that when I play the audio wav file ( both SSDR and N1MM+ running ) with the MS voice recorder program it faithfully reproduces the file 100%. However, when N1MM+ commands that the wav file to play, it will only play correctly about 75% of the time.

I also know this is not an RFI issue because it also occurs when the SSDR power slider is at
0.0 watts.

Any suggestions on how to resolve this ? I have an i5 Dell 660 win10 pro and latest SSDR.
Photo of km9r.mike

km9r.mike

  • 425 Posts
  • 62 Reply Likes

Posted 3 years ago

  • 1
Photo of Al K0VM

Al K0VM, Elmer

  • 608 Posts
  • 102 Reply Likes
Mike,
  It might be caused by a DAX condition...If its a case where it works for a while and then it goes bad, try stopping and restart the DAX control panel.  Its likely that this may cure it ( temporarily ).

I dont know what exaclty triggers this condition but is seems related to window/PC/networking.latency (DPC's) issures.

AL, K0VM
Photo of Al K0VM

Al K0VM, Elmer

  • 608 Posts
  • 102 Reply Likes
You may also wish to verify that your record/playback samples rates are consistent. 48Kbps or sub-multiple (e.g. 24,12, 8 ).

AL, K0VM
Photo of km9r.mike

km9r.mike

  • 425 Posts
  • 62 Reply Likes
Just a quick follow up. It appears that may be my issue. Before, like I originally stated the bad playback would occur about 75% of the time while using N1MM+ with no rhyme or reason. I just finished engaging the cq loop feature on N1MM+ multiple times. I would let it play until the jittery playback occurred (approx. after 10 cq repeats ) at which time I would stop the playback feature in N1MM, close dax, restart dax and re engage the cq repeat function. Each time I did this the playback would be reliably nice and clean for about another 10 to 12 repeats then jittery would reappear. Hopefully reliability can be improved to 100% this is a neat feature.
Photo of km9r.mike

km9r.mike

  • 425 Posts
  • 62 Reply Likes
I thought that a difference in sample rates may be an issue as well, but that darn MS voice recorder is not too user friendly wrt allowing a change in settings. Thanks for the things to look at Al. I only been playing with it for two days now and I will keep your help in mind when trying to resolve this.
(Edited)
Photo of Al K0VM

Al K0VM, Elmer

  • 608 Posts
  • 102 Reply Likes
Try using Audacity ( free) .. 
The DAX issue seems somewhat related to the ablity of the PC to handle multitasks
without encountering long Delayed Procedure Calls (DPC's). More PC is better.
AL, K0VM
Photo of km9r.mike

km9r.mike

  • 425 Posts
  • 62 Reply Likes
I have been playing with it more and while the restarting of dax appears to help, I think it reoccurs too soon for it to be dax related and think it may be an issue of a weenie pc and multitasking. I am gonna utilize the MS pc monitoring program and see if I can determine if it occurs during peak demands only. It does sound as if the pc is struggling to get the words out : )


When it works, it works great and has great quality. About one out of every 10 is jittery/fluttery but that will disappear on the next repeat but then will reappear, I have noticed when I command a playback of my call, when the flutter playback occurs it appears to repeat for a longer duration the quicker I command N1MM to playback my call (ie placing more demand on the PC). I am guessing once the PC recouperates then the flutter goes away.
(Edited)