Cat stopped working

  • 1
  • Problem
  • Updated 4 years ago
I just received my 6300, but smartsdr cat will not load.  I get a error stating "Cat stopped working"  Here is the error from the event log.  I checked and the virtual serial port service is running.  Not sure what to check.  I tried on another computer and it worked fine.  Not sure what could be causing this on this computer.  Any ideas?

Application: Cat.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.Net.Sockets.SocketException
Stack:
   at System.Net.Sockets.Socket.DoBind(System.Net.EndPoint, System.Net.SocketAddress)
   at System.Net.Sockets.Socket.Bind(System.Net.EndPoint)
   at AsyncSocketsV2.server..ctor(Int32)
   at Cat.Main..ctor()
   at Cat.Program.Main()
Photo of William Hemmingsen

William Hemmingsen

  • 573 Posts
  • 278 Reply Likes

Posted 4 years ago

  • 1
Photo of Jim Gilliam

Jim Gilliam

  • 459 Posts
  • 71 Reply Likes
Perhaps something corrupted in your computer for some unexplained reason. Have you tried restoring your computer to an earlier date? Sometimes the restore function corrects the computer to its former state when it was working.
Photo of Bill

Bill

  • 6 Posts
  • 2 Reply Likes
You are right on but I would add that the radio and the computer are partners in the station. Many people neglect the care and feeding of the computer and it can have all kinds of issues, especially stuff running in the background upon startup. Getting rid of the junk weekly with a pcclean type program makes the computer twice as accessable. The same people who would never miss brushing their teeth regularly, run a collectively cruder up machine and have these type problems! Bill, KI4B
Photo of Jim Gilliam

Jim Gilliam

  • 459 Posts
  • 71 Reply Likes

I have preached over and over and over again on this net to make a hard drive image and it always falls on deaf ears with an ensuing argument. Even the restore is better than nothing but you are correct.


Jim, K6QE

Photo of DrTeeth

DrTeeth

  • 1687 Posts
  • 387 Reply Likes
I image daily and religiously.

Lets not talk about the (windows, natch)  PCs with broken prefetch or corrupt icon caches. See a lot of this when I service PCs. Big performance hits.

My PCs are like greyhounds - lean and fast.
(Edited)
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2771 Posts
  • 610 Reply Likes
Guy tell me, would this be happening if the computer is only a Flex box?. I mean some use the computer for everything then run SSDR as well.
Photo of DrTeeth

DrTeeth

  • 1687 Posts
  • 387 Reply Likes
I doubt it. I do not use any computer as exclusively for Flex. All sorts of other stuff is going on at the same time - only stuff that is needed.

I have never come across a situation where heavy multitasking itself makes a program crash.
Photo of William Hemmingsen

William Hemmingsen

  • 573 Posts
  • 278 Reply Likes
Back to the original topic.  I fixed my issue,  And here is what it was if anybody runs into this;

My PC had another virtual com port driver I used with power SDR.  I removed this driver and reinstalled everything.  Now I have my log program work fine with the 6300.

So my advice is as said above, look for drivers and services that might be conflicting and remove them.  A clean slate is always best for sure.

W4WHL