CAT setup lost in 1.11.12 - COM73?

  • 2
  • Question
  • Updated 1 year ago
  • Answered
I installed SmartSDR 1.11.12 today after uninstalling the 1.10 beta.  When installed. 1.11 had lost the previous CAT setup information, and the four ports I had created were all shown as "COM73" and unable to be changed to the lower numbers they had been previously.  This really screwed up my OmniRig link to Log4OM because I can't specify a COM port over 20 there, and attempting to create a new com port in CAT starts with the lowest number of 73.  Am I missing something?  I've deleted all the com ports and added them back, but it always starts at COM73 and will not allow selecting anything lower.  Any pointers would be welcome.
Photo of Duane, AC5AA

Duane, AC5AA

  • 416 Posts
  • 90 Reply Likes

Posted 1 year ago

  • 2
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 821 Posts
  • 191 Reply Likes
Hi Duane:

Take a peek in Device Manager and see if you are showing these ports up to 73 already listed. Mine looks like this:


If yours shows ports up to 73 then you might want to try the Com Name Arbiter tool. This would allow you to clean up unused COM ports making them available for assignment again. In my case it shows checks only by the ports I've set up. In your case you may see checks from COM1 to COM73 (and others maybe).


Run this as administrator, clear the checks if they are there and apply. Then try setting up SmartCAT again.

(hmm - 73. coincidence? Let's call this the BEST WISHES bug) ;)

73,
Kev K4VD
(Edited)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9153 Posts
  • 3496 Reply Likes
Official Response
Sorry about the loss of the CAT ports on the upgrade.  The new CAT and FlexVSP driver should be less susceptible to this happening in the future.

This is what you need to do.  If running, close down SmartSDR for Windows and DAX, but leave the CAT application open.  Put your mouse over the REMOVE button in the lower right-hand corner and right mouse click to bring up the context menu.  Select the Reset FlexVSP Ports option and wait about 30 seconds or so then close the CAT application.

Now reset your In Use CAT ports by following this procedure.
https://helpdesk.flexradio.com/hc/en-us/articles/115000504463-Removing-In-Use-Com-Ports-for-Availabl...

After that, reboot your PC.

When the CAT application starts up, if there are any serial ports defined, then highlight them and delete them using the CAT application.  This will clean up all of the previous CAT ports properly.

Now recreate your ports you need for your applications.

Refrain from deleting the ports using Device Manager.  That can make a bigger mess of things which can be harder to recover from.
(Edited)
Photo of Duane, AC5AA

Duane, AC5AA

  • 416 Posts
  • 90 Reply Likes
Thanks, Tim - I'll give it a try this evening when I return home.  
Photo of Duane, AC5AA

Duane, AC5AA

  • 416 Posts
  • 90 Reply Likes
Again, thanks, Tim - the arbitor tool worked great - I just selected the "clear non-present" button and it cleared all but the two I had in use.  A few minutes later I was back up and running again.  Now if I can just find a solution to the CWX "hesitation" problem I'll be a really happy camper.  (I opened a trouble ticket on it. It's been present since 1.7 or 1.8.)