CAT Server Send Error?

  • 2
  • Question
  • Updated 3 years ago
Everytime I use the Flex Control knob to change frequency, I get the error message "CAT Server Send Error".  It seems to flash on the screen proportional to the encoder in the Flex Control knob.  Everything continues to work, but it is a bit disconcerting to see that error message pulsating in the lower right portion of the panadapter.  The second line in the error message says "It appears that the server is not connected".  But everything works.

Any ideas?
Photo of Charles - K5UA

Charles - K5UA

  • 315 Posts
  • 87 Reply Likes

Posted 3 years ago

  • 2
Photo of Jon  W1JDB

Jon W1JDB

  • 146 Posts
  • 35 Reply Likes
Most likely there is a COM Port that is trying to be used by both. Have you tried looking to see if there is a duplicate port that is enabled for something in SmartCAT and the Flex Knob?
Photo of Jim Clarke

Jim Clarke

  • 7 Posts
  • 0 Reply Likes
I have the same problem both with the Flex Control Knob and changing frequency with the mouse. The Flex Control is out of the normal ports at com 100. I am using  a 6500 with v1.6.21.77.  It was also  doing this with the previous version
Photo of Jon  W1JDB

Jon W1JDB

  • 146 Posts
  • 35 Reply Likes
I would suggest a Flex HelpDesk ticket.
Photo of Charles - K5UA

Charles - K5UA

  • 315 Posts
  • 87 Reply Likes
Interesting new development in this error message.  It only occurs when DDUTIL is running.  Turn off DDUTIL and the error message goes away.  DDUTIL does not share any Comm Ports with any other program.  Does his shed any light on the error message.?
(Edited)
Photo of Neal - K3NC

Neal - K3NC, Elmer

  • 438 Posts
  • 130 Reply Likes
I found on one computer that there were duplicate comm ports defined (as seen in the Ports subsection of the Device Manager). One of the duplicates was a physical port and I could not prevent Windows from dupe-assigning it so I assigned it a number in the 100s and then disabled it. This stopped the messages for a day or two but I just heard that the message is back.  I don't think it has anything to  do with DDUtil however.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3467 Reply Likes
The "Server send" error is an issue with the TCP CAT port connecting to DDUtil.  I suspect that it has not been properly set up to communicate with CAT over the TCP connection.
Photo of Charles - K5UA

Charles - K5UA

  • 315 Posts
  • 87 Reply Likes
Thanks Tim,
I'll see if any of the DDUTIL users can help with this.  Doesn't seem to break anything, but annoying to see the message flashing as the Flex encoder turns.
Photo of Neal - K3NC

Neal - K3NC, Elmer

  • 438 Posts
  • 130 Reply Likes
Itwill do it even if you use your mouse wheel instead of the flex control.
Photo of Charles - K5UA

Charles - K5UA

  • 315 Posts
  • 87 Reply Likes
Haven't tried the mouse wheel yet, but I will. If anyone knows of a solution within ddutil, please post it.
Photo of Jim Clarke

Jim Clarke

  • 7 Posts
  • 0 Reply Likes
DDUtil only has one port selected for connection to a Elecraft KPA500. I have unplugged it, no success. I have unchecked 'Serial Port Emulator' on this port and restarted, no success. Dudley has a ticket on it now.