CAT ports all dead, yellow triangles on device manager even after deleted

  • 1
  • Problem
  • Updated 2 years ago
Just before CQ WW RTTY, naturally, my COM ports, all of them, seem to have crapped out.  They show up with yellow triangles, so it isn't exactly and entirely the "hidden port" problem, but is very similar in appearance, but doing the "delete hidden ports trick" hasn't worked.

Here's what I have done so far:

1.  Upgraded from 1.6.7 to 1.9.9.
2.  Deleted all the ports from the SDR CAT program except TCP port 5002.  Nothing changes, except I can't create anything new, even after reboot.
2.  Deleted the "visible" virtual SDR created ports with the yellow triangles.
3.  Ran the "hidden" port deletion procedure, with not much to do, though a few were left around.
4.  Somehow discovered, under "other devices" something called "Fabula" ports in the same range as the COMx ports I had.  Deleted those.  They do not appear.

So, I think I have deleted everything I dare, with or without being 'hidden'.  The remaining COM ports (I have some actual COM in the machine) now look normal as far as I can tell and they don't overlap the Flex range anyway.

SDR CAT will only let me even try to create COM4: throughout, but it always fails to create, whether under my "local" user or under my "admin" user. 

Anyone seen this?  How do I get out of this hole?
Photo of Larry Loen  WO7R

Larry Loen WO7R

  • 201 Posts
  • 23 Reply Likes

Posted 2 years ago

  • 1
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4025 Posts
  • 1248 Reply Likes
After every uninstall you need to make sure you reboot the computer and check to see if they actually got deleted.  Then reboot after a re-install.

I did an undelete and re-install without rebooting in between and had a lot of grief...

1) as a first step, you might find FlexVSP in your programs folder and click "repair" or "Reinstall"

2) If that doesn't help...You might want to export your profiles, do a COMPLETE uninstall and cleanse of the SSDR and VSP...reboot...check for Phantom and Ghost ports (audio and COM) ,,, reboot again if you deleted any residuals...then install 1.9.9 and reboot...and reconfigure your CAT ports....Then import your profiles and see if that helps.

You may have already done some of this, but a missed step can sometimes cause problems.
Photo of k3Tim

k3Tim

  • 848 Posts
  • 166 Reply Likes
I would open the task manager and stio the Virtual Serial Port Kit Service unless you already have.
In directory: 
c:\Program Files\FlexRadio Systems\SmartSDR v1.9.9\64-bit Drivers\VSP

run the .MSI installer as admin.

You'll likely have to reboot to get the VSP kit running again. 

GL and see you on the green keys.

TImPE
Photo of Mike va3mw

Mike va3mw

  • 824 Posts
  • 196 Reply Likes
Hi Larry

Ken's comments are solid.  You may also want to get a support case opened at the same time.

Mike
Photo of Rory - N6OIL

Rory - N6OIL

  • 268 Posts
  • 47 Reply Likes
We here in our IT dept call those yellow triangles, bangs! Can't wait to get my Flex back from the hospital and try out the latest SSDR software.
Photo of Larry Loen  WO7R

Larry Loen WO7R

  • 201 Posts
  • 23 Reply Likes
Well, thanks for all the helpful comments.  I took NM9P's advise because I saw it first.  I deleted everything (as far as COMx went, already done), uninstalled everything, including VSP, rebooted, reinstalled 1.9.9, rebooted and was able to recreate my ports.

All seems well; my usual third party apps seem to be running.

I put the blame here on that big, involuntary Windows update, whatever the name of that thing is.

What a mess that thing has caused.
Photo of Rory - N6OIL

Rory - N6OIL

  • 268 Posts
  • 47 Reply Likes
We have not deployed Win10 yet in our school district but I remember reading that Win 10 Pro N doesn't force auto updates, maybe more in the know can comment.
Photo of Jim G3YLA

Jim G3YLA

  • 6 Posts
  • 0 Reply Likes
Similar to Larry's experience, I've just had a Windows 10 moment too; seemed a very bleak outlook, if it helps anyone, here's how I stumbled through it...

Win10 decided to do what seemed like a major update, after which the CAT/DAX ceased to work. No sign of FlexVSP driver loaded. Tried to install manually, but did not complete.

Eventually got it working by completely uninstalling SSDR and reinstalling new version1.9.9 and all is good again. (I did not delete any com ports, by the way, simply reloaded the SSDR)

On restarting, the rig update part stopped part way through with a Smart SDR file transfer error. I clicked ok to try again and it worked through to the end with one auto rig restart.

Win 10 updates not so keen, SSDR updates keep 'em coming Flex, very pleased.
73 de Jim
g3yla