CAT not connecting to SSDR/6500? Cannot create V ports....

  • 1
  • Problem
  • Updated 3 years ago
  • Solved
I tried to do an uninstall of all my old Flex SSDR software and VSP and DAX and so on....  Clean sheet as it were...  I did restarts after the VSP uninstall and SSDR uninstalls as well as unplugging the Flex control knob.  I followed the instructions, “how to do a computer uninstall of SSDR for windows from your PC”, at least I think I did....  
As you can see from the attachment the RADIO is not showing up in the CAT display, and, I’m not able to create any serial ports in the serial port window...  The radio starts and works....   I show the DDUtil setup display connecting to the CAT and I can see the CAT connect flag popping up with DDUtil starts.  (DDUtil was closed when I did all the uninstalling.)
 
There were no hidden ports to delete.  I didn’t uninstall the Flex control driver, hope that isn’t the problem.   It looks to me like the CAT is not connecting to the radio....  (CAT in startup list)
 
I’m running V1416.  The radio and PC are directly connected to my router with separate cables.  I’m running the W7 with all updates.
 
Dennis, k0eoo
Photo of k0eoo

k0eoo

  • 594 Posts
  • 81 Reply Likes

Posted 3 years ago

  • 1
Photo of Burt Fisher

Burt Fisher

  • 1049 Posts
  • 366 Reply Likes
I have to to go to Task Manager stop DAX and CAT  then restart to get it to work
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3466 Reply Likes
DAX has nothing to do with SmartSDR CAT.
Photo of Burt Fisher

Burt Fisher

  • 1049 Posts
  • 366 Reply Likes
Neither works unless I go to task manager and stop each to get each to work by manually starting them
Photo of Wim

Wim

  • 90 Posts
  • 17 Reply Likes
I had similar issue and had to turn off Windows Firewall, then it worked.
Once I had it in that state I checked the firewall rules for Flexradio and unchecked/re checked those
firewall rules and now can leave the firewall on for smartCAT to connect...
Photo of k0eoo

k0eoo

  • 594 Posts
  • 81 Reply Likes
Wim, can you show me what window you did the unchecked/rechecked firewall rules in?  I was in the "Allow programs....  window", but, that might not be the place you're referring to?
Photo of k0eoo

k0eoo

  • 594 Posts
  • 81 Reply Likes
Thank you Burt and Wim for the help....  Wim's response solved the issue.... Burt, I didn't need to try your solution, at least not this time....  

The SSDR CAT manual did not indicate there might be problems connecting because of the Firewall, at least not that I found....
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3466 Reply Likes
As a point of reference, the same things that prevents SmartSDR from connecting to a FLEX-6000 affect all applications that connect to the radio.  This is covered in the SmartSDR for Windows manual.
(Edited)
Photo of Burt Fisher

Burt Fisher

  • 1049 Posts
  • 366 Reply Likes
True both Fldigi anf WSJT-x need the same solution but once engaged it works the whole day.
Photo of k0eoo

k0eoo

  • 594 Posts
  • 81 Reply Likes
Followup with connectivity problem:

Shutting off the firewall only temporarily fixed the problem.  When off, SSDR connects to SmartCAT and all works as advertised.  I can then turn the firewall back on and all still works good.  But, as soon as I shut down radio and PC, then restart all, SSDR will not connect to SmartCAT.  This has NOT been an issue for the last two years, only now....

Also, I have unselected/reselected  the SmartSDR CAT V1416 in the "Allow programs to communicate through Windows Firewall" with NO joy....

And for point of reference, this connectivity problem is NOT covered in the SmartSDR software manual....

So, looks like uninstalling all those previous versions of SSDR has deleted something that is preventing SSDR from connecting to the SmartCAT at startup.

Would appreciate help...
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3466 Reply Likes
Something is just hosed up with the firewall rulesets.  I'll remove all versions of SmartSDR and manually remove any firewall rules that remain and reinstall like I suggested above.  I think a "clean slate" is needed.
Photo of k0eoo

k0eoo

  • 594 Posts
  • 81 Reply Likes
I have already removed all previous versions of SmartSDR.  The only version on my PC is V1416.  How do I manually remove any firewall rules that remain?  Do you mean remove them from the exception list?
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3466 Reply Likes
Yes, highlight the rule and click Remove.
Photo of k0eoo

k0eoo

  • 594 Posts
  • 81 Reply Likes
Thank you Tim, I was able to remove "Cat" and redid the un/re install procedure and all is working as advertised....
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3466 Reply Likes
Perfecto!

This conversation is no longer open for comments or replies.