Can't get SmartLink working, need help.

  • 2
  • Problem
  • Updated 2 years ago
  • Solved
OK, I give up.  I need some help.  Try as I might, I can not get SmartLink running.  Here's my current configuration:  Netgear DM111 DSL modem/router at 192.168.0.1, feeding a Netgear R6400 router at 192.168.1.1, uPnP enabled, manual port forward also set to TCP 4994, UDP 4993.  No matter which configuration I try, the SmartLink test fails.  I have a help ticket open, and had one email from Dudley with a suggestion I do a cold boot to factory defaults on the 6500 which I did (several times, in fact, as well as doing a total uninstall/reinstall), but no luck.  I've reset both the modem and the R6400 router, and all other internet and WiFi functions work fine.  The 6500 and the desktop computer are both plugged into the R6400...the only things plugged in...everything else in the house runs on WiFi.  The desktop has a good internet connection, and the 6500 works fine otherwise, and all of the third-party software is communicating with the internet as it shoud, just not SmartLink.  I need ideas....

Rick, W0FG
Photo of Rick Hadley - W0FG

Rick Hadley - W0FG

  • 588 Posts
  • 128 Reply Likes

Posted 2 years ago

  • 2
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4083 Posts
  • 1276 Reply Likes
What is the IP address showing for your rig and computer?
Photo of Mack McCormick

Mack McCormick, Elmer

  • 381 Posts
  • 134 Reply Likes
Rick,

Is it possible to place your DSL modem/router in "bridge" mode? That is, no router function. You are doing two network translations and that can be problematic. Or can you place the R6400 in bridge mode? Also, if possible, try enable universal plug and play on your SINGLE router. I'll bet it works then.

Mack
W4AX
Alpha Team
Photo of Mike va3mw

Mike va3mw

  • 824 Posts
  • 197 Reply Likes
One more idea is there anyway you can connect your radio directly to the router and boot it up even if only for 10 minutes?  The actual radio has to have access to the Net.
Photo of Tony Taddeo

Tony Taddeo

  • 61 Posts
  • 29 Reply Likes
I believe you may have a double NATing issue as you (may) have 2 routers connecting to each other both using their WAN ports. That means you either need to port forward the DM111 to the R6400 and then port forward the R6400 to the radio or just plug into the network switch side of the R6400 (looks like a white port on pictures on the internet ) rather an the yellow Wan port and just do the port forwarding in the DM111.

Good luck
Tony VK5TT
(Edited)
Photo of Tony Taddeo

Tony Taddeo

  • 61 Posts
  • 29 Reply Likes
Further to this, you may not need to do any port forwarding if uPNP working on the DM111. DHCP needs to be turned on, on the DM111 and all devices on your internal network will need to be rebooted to be allocated an ip on the 192.168.0.x subnet.
(Edited)
Photo of Tony Taddeo

Tony Taddeo

  • 61 Posts
  • 29 Reply Likes
Sorry, also turn DHCP off on the R6400 if you are doing the above.
Photo of Jay Spaulding

Jay Spaulding

  • 65 Posts
  • 3 Reply Likes
I think Tony is right. You have two routers. You need to bridge the first one. Then open ports to your radio on the second one. Or you can DMZ your second router from the first and still have to open ports.

I did the manual setup in the smart link and put in the ports I wanted to use and opened them to my radio IP. Works fine here.

Good luck and hope you get it going

Jay
Photo of Mike va3mw

Mike va3mw

  • 824 Posts
  • 197 Reply Likes
OMG... what was I thinking.  Sorry, that is the wrong fix for this problem.  I'm sorry if I lead you astray.
Photo of KD7CAO

KD7CAO

  • 33 Posts
  • 17 Reply Likes
I like Mack's suggestion. I will make one additional suggestion, plug your computer and Flex into the DSL Modem/Router if you don't want to adjust settings for the rest of your network. You should be able to access devices behind the second router from your computer if you have a NAS or other devices. I do this on my setup. I have a Cisco Gigabit Router rack mounted in my Flex Go-Kit but, it plugs into my switch which runs back to my home network. 
Photo of Ken Hansen

Ken Hansen

  • 282 Posts
  • 83 Reply Likes
The DSL device may only allow/support one 'inside' IP address - the DM111 is a DSL modem, not a router, with only one Ethernet port.

https://www.netgear.com/home/products...

I think the answer is to put the inside router in the DMZ.
Photo of Jay Spaulding

Jay Spaulding

  • 65 Posts
  • 3 Reply Likes
Yeah there still a firewall in that modem that needs to be addressed.
Photo of David Vernier

David Vernier

  • 18 Posts
  • 6 Reply Likes
If the R6400 isn't in A DMZ, the you're running what is commonly called a double NAT configuration. That's probably not going to work. Either attach the flex tho the DM111 or put the R6400 in a DMZ...
Photo of Ken Hansen

Ken Hansen

  • 283 Posts
  • 86 Reply Likes
You've got two routers, and have only set up UPNP on one of them, the 'inside' router, the RM6400. The 'outside' router, the DM111, does it appear to have the necessary ports open to pass traffic on the specified ports on to the inside router.


To make this work you'll have to manually port forward the correct ports from your outside router to the IP address of the inside router, and the inside router will be set using UPNP to direct traffic to your Flex.


You could put your inside router, the RM6400 in the 'DMZ' of the outside router so that all ports are forwarded to the inside router, and it then passes selected ports to the Flex.


Two routers between your ISP and the radio is a tricky setup - it would be best if you could find a way to put the Flex on the outside router.
(Edited)
Photo of Rick Hadley - W0FG

Rick Hadley - W0FG

  • 588 Posts
  • 128 Reply Likes
Ken.  The 6500 is 192.168.1.8, the computer 192.168.1.150

Mack.  It may be, but I can't figure it out.  The modem has the ability to be placed in either Modem/Router mode or just straight Modem, but when I tried the latter, I lost all connectivity.  uPNP is enabled on both boxes.  There is an option for VLAN/Bridge settings on the R6400, but I when I enabled it with the default settings, I lost all internet connectivity.  I'm basically network illiterate beyond the basic setup.  I'd be happy to host a TeamViewer connection if you or anyone else cares to give it a try.

Rick, W0FG
Photo of Rick Hadley - W0FG

Rick Hadley - W0FG

  • 588 Posts
  • 128 Reply Likes
David & Ken.  I'm sure that's what's happening, but don't know how to set things up.  The DM111 only has one output.  It's the 'inside' router if I understand you right.  The computer and Flex are attached to the R6400, the 'outside' router which feeds everything else in the house too.  As I understand it, the R6400 is strictly a router, and need the feed from the modem.  Don't know how to set things on the DM111 to get around the issue.
 
Photo of Ken Hansen

Ken Hansen

  • 283 Posts
  • 86 Reply Likes
Here's the DM111 manual, look around page 33, and review chapters 3 and 5. I think page 33 +/- has the answer, the two chapters might help you understand what is happening.

The question is how will outside traffic find it's way to your radio? The DM111 needs to pass the selected ports on to the inside router, which in turn needs to pass the selected ports on to the radio.

http://www.downloads.netgear.com/file...
Photo of Rick Hadley - W0FG

Rick Hadley - W0FG

  • 588 Posts
  • 128 Reply Likes
Turned off DHCP on the R6400, but no change.  How do I do the DMZ thing?
Photo of Tony Taddeo

Tony Taddeo

  • 61 Posts
  • 29 Reply Likes
Plug the network cable from the DM111 into the network side of the R6400 not the yellow WAN port. Then reboot devices on your network. They should then be on the 192.168.0.x subnet.
Photo of Mike va3mw

Mike va3mw

  • 824 Posts
  • 197 Reply Likes
I'm going to jump in on this and see if I can provide an idea that has been provide, but maybe word it differently.  Like Rick and others say.....

Your main router is fine.  You can leave it alone.

Take the second Wifi/Router and log into it.  Turn off the DHCP in it as we are going to use DHCP on the main router.  As he said, use a Lan cable to connect this router, but you MUST plug that Lan cable into the LAN ports not the WAN port.  This is key.  Place some tape over the WAN port just in case ... for the future.  DHCP is the service that provides the IP address to devices and we only want 1 DHCP server active in your house.  Don't worry about UPNP in this router as it will never be used or required.

This makes the 2nd router just an Access Point & Switch.

What will happen now is that all devices will get their IP address from the main router and eliminate double NAT.  You access point will work fine.

Reboot everything that was on the 2nd router and it will now get its IP address from the main router and you will be able to see everything and UPNP will function.

I hope this makes sense.  I do this all the time for home installations who need more AP's, but need it to work.

Mike 
Photo of Rick Hadley - W0FG

Rick Hadley - W0FG

  • 588 Posts
  • 128 Reply Likes
Official Response
Got it working thanks to some serious offline help from Tony. Michael, your suggestions were part of the fix, but additionally, we had to use manual port forwarding on the modem, a process that was anything but clear cut in the NETGEAR modem setup. In any event, it's working now, though the thruput on my ATT MiFi hotspot is rather marginal. I'll try to find another hotspot in town to try it from. Thanks to all for your help, and Tony, I owe you a steak dinner if you're ever up this way!