Can't get Fldigi to connect to Flex-6500 since I allowed Windows 10 to do an upgrade 28Aug15.

  • 1
  • Question
  • Updated 3 years ago
Have been running Fldigi 3.21.78 successfully under Windows 10 with SmartSDR version 1.4.16 using RigCAT and SmartSDR.xml.  I allowed Windows 10 to do an upgrade and cannot get RigCAT to initialize.  SmartSDR CAT is working fine - it shows the correct frequency for example when using the test feature.  I checked on the two Microsoft updates that comprised the update and per the KB they don't seem to relate to networking. Only one was available to uninstall, so I tried that. I also tried turning off Windows Defender and the firewall, and still no luck.  I also downloaded and intstalled Fldigi 3.22.13 (latest version) with an updated xml rig definition file.  Still no success.  Also tried reinstalling SmartSDR to reinstall SmartCAT but still no success.  Likely something simple I am missing.  Any ideas?
Keith
KE4TH
Photo of Keith - KE4TH

Keith - KE4TH

  • 18 Posts
  • 1 Reply Like

Posted 3 years ago

  • 1
Photo of W7NGA

W7NGA

  • 437 Posts
  • 187 Reply Likes
Keith, I just installed Windows 10 and it is working with SSDR like a dream with no issues. Fldigi would not initialize as the .xml definition file had disappeared. I downloaded it once again, pointed to (opened) the new file in the RigCat section, initialized, and everything works. You have to be very specific as to where the file resides. Perhaps this is not your issue, but others might find it of value.

W7NGA - dan
San Juan Island, Wa.
Photo of Al K0VM

Al K0VM, Elmer

  • 593 Posts
  • 100 Reply Likes
Keith,
  I would got through and redo all of the CAT & audio setting in FLdigi and SSDRCAT/DAX as if you where setting it up for the first time.. WIndows sometimes scrambles CAT and audio ports on reboot and upgrades..

AL, K0VM
Photo of John n0snx

John n0snx

  • 229 Posts
  • 54 Reply Likes
I had the same issue until I manually deleted all the com port related to Flex in the device manager.... Then reload SSDR and let it rebuild the Flex ports and all was fine after that... good luck...
Photo of Rob G6EIH

Rob G6EIH

  • 102 Posts
  • 12 Reply Likes
If your runing antivirus software this can disable com's on many ports, uninstall your antivirus and see if it works, you can always install antivirus again and it won't compromise other settings or software.
Photo of Keith - KE4TH

Keith - KE4TH

  • 18 Posts
  • 1 Reply Like
Rob - I tried turning off Windows Defender, the antivirus software native to Windows 10.  The SmartSDR CAT is not showing any Available Flex Virtual Ports and I think somehow this is part of the issue. The Main tab still shows COM4 for 3rd party software.
John - I could not find any com ports in device manager related to Flex software.  I tried showing hidden devices and still no luck finding any ports.  Maybe lack of ports is the issue.
I appreciate everyone's comments!
Keith
KE4TH
Photo of Keith - KE4TH

Keith - KE4TH

  • 18 Posts
  • 1 Reply Like
I removed SmartSDR and deleted visible and hidden ports in device manager. Interesting that the ports only showed up after I deleted SmartSDR.  After reinstall, the new virtual ports created, COM4 (for Fldigi) and COM14 (for radio), show with yellow caution triangles in device manager.  The error message is "Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)".  Apparently this is the issue, even with a clean install, the virtual com ports are not working properly.  Any ideas how to get a cleaner install?
Keith
KE4TH
(Edited)
Photo of k3Tim

k3Tim

  • 865 Posts
  • 170 Reply Likes
Had same exact message when I upgraded from win7 to win10. Removing the devices as already mentioned and installing SDR-CAT manually using Admin-priv fixed it. Sa!e was required for SDR-DaX. After this everything has worked under Windows 10 and I am glad to be over this hurdles.

Good luck...
Photo of John n0snx

John n0snx

  • 229 Posts
  • 54 Reply Likes
Keith now that they showed up delete them again reboot computer and reload ssdr again... that's what worked for me....
(Edited)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9153 Posts
  • 3497 Reply Likes
Keith - this is the pitfall of not completely removing the entire SmartSDR "ecosystem" before allowing Windows to upgrade an operating systems; drivers get hosed in the upgrade process.  

My recommendation is to revert back to your previous OS version, uninstall entire SmartSDR "ecosystem" (https://helpdesk.flexradio.com/hc/en-us/articles/204975589), upgrade to Win10 and then re-install SmartSDR.