Can't connect to Flex using Smartlink over Comcast but works ok with other providers?

  • 1
  • Problem
  • Updated 4 days ago
Solution for not being able to connect with Smartlink using one internet service but connects ok with others.

Has anyone experienced a problem like I did where they could not reach their Flex remotely with Smartlink when using one provider but it works ok over another provider?  I have a Flex 6600 that I could not connect to if the Internet provider is Comcast but it worked fine if I used my AT&T Mobile Hotspot.  I even tried a VPN and it works fine with that, too.  Obviously a problem with Comcast, right?   Of course not.  That would be way too easy.  It was not a problem with Comcast.  The solution is to set a parameter called "MTU" on the client router to a smaller value.  Default on mine is 1500.  Setting MTU to 1478 made it so I could reach the Flex over Comcast with no further changes.  Your numbers may vary but this is a starting point before you open any trouble tickets.  I saw lots of similar posts but I didn't see any solutions.  Hope this helps some one out there. 
Photo of Mark - W0QL

Mark - W0QL

  • 2 Posts
  • 0 Reply Likes

Posted 5 days ago

  • 1
Photo of KI4P

KI4P

  • 171 Posts
  • 34 Reply Likes
ok! ill bite! cant remember what MTU is, have seen it somewhere but not sure what it does
Photo of Mark - W0QL

Mark - W0QL

  • 2 Posts
  • 0 Reply Likes
Hello.  Thanks for asking. I should have defined it.  It stands for Maximum Transmission Unit.  In other words it's the maximum size of the packets.  The setting should be found in the Internet section or wan section of a router.  My whole bloody writeup is here if you want something to put you to sleep tonight.   https://w0ql.wordpress.com/
Mark