Cannot make dogparkSDR work with Flex-6600M

  • 1
  • Question
  • Updated 1 year ago
  • Answered
I've got a brand new Flex-6600M here, running the latest available firmware. I'm running dogparkSDR v1.12 on a late 2016 15" MacBook Pro, running macOS 10.13.4. 

I really want to make dogparkSDR work, but I can't. No amount of fiddling with settings or preferences helps. SmartSDR for Windows works properly.

When I start dogparkSDR, it appears to connect properly to my radio: it identifies the radio on my network, reads its serial number, and it even shows the frequency the radio is set to. However, none of the buttons do anything (for example, I can't change frequency) and the panadapter screen says "Starting up" and nothing else, the whole time. (I also tried the v1.13 beta 5 too, with identical results).

Here's a screenshot: https://www.dropbox.com/s/umzg3e4t2291f46/Screenshot%202018-05-03%2018.43.17.png?dl=0

What's going on here? Does dogparkSDR not yet support the Flex-6600M?

Can anyone on this forum claim that they are successfully using dogparkSDR with a 6600M?
Photo of Dan Parsons - WT7Q

Dan Parsons - WT7Q

  • 35 Posts
  • 3 Reply Likes

Posted 1 year ago

  • 1
Photo of George Molnar, KF2T

George Molnar, KF2T, Elmer

  • 1679 Posts
  • 614 Reply Likes
I am running flawlessly with a 6600 (not M). Have you allowed Dpsdr through the MacOS firewall?
Photo of Dan Parsons - WT7Q

Dan Parsons - WT7Q

  • 35 Posts
  • 3 Reply Likes
I have tested both with firewall on and off, behavior is identical.
Photo of K3SF

K3SF

  • 302 Posts
  • 99 Reply Likes
i see you are running a demo copy.

dpsdr does support 6600M.

I worked with Don to help get 4 slice/4 panafalls working correctly and it even works with smartlink too. I have a registered copy of dpsdr.

Not sure if there is an issue in demo mode
BUT
One thing you might try is adding another panafall.

Here is pic of my macbook pro running 4 slices from a 6600M


Photo of Dan Parsons - WT7Q

Dan Parsons - WT7Q

  • 35 Posts
  • 3 Reply Likes
Yeah, running demo copy, not going to pay for this thing if it doesn't do what it says. When you worked with Don, what did he tell you to do? I've contacted him also, waiting for a reply, hasn't been very long yet.
Photo of Don Agro

Don Agro

  • 129 Posts
  • 80 Reply Likes
https://www.dogparksoftware.com/dogparkSDR_Help/dogparkSDR_Help.html

Getting Started

The first time your run dogparkSDR you will need to connect to the radio by selecting it in the HUD popup or double-click on it in the Registration prefs list. You may also need to add Panadapters and Slices from the dogparkSDR File menu and select or create a new global profile.

Photo of Scott Russell - N1SER

Scott Russell - N1SER

  • 132 Posts
  • 66 Reply Likes
Official Response
Dan, go to File/Add Panadapter and see if that works. I had the same issue when I first tried dogparkSDR. It doesn't seem to default to a panadapter. Hope this helps!

Scott N1SER
Photo of Dan Parsons - WT7Q

Dan Parsons - WT7Q

  • 35 Posts
  • 3 Reply Likes
Oh my god that fixed it! Wow!!! How on earth do they justify shipping software with a bug like this in it? I mean, aside from the panadapter not coming up correctly at launch, none of the buttons work either until I followed your suggestion.
Photo of Don Agro

Don Agro

  • 129 Posts
  • 80 Reply Likes
https://www.dogparksoftware.com/dogparkSDR_Help/dogparkSDR_Help.html

Getting Started

The first time your run dogparkSDR you will need to connect to the radio by selecting it in the HUD popup or double-click on it in the Registration prefs list. You may also need to add Panadapters and Slices from the dogparkSDR File menu and select or create a new global profile.

Photo of Pat - WH6HI

Pat - WH6HI

  • 439 Posts
  • 81 Reply Likes
Not sure how the M versions work, but is there a way to shut down on board display/PC control? I think the on board computer is got the radio tied up. Only one Computer at a time can run radio as the radio is the server. Dog park may only go so far to connect. Just my uneducated 2 cents.
(Edited)
Photo of Don Agro

Don Agro

  • 129 Posts
  • 80 Reply Likes
Hi Dan,

I think you probably just need to add a Panadapter.

https://www.dogparksoftware.com/dogparkSDR_Help/dogparkSDR_Help.html

Getting Started

The first time your run dogparkSDR you will need to connect to the radio by selecting it in the HUD popup or double-click on it in the Registration prefs list. You may also need to add Panadapters and Slices from the dogparkSDR File menu and select or create a new global profile.

When you restart dogparkSDR it should remember your choice and Auto Connect if you have that option set in the Radio prefs.

Photo of Dan Parsons - WT7Q

Dan Parsons - WT7Q

  • 35 Posts
  • 3 Reply Likes
Thanks Don and everyone for the help!

This conversation is no longer open for comments or replies.