Cannot Download SSDR 2.0

  • 1
  • Question
  • Updated 2 years ago
  • Answered
I have been reading numerous posts from those who have successfully downloaded and installed SSDR 2.0, but I am now on my tenth attempt to download a complete and working ~51-mb file. The download fails, usually during the first half of the process. If I select 'resume', it continues for a while, then fails again. Edge, Firefox, and Chrome all yield the same problem. If I manage to download the complete file, the Update (the radio) portion fails.

Also, I set up an account for the license, and received a response that the account is working. Does this start the license period. despite not having a complete and working download?

The radio is connected to my network via WiFi and there has never been a problem with software upgrades since new (a couple of years ago). Just for fun, I tried downloading the software on a "hard wired" PC, and had the same problem. My Internet speed is Ping = 21, Download = 3.11, and Upload = 10.77... is this sufficient?

Is there something I am missing here? I plan to attempt yet another download sometime after 0300 (but before 0700), in the event the servers are just overloaded. Maybe...

Thanks in advance for any assistance on this.
Photo of Jerry - W2TXB

Jerry - W2TXB

  • 88 Posts
  • 17 Reply Likes

Posted 2 years ago

  • 1
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9154 Posts
  • 3507 Reply Likes
I am totally confused.  If you can't download the Installer how did you setup an account since you do that using SmartSDR v2.0.17?

Where did you set up an account?

The web servers are not overloaded.   I just did a download in about 10 seconds, but I have a VERY fast fiber connection.
Photo of Jerry - W2TXB

Jerry - W2TXB

  • 88 Posts
  • 17 Reply Likes
I signed in and verified the account through "SmartLink Login <no-reply@auth0user.net>". At that time, I had downloaded the file, but then found out it was corrupted. The file required more than 25 minutes to finally download.

Using Time Warner/Spectrum cable internet, and previous downloads of SSDR came through within a few minutes.
(Edited)
Photo of Gary L. Robinson

Gary L. Robinson

  • 251 Posts
  • 54 Reply Likes
I just downloaded the 2.0.17 installer and it took 2 minutes with my Spectrum cable internet.   

---Gary WB8ROL
Photo of Phil - WG5D

Phil - WG5D

  • 39 Posts
  • 3 Reply Likes
Jerry,

You mentioned the stats on your internet speed test " Ping = 21, Download = 3.11, and Upload = 10.77". This indicates a network problem to me - typically download speeds are ~5x higher than upload speeds. Your ping time is fine.

I would begin with powering off your router for at least one minute to fully reset your internet connection, power back on, and then try it again. If that does not work, there could be an issue with your ISP, or you could have some other hardware and/or configuration problems such as another firewall somewhere in the mix or incorrect MTU settings on your computer. Feel free to reach out to me directly if you can't get this working.

Phil - WG5D
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4149 Posts
  • 1325 Reply Likes
This is certainly not the standard experience most have had...

I would suggest these steps...
Delete any partially downloaded copies, or move them to a different directory.
Clear your internet Cache...
Reboot your computer.
Check your internet connection with DSLreports.com to make sure you haven't had a problem creep in.
Connect with hardwire to eliminate WiFi problems..

Try again

Ken - NM9P
Photo of Jerry - W2TXB

Jerry - W2TXB

  • 88 Posts
  • 17 Reply Likes
Did all of that several times, and DSLReports showed this: [img]http://www.dslreports.com/speedtest/19155330.png[/img]
Photo of Jim Gilliam

Jim Gilliam

  • 910 Posts
  • 208 Reply Likes

Maybe you could find a friend who could download it and put it on a thumb drive. Now you can blame the thumb drive.



Photo of Jerry - W2TXB

Jerry - W2TXB

  • 88 Posts
  • 17 Reply Likes
Not looking to blame anybody nor anything... just wanting to get it downloaded and installed. ;)
Photo of Tom N5MOA

Tom N5MOA

  • 81 Posts
  • 23 Reply Likes
I signed in and verified the account through "SmartLink Login <no-reply@auth0user.net>". At that time, I had downloaded the file, but then found out it was corrupted.

I don't recall seeing anything like that.

Did you download the installer from here?

http://www.flexradio.com/downloads/smartsdr_v2-0-17_installer-exe/

This video helped me https://youtu.be/Umt3q0Uwk0Y  Easy enough I could do it. I didn't un-install anything, but I did close DAX/CAT and power down the radio and pwr supply before starting.

I also had to do this https://community.flexradio.com/flexradio/topics/v2-0-for-those-connecting-their-radios-directly-to-... 

since my internet connection is via AT&T WIFI. 6500 straight to the computer, no router to plug into. Smartlink doesn't work, but I was able to finish the upgrade register. 

If you have already looked at the video, read the links and followed the directions, I'm out of ideas.

I know diddly about software and routers. I just follow the directions/suggestions of those who do. Thanks to them for sharing.
Photo of YV5WZ

YV5WZ

  • 415 Posts
  • 50 Reply Likes
Delete cookies in your browser.... you will solve the problem

George, YV5WZ / PY3ZZZ
Photo of Jerry - W2TXB

Jerry - W2TXB

  • 88 Posts
  • 17 Reply Likes
Official Response
OK... making some progress here... hauled the old reliable ThinkPad with me to a doc appointment and, while in the waiting room, connected to their WiFi. Downloaded the entire 51.6 Mb file without interruption in ~30 seconds. Now that is the download speed (Ping = 1, Download = 26, and Upload = 63) and connectivity I am used to! :) When I get home, I will use the old tried and true "SneakerNet" method to transfer (copy) the install file to the desktop PC and see how it works out from there.

When I get home, I will check the speed there again to see if Time Wiener/Sprectum has fixed their system. If not, a phone call to them will be next... that should be interesting.

Many thanks to all for the assistance here... will post up if there are any more problems.
(Edited)
Photo of Jerry - W2TXB

Jerry - W2TXB

  • 88 Posts
  • 17 Reply Likes
Update: Arrived home and checked my Internet connection. Out of the cable modem the Download speed was >120; Upload and Ping were markedly faster as well. Did several reboots and got the speed through the (five year old Netgar WNDR4500) router up to ~81 on download, and was able to download SSDR. Will deal with the rest of that later.

On to SSDR... I installed it and all went quickly and smoothly, except now I am getting the "License Required" message. Hit "Refresh" and no change. The radio is a Limited Edition, which I believe includes the software license (or not?). Will have to address this in another thread.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9154 Posts
  • 3506 Reply Likes
Jerry, Open a HelpDesk ticket so we can validate your license.  Make sure to include in your ticket that you have an LE radio
Photo of Jerry - W2TXB

Jerry - W2TXB

  • 88 Posts
  • 17 Reply Likes
Tim,

I just filed a support ticket; thanks again.

Jerry
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 3558 Posts
  • 851 Reply Likes
I think there were others having the same problem,,a help ticket should address it
Photo of Jerry - W2TXB

Jerry - W2TXB

  • 88 Posts
  • 17 Reply Likes
With Dudley's help, the problem will soon be solved... network switch is en route from Amazon.
Photo of Andrew O'Brien

Andrew O'Brien

  • 384 Posts
  • 44 Reply Likes
Just tried obtaining the installer , nothing downloading when I click on the link.
Andy K3UK
Photo of Andrew O'Brien

Andrew O'Brien

  • 384 Posts
  • 44 Reply Likes
Switching from Chrome to Edge solved the issue
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9154 Posts
  • 3506 Reply Likes
I test the web site extensively on Chrome (and FF, Edge and Safari (iOS)) and the download worked here.
Photo of Jerry - W2TXB

Jerry - W2TXB

  • 88 Posts
  • 17 Reply Likes
I am wondering how much the ability to download is affected by the security and privacy settings of a particular browser... used to run into this with downloading updates to the UConnect (and sometimes UDon'tConnect ;) )stuff from Chrysler. Safari for Windows (RIP :( ) worked flawlessly and quickly, probably because it's settings were normally pretty weak.
Photo of Jerry - W2TXB

Jerry - W2TXB

  • 88 Posts
  • 17 Reply Likes
Official Response
Update: The network switch arrived today and I connected everything as suggested. Connected to the radio and it worked instantly; it registered the radio, and appears good to go. Although I will not be able to use SmartLink for the time being, I did the setup anyway.

Thanks again. :)

This conversation is no longer open for comments or replies.