Bug Missing Dahs

  • 1
  • Problem
  • Updated 2 years ago
I have a Begali Intrepid. It is similar in function to a Vibroplex mechanical bug. I have this weird issue and I can't figure out the cause. I'm not sure I can explain it well.

The dits rattle off just fine but the dahs drop randomly. When it drops, if I continue to hold the dah down it continues to not be detected by the radio. A quick release and dah again and it is good. It's almost like the 6500 is ignoring the dah at random times.

I've tried all the normal stuff - replacing the cable, cleaning the contacts with no success. Same symptom. I use the bug on my KX3 without issue. I use paddles and straight key on the 6500 with no issue.

The only thing that works consistently for the bug is if I insert my Logikey K5 in between the bug and the radio. Now nothing is lost. I just don't want to have to use the K5 as it shouldn't be necessary and I dislike the clutter on the desk.

Is there something in the debounce logic that may be causing some dah's to be ignored? Is there some other test I can do to try and clarify the situation?

Setup is 6500 with v1.7. Mode is CW. Sidetone is on, breakin and iambic are off (not an RF issue).

Kev K4VD
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes

Posted 2 years ago

  • 1
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes
Another symptom to add. I have a straight key in parallel with the bug. When the dah is ignored on the bug I can hold the straight key down and it is still ignored. It's not until I release the key and press it again do I get a tone. It's like something is triggered within the 6500 to ignore the key down and it will keep ignoring it until there's a key up and key down again. Maybe it is some fluke of my fist and the Flex sees it as a key bounce and ignores it?

I'll open a ticket but thought I'd try here first. Curious if any other mechanical bug users (any model) have seen such a thing.