Audio popping in 2.3.7

  • 2
  • Question
  • Updated 3 months ago
After upgrading to 2.3.7 I have noticed loud "pops" when receiving CW and at the same time the SmartSDR display pauses. This is quite random but they are very noticeable and loud in the headphones.  When transmitting, the transmitted CW character sidetone is interrupted and I really don't know if the transmitted character is also interrupted. Anybody else experience this? I believe the previous S/W version addressed this issue and it was quite successful in virtually eliminating the popping but now it is back.
Photo of W9ILY

W9ILY

  • 52 Posts
  • 4 Reply Likes

Posted 4 months ago

  • 2
Photo of W9ILY

W9ILY

  • 52 Posts
  • 4 Reply Likes
Well, it's fixed and here what happened. Last night the pops and snaps and CW pauses were so bad it was not usable. So I downgraded to 2.2.8 and all was OK there as it had been in the past. So I upgraded back to 2.3.7 and the pops/snaps did not reappear. All was OK. The only issue was that when I downgraded my CAT ports all disappeared and when I upgraded to 2.3.7 they were still gone. I reconfigured everything all all is OK now.
Photo of W9ILY

W9ILY

  • 52 Posts
  • 4 Reply Likes
It appears that the sharp snaps are back but not to the extent that they were in the past. However, in the past I thought the snaps were only in the audio output BUT I noticed something disturbing during the NAQP-CW contest yesterday. On at least two occasions when transmitting there was a snap and the transmitted character was interrupted. This was at about 26 wpm and on both occasions I was asked for a repeat of my name (John). During the other more than 500 Qs I believe I may have been asked for a repeat two times, probably due to normal fading, so this is a really big concern. When the snaps occur during receiving, the received character is also interrupted and I usually have to ask for a repeat. I also noticed that the SMART-SDR display on my screen pauses momentarily.
I sure hope this issue can be corrected as it is very disturbing.
Photo of Marty Ray

Marty Ray

  • 12 Posts
  • 0 Reply Likes
I am having the same problem with my 6600M. I did a cold boot this morning, which appears to have helped.
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2955 Posts
  • 639 Reply Likes
A proper cold boot is a must...
Photo of Bob Wright, N7ZO

Bob Wright, N7ZO

  • 268 Posts
  • 66 Reply Likes
The audio popping was one reason I had to downgrade my 6700 from 2.3.7 to 2.2.8.  I commented on it in this thread (https://community.flexradio.com/flexradio/topics/smartsdr-2-3-7-its-deja-vu-all-over-again-and-again... ) but that was more focused on the disconnect bug.
2.3.7 pops in both SSB and CW, but the CW popping is more noticeable.  I still get occasional pops in 2.2.8, but not nearly as bad.
I should note that these pops are using the speaker out on the back of the radio, NOT audio through the PC.
(Edited)
Photo of Bob Wright, N7ZO

Bob Wright, N7ZO

  • 268 Posts
  • 66 Reply Likes
SliceMaster was not being used here when I was getting the audio popping.
Photo of AA0KM

AA0KM

  • 341 Posts
  • 59 Reply Likes

As soon as these pop-outs or what ever they are called happens I get  2 pops in the speaker output from flex-6500.

These Pop-outs are created from Slice-Master-6000 V0.10.5d latest version.

It is reproduceable every time Slice master is started.

 So not sure which version is doing the popping at this point.

 Weak sound click/pop as it may be never was there in earlier versions of SDR and of Slice master.

Once slice master is running and  on occasion there will be this tick or pop noise.

Very random hourly  except on start up It is every time.

Almost like static discharge noise.

 Is it the Flex software update 2.37 or Slice master 0.10.5d?


Photo of AA0KM

AA0KM

  • 341 Posts
  • 59 Reply Likes


LSB SSB 20 meters Startup of slice master. These kept popping up so I had to stop slice master.

But then a few times I ran it and it stopped @6 of these only.

My DAX is loaded but not turned on and also just on 20 meters nothing else but flex software and slice master running.

I know dont run LSB.....lol But yes and get some pops with this as well.

It seem that the EQ Rx on or off has some effect.


Next I will go to 20 meter profile only and see what happens.


Photo of K1UO - Larry

K1UO - Larry

  • 802 Posts
  • 128 Reply Likes
Is there a reason for cranking all Octaves of the RX Equalizer all the way up to +10? 
Just curious.
Photo of Jay / NO5J

Jay / NO5J

  • 1571 Posts
  • 227 Reply Likes
My guess, not really.
To each his own misconfiguration, it's all about Flexibility right? 

    #FlexRadio IRC chat

For real-time discussions

        SDRgadgets

User created documentation.
           Volunteer!!

         73, Jay - NO5J

Photo of AA0KM

AA0KM

  • 341 Posts
  • 59 Reply Likes

No Larry not even sure why they were all the way up.

Something I was testing when I took the picture.


Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4015 Posts
  • 1240 Reply Likes
I keep them flat for all modes:

UNLESS I am peaking a CW signal...Then I put the 500Hz all the way to the top and drop everything else to the bottom.  It adds some additional audio enhancement.

or unless I am listening to a weak phone signal or a badly EQ'ed one and need to raise the 1K, 2K & 4K a little and drop the 63Hz, 125Hz, 250Hz, & 8K to the bottom.

RX EQ is a great help, but my understanding is that running all to the top will give an RX profile with ripples or peaks surrounding each of the slider's center frequencies. It won't be perfectly flat like it will with the sliders all at zero. 
Photo of AA0KM

AA0KM

  • 341 Posts
  • 59 Reply Likes

I ran it on my 20 meter profile USB and get the pops and normal 2 pop-outs.

I ran it 20 meter profile and only changed it to LSB and got 16 pop-out ip panels then one by one they disappeared normally.

Something is crossing stream paths with something. 

73 Jeff

Photo of N8SDR

N8SDR

  • 120 Posts
  • 21 Reply Likes
What I have noticed,

Don - Slice-master- Master has commented on as well- the audio popping is something that Flex needs to address, while yes it is more noticeable in the D version of slice-master.

To avoid the many popups of Slice-master saying connected, contrary to how I had in past versions of Slice-mater , I noticed you have less and it seems more stable if you start things in this order.

1) Start Slice-master first
2) Start SSDR second
3) Start any additional applications after SSDR is up and running.
Photo of AA0KM

AA0KM

  • 340 Posts
  • 59 Reply Likes

 Yup startup in order and especially for this new 2.3.9 ssdr version other wise it is ip pop-out galore.


Photo of AA0KM

AA0KM

  • 341 Posts
  • 59 Reply Likes

Going through the steps interrupts the audio as well with only SSDR running.

I don't recall this doing that before 2.3.7....


(Edited)