Audio Musings: RX Streams, RX Gain and the Meter in DAX; Sampling Rates

  • 1
  • Question
  • Updated 11 months ago
I've had the Flex 6500 for a while now and still seem to learn new things all the time. I recently posted a picture showing my transmit audio level. I had the levels set (for digi modes mostly) just below the level where the peak indicator would turn red. No red, I'm good. I thought I had read this was the right thing to do. After being disabused of that idea I began questioning the rest of my audio setup.

Looking at DAX, RX Streams Slice A, what is the meter telling me? If the meter is getting to zero does that indicate I'm over driving something and getting some distortion on the receive audio? Is this something I have to set to keep below zero on the peaks? It's always red so that's no indicator.

As I work mostly digital modes I have AGC turned off. In a 3 or 5 KHz filter that leaves lots of opportunity for a single strong signal to peg the audio meter against the stops. I generally control the levels by riding the gain control, is it called AGC-T even with AGC off? But I never pay attention to the meter in DAX.

Am I overthinking this stuff or are there common guidelines for the receive audio setup.

While on the topic of audio settings, I read in the manual or FAQ or something (meaning I might have made it up) that I should change my audio driver sample rate from default 44.1 to 48 KHz to reduce the impact of sampling errors. I wonder if there's any advantage of running the sound card sampling rate (TX and RX) at a multiple of 48 KHz? My I/Q settings are set for 192000 (4x 48 KHz) for CW Skimmer. Is there any advantage to setting a higher sample rate in the driver for the slice streams if the computer can support that?

Lots of discussions on getting good voice audio. I'm wondering about getting the cleanest TX and RX audio for digital modes.

73,
Kev K4VD
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes
  • droopy

Posted 12 months ago

  • 1
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 3911 Posts
  • 1187 Reply Likes
Kev.  Depending upon the waveform, you may want to stay a notch or two below the "0."

I think Tim said something like "grazing the red once in a while is OK...having it bump it regularly or letting it stay there for a long period of time is bad..."  (My paraphrase.)

Making sure your sampling rate is evenly divisible into 48000 is good.  DAX installs already set to 48000.
Most Digi programs are set to even numbers... 8000, 12000, 24000, so that is fine.

RE:  AGC-T ... In very weak signal modes, I will sometimes use OFF and set it so that very strong signals do not drive the receive audio into distortion.  As long as it is clean audio, and enough for the decoder to function, the Digi programs have a lot of dynamic range and you don't really need to ride the gain control.... If the volume is too loud for your human ears, turn the local speaker volume down. In fact, if you keep riding the gain in the JT modes, you will always be cutting the weak ones out of the picture.

In other digi modes, like rtty, or FT8, I use FAST and set the gain just a little higher than the "Knee" or Sweet Spot.  I haven't noticed any great reduction of signal decoding.  Others may have different advice.

Note - using DigiU is the standard for most Digi modes.  It disengages the PROC and TX EQ in order to keep your TX audio cleaner for Digi.  Do not use USB or LSB for Digi modes.  The PROC can wreck havoc on Digi signals, as can the TX EQ.

RE:  Mic gain in Voice modes... Just for fun, have a look at my Youtube video on "A tour of my audio profiles."
it needs a little update, but in about the last quarter, I talk about "How to make a Flex sound BAD."

You can, if you are boosting the Bass frequencies significantly and using the Processor, overdrive the processing stage and sound really bad, even if you are not bumping the audio control into the red.

Some of my friends in broadcasting used to use a phrase to describe the effect of Hyper Bass Boost.  The anatomical reference translates roughly to "Giving you ....Gravitas"  or "Boosting your Testosterone Production."

I have found that when guys do this on SSB, it creates a strong "droning" carrier at a frequency between 60-150 Hz that is really irritating to listen to.  It also tends to overdrive the Processor and/or create artifacts in the audio chain that show up as distortion.

If using the PROC at more than NORM, it is usually advisable to bring your Lo Cut up to 150-300, and drop the TQ EQ below 250 Hz so that you don't overload the PROC or other mic circuits.  (if you are cutting everything below 300 Hz, it makes no sense to send lots of 63, 125 & 250 energy to the mic circuits.)

The best thing to do, in any case, is set yourself up to monitor your own audio using 2 slices and FDX.  Transmit into the XVTR port, and listen with a good set of headphones, or record your own signal and play it back.  Make sure that you have your receiving slice bandwidth at least as wide as your transmit signal.

The best way to keep from "overthinking it" is to experiment with it in a safe mode.....listen to your own signal, and adjust the TX EQ sliders up and down, one at a time, until you learn to discern what effect each slider has on the quality of your audio when boosted or cut.

There is an excellent article on the Flex Website about this:

http://kc.flexradio.com/KnowledgebaseArticle50114.aspx

Let me know if you need any more help.

Ken - NM9P
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes
Hi Ken... your posts are always helpful and this was no exception. In fact, I was referring to your posts and vids concerning good voice setup and was asking about similar concerns for digi audio setup.

So one of my questions concerned selecting the sampling rate. Should I set things for 48 KHz or some multiple higher that my computer supports? I get the impression there probably is not any advantage to using a higher sampling rate? If the source is sampled 48 KHz nothing is gained by sampling that at 96 KHz.

As it is digital, I am using DIGU so no proc, eq or anything else in the path. Just wanting the cleanest signal outbound and inbound.

This meter...

How is it adjusted? If it is pushing zero is it distorting the incoming audio?

On transmit, I think I'm OK. I have backed it out of my previously hot position. I  have one of those KK7UQ PSK IMD meters and it always shows a reasonable value of -28 dB or lower (most often -30ish dB) for IMD. It showed those same values when I was apparently set too high also. But I feel safer now.

I posted a question to the FLDIGI reflector. I have to restart fldigi every few hours as the decoding and waterfall presentation degrades to the point where I can't copy any signals. Restarting fldigi and things clean up very nicely. Not sure if fldigi is the real problem or some other setting associated with the whole system.

Again, thanks for the response. Good things to think about.

73,
Kev K4VD
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 3911 Posts
  • 1187 Reply Likes
Thanks, Kev.
All of the normal DAX channels are set for 2 Channel, 16 Bit, 48,000 Sample rate (DVD Quality).  Setting them any higher at this point won't help anything, as far as I know.  I think that is the max that is supported in the DAX Driver.  I always select the highest sampling rate available on individual 3rd party Digi programs.

The DAX IQ, on the other hand, will go all the way to 192,000 Sample rate, and is useful with things like CW Skimmer at that higher rate, though most I think are using 96,000 for DAX IQ right now, because that is about as wide a CW band as is often used in a contest.

If you FLDigi decoding goes haywire, I would suggest closing and restarting the DAX utility, rather than FLDigi, and see if that helps.  There seems to be a memory overrun or something in the DAX Driver that occasionally clogs up (highly technical term).  Toggling DAX off and on usually corrects the problem.

If not, then that particular problem may be a FLDigi problem.   I remember hearing that one of the versions had a glitch that raised its ugly head once in a while.

Make sure your FLDigi is updated to the latest version.

I haven't used FLDigi for a while...since V. 3.23.20.  I am going to update and test some more myself with V. 4.0.9.8.

Good luck.

Ken - NM9P
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes
DAX was restarted without any change. The big difference came when fldigi was restarted. I posted on the fldigi site but not seeing any responses nor any previous reports so it will be one of those things that either goes away or I work around it.

73,
Kev K4VD
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes
Here's a couple of screenshots showing what signals look like after a few hours of running fldigi and then again after I restart fldigi. Nothing else was done other than the restart of the application (and the fldigi-dxlabs-gw).

This is what things looked like this morning (looks bad):


Here's close to the same time on SSDR (looks good):


And here's what it looks like after restarting fldigi (looks good):


Not sure the problem is with fldigi. I haven't tried this yet with WinWarbler. WSJT-X and JTDX don't seem to have this issue but the signals are quite a bit different so I'm not so sure I'd notice. According to the FLDIGI documents, it seems to prefer the native sound card sample rate of 44.1 KHz but has settings for other sample rates. I'm running at 48 KHz as suggested by Flex. I'll keep poking the fldigi group list but if anyone else has seen this behavior I'd like to hear about it.

73,
Kev K4VD
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9130 Posts
  • 3453 Reply Likes
Always change Fldigi sampling rate to 48k.  The 44.1 sampling rate a "compatible" sampling rate for older sound cards that used this rate as their default.

DAX is running at 48k and you do not want Windows doing any sampling rate conversions as it will introduce artifacts into the bit stream.
(Edited)
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes
Understood but not to confuse the issue, after initially changing from 44.1 to 48 I still notice the problem after running fldigi for about a day. I've shut down fldigi now and going to run WSJT-X and look to see if the fuzzy issue exists there.

I also have a post on the fldigi group but no comments to it yet.

Kev