Audio break up, (stutters) and the signal display stutters v1.4 & 1.43 Remote

  • 1
  • Problem
  • Updated 5 years ago
  • Solved
I previously posted about this under another subject, thinking that it was related to the freezing problem some others were having - "SmartSDR 1.4 rx intermittent pauses" - https://community.flexradio.com/flexradio/topics/smartsdr-1-4-rx-intermittent-pauses

Sorry for the lengths but I've been working on this for several weeks.. it all added up, including some of the additional expenses. I'm posting this message about my experience with the hope that there can be a solution.

Here is what I have tried and the results I have found.

- This only happens when using WiFi and the new Remote mode.
- The problem happens intermittently with SmartSDR v1.4 & 1.43.

- Operating System: Windows 8.1
- No DAX connections
- I reset the 6500
- Laptop was the only computer turned on for the tests.
- using 5ghz WiFi, no other users on my network and on other 5ghz users in my are.
- tried using 2.4ghz WiFi where the are lots of other users in the area, it makes no difference.

It makes no difference where my laptop is located, even when it is with in 3 feet of the router I still have the same problem.

I have read the Flex information on what to check. I tried everything including the running the DPC Latency tests. This laptop passes all the tests without SmartSDR running. I have tried several laptops and have updated my network to use the latest high end wireless router.

Laptops tried: Dell & HP with the same specs

CPU  - i7 dual core
       RAM   - 8gb
       Video - Nvidia (2gb dedicate memory)
       OS    - Windows 8.1

Next I bought another laptop with slightly better specs

CPU  - i7 quad core
       RAM   - 8gb
       Video - Nvidia (2gb dedicate memory)
       OS    - Windows 8.1

Over all performance is better with the i7 quad core.. (much lower CPU load)
In all cases, the Nvidia graphic was enabled.

The problem exists on all laptops...

Observations:

The audio breaks up, (stutters) and the signal display stutters. It only last a few seconds and is very random. Happens on all bands even when not tuned to a signal. It also happens while transmitting but I have had no reports of the receiving station loosing any of my transmission.

It can happen in two different ways:

1)- Audio break up (stuttering) and display is choppy. No other indications from SmartSDR.

2)- At other times, when audio breaks up (stuttering) and display is choppy, I see a change on the SmartSDR network indicator (on bottom bar). It will quickly go to all gray bars.

The audio and video will recover - when all bars on the SmartSDR network indicator are gray, long before the network indicator returns to all green.

It can happen when the SmartSDR network diagnostics shows:
- Network Status Excellent
- Latency =1
- Max Latency =2
- Dropped =0

At other times:
- Network Status Poor
- Latency = 277
- Max Latency = 277
- Dropped =2

-------

You have to watch the SmartSDR network indicator closely to catch this - it shows reduced network signal strength quickly going to 2 yellow bars, then 1 red bar, then all gray, it goes down down quickly and then slowly reverses back through the same cycle until it is all green, again. The actual audio/video problem happens much faster.

The audio & video breakup corrects itself, while the network indicator is still showing all gray or one red bar, long before it goes back to all green. This happens very quickly and even when no network signal is shown, SmartSDR does not loose connection with the 6500 and keeps receiving. Transmitting in SSB doe not seem to be effected, other that the video display of the signal, compressor and power output not being in real time. I have observed the event happening but have never had any complaints of comments from the station on the receiving end.

- I see little, if any, change shown in network usage on the Windows Network monitor.
- SmartSDR CPU usage drops during the event,
- the 5gh WiFi connection is solid all the time, speed over 400, no other  users on the   network or in the area. 
- the SmartSDR network indicator normally shows all bars green, except during the   audio/video stuttering event.
- when the event starts there is often a Latency of 200 - 277 indicated on network diagnostics with few dropouts..
 
Another test

I run SmartSDR on my main computer, connected to a wired LAN, then connected to it from laptop on WiFi) using TeamViewer.. To get audio on the remote PC I used TeamViewer audio transfer function, remote was activated on the main computer. I listened and made some test transmissions via the TeamViewer connection from the laptop.

No problems with the audio & video break up during a 1 hour plus test.. The laptop had the resources to pass everything in close to real time using TeamViewer.

Another test

I also tested SmartSDR on an older dual core laptop, win7 & 4GB RAM. All worked fine until the  audio/video stuttering event started. SmartSDR was not able to recover on this laptop. It was interesting to observe that while the Latency indicated around 250, the dropout counter just kept going up as fast as it could without stoping.
 
Conclusion

This problem is a real annoyance but does not stop the use of SmartSDR in Remote.

I've tested all that I can, isolated SmartSDR on the network and nothing has changed the situation. Using a wired connection solves the problem but has it's limiting factor.

I can't tell what is happening with SmartSDR. Is it possible that it is being over protective of the connection or something is happening when it sees higher latency that can be changed to improve this?

Ken - VE5KC
Photo of Ken - VE5KC

Ken - VE5KC

  • 52 Posts
  • 14 Reply Likes

Posted 5 years ago

  • 1
Photo of hans weijers

hans weijers

  • 31 Posts
  • 8 Reply Likes
I do have exactly the same problem : in remote mode audio/video dropping out intermittently on my HP 6550b i5 laptop with 4Gb ram. I tried out some other laptops with the same results.
Ken's description of the problem is the same as what i see here.
I do have a dedicated internet connection / IP address with a 300N WiFi router connected.
SmartSDR is the one and only user of that network and the main PC is disconnected from the router.
Windows reports an excellent network performance,  most of the times the SmartSDR indicator is fully green.
Then once on a sudden the SmartSDR indicator goes to grey and the intermittent audio/video starts.
Main processor load is 14% of which SmartSDR takes about 10%.
No other programms are running on the laptop and even in this situation Windows reports : Excellent network connection.
SmartSDR reports poor network status, latency 1ms, max latency 400ms, remote RXrate 97kbps.
Settings in SmartSDR: No DAX, AVG=50, FPS=15, rate=70
Sometimes these intermittent conditions dissapear without any obvious reason, another time the connection is lost and reconnecting is impossible because SmartSDR indicates FLEX6300 in use and most of the times slowly the normal condition returns.
I cannot put my finger on it and the question is : what is happening and how to prevent this strange behaviour ?
I hope somebody has a acceptable answer on this matter.
best 73,
Hans - PA0HWB
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9197 Posts
  • 3557 Reply Likes
If the SmartSDR network indicator goes gray, the quality of your wireless network connection has degraded or there is an internal PC system latency that is preventing the reliable transfer of streaming data, regardless of CPU utilization and what Windows reports as network quality indicators show.  A max 400ms RTT is too too great.
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 3972 Posts
  • 967 Reply Likes
I think most people understand there is something going as to how remote uses computer resources and I think Flex is checking into it. How ever there has been some discussion about this and many have found by making changes to things like having no water fall or changing video properties solved the problem for them. It is also best not to use any windows drivers for your video or audio. Get the drivers from the makers of the components.
Photo of Burch - K4QXX

Burch - K4QXX

  • 538 Posts
  • 132 Reply Likes
Ken, I have experienced exactly the same thing.  Still having a blast with the remote operation but this is a bit of an annoyance.  When this happens, my laptop has a great wifi connection and the CPU is low so I don't think it's a laptop resource problem.
Photo of Jim Gilliam

Jim Gilliam

  • 462 Posts
  • 71 Reply Likes

Just for comparison, You might try connecting the client computer directly to the router and see if the problem persists.


Jim, K6QE

Photo of Joe, KQ1Q

Joe, KQ1Q

  • 79 Posts
  • 21 Reply Likes
I had problems like this on an older Toshiba C655 laptop with 2.1Ghz dual-core i3, 8GB RAM, on Windows 7. CPU consumption was not excessive, and SmartSDR net stats looked good, but somehow the latency was causing stuttering and dropouts, esp. on Tx. This was despite the WiFi network being fast (50 megabit/sec using SpeedTest.net and PingTest.net) .

I reviewed all apps on the laptop (whether I thought they were running or not), then used Control Panel "Programs & Features" to remove non-essential ones. I then used MSCONFIG to check and eliminate unwanted startup programs. After that I updated the BIOS and video driver. Toshiba's HD3000 video driver was old, so I had to get the updated one from Intel's site.

In SmartSDR I then reduced the frame rate to a lower number.

After all that it actually worked pretty well on both Tx and Rx. -- despite being below the minimum equipment spec.

WiFi routers are very important in these situations. Mine is an Asus RT-AC66R, which is pretty fast. I don't know to what degree that was a factor. However I've tested various cheap ISP-provided routers and they are often sluggish even at close range. Besides the speed, newer routers and WiFi specs use performance enhancing techniques like beamforming, MIMO, etc. Of course no matter how fast the router is, a downlevel client will negotiate and use lower speed and methods. But even my 2011-vintage laptop is working OK via WiFi on SSDR 1.4.3, albeit just barely and after significant tweaking. This laptop does have an upgraded SSD hard drive, maybe that helped some.

If anyone has an older PC or laptop, it's worth considering doing an SSD upgrade. This is very easy, you don't lose any data nor have to re-install apps. It often transforms the utility of the machine. See http://www.crucial.com/ However this by itself will not magically make a PC which is vastly below the minimum specs work with SSDR.
(Edited)
Photo of Duane, AC5AA

Duane, AC5AA

  • 462 Posts
  • 103 Reply Likes
Ken - I'm seeing exactly the same thing with my 6500 when running on a WiFi (but not "remote").  There was no hint of a problem in 1.3.8 and earlier versions, but the bahavior I have seen is exactly as you have described.  If I cable the PC to the router via ethernet, I don't see the problem, and I'm running a fast router and NIC with only a couple of feet separation between the PC and the router.  Again, not a hint of this problem in pre-1.4 releases.  Thanks for the excellent description. 
Photo of Jim Gilliam

Jim Gilliam

  • 462 Posts
  • 71 Reply Likes

I don't understand that this problem didn't persist on lower releases. 1.4 is the first time the remote feature became available. Are you, then, referring to using the DAX to remotely transport your audio?


Jim, K6QE

Photo of NX6D Dave

NX6D Dave

  • 314 Posts
  • 96 Reply Likes

Sounds like a good candidate for buffer bloat to me:

http://en.wikipedia.org/wiki/Bufferbloat

Some manufacturers of routers and switches don't understand how TCP is meant to work.  They have incorrectly assumed that by making internal buffers larger, they can increase throughput.  I suggest running the tests described in the Wikipedia article.  If you detect buffer bloat, you could try to reconfigure the offending piece of equipment, or replace it.

I'll assume that the network specialists at FRS are aware of this.  If not, then there may be some opportunities to tune the TCP stack in the radio.

Finally, I'm assuming the packets running between the radio and SSDR are TCP and not UDP.  Someone with wireshark can set me straight if they are UDP.  For that matter, wireshark can probably confirm or disprove the existence of buffer bloat.


Photo of Jim Gilliam

Jim Gilliam

  • 462 Posts
  • 71 Reply Likes

It would be interesting to survey the types of routers used. I use a Linksys (Belkin) WRT1900AC (the latest model) and have had no problems at all.


Jim, K6QE

Photo of Robbie - KI4TTZ

Robbie - KI4TTZ

  • 484 Posts
  • 78 Reply Likes
I'm using a Asus AC68U, i'm very happy with it, best router I've owned so far.
Photo of Duane, AC5AA

Duane, AC5AA

  • 462 Posts
  • 103 Reply Likes
But wait, before you answer the router question, are you using WiFi?  Because if you're cabled, there should be no problems.  And this is not always a "remote" issue, because I ran my 6500 from my Wifi connected shack computer (2' away from the router) with no problems until now.  My AT&T Uverse router worked fine before 1.4, so why does it now have this problem when, reportedly, the CPU and other processing has decreased so much in 1.4 and 1.4.3?  That's what doesn't make sense to me.  Why is this not a 1.4.x problem?
Photo of Jim Gilliam

Jim Gilliam

  • 462 Posts
  • 71 Reply Likes
Wired, WiFi, 2.4 GHz. 5 GHz. absolutely NO problems.
Photo of Wayne VK4ACN

Wayne VK4ACN

  • 17 Posts
  • 6 Reply Likes
Not sure if this will help. I bought a new laptop, i7' 16g ram, gtx860 video card for flex remote. Had same problem on 5ghz wifi. I did notice it would happen if i opened windows explorer, or if i clicked on network icon on taskbar and charms slid accross with available wifi signals. The signal would drop to yellow bars and take a couple of secs to recoop. Did read on net that intel ac 7260 wireless chip has intermittent dropouts. Updated to latest driver. Same problem. Bought myself a USB Netgear A6100 Wireless-AC600 Dual Band Mini Network Adapter. So far no dropouts, and opening explorer or other things has no effect on flex remote.
Works a treat now

Hope this helps
Cheers
Wayne. VK4ACN
Photo of Ken - VE5KC

Ken - VE5KC

  • 52 Posts
  • 14 Reply Likes
Hi Wayne....   THANK YOU!!

If there was a winner, the prize would go to you!

The problem would seem to be the integrated Intel Wireless in ALL the laptops I have tried.

Following your information, I remembered I had a Linksys AE3000 USB dual band WiFi adapter I used for another project, with an older computer. I dug it out, hooked it up to my NEW fancy laptop, installed the drivers and got it working. 

The results, NO MORE STUTTERING audio and video! Max latency all evening was 35 with latency staying at 3 the majority of the time.

The problem with the Intel WLAN was too much latency. Despite the  AE3000 being a few years older then what is in this laptop, it does the job much better!  It uses the Ralink Technology chip, NOT Intel.

I will be trying this USB WiFi stick on some other computers next.

73..  Ken - VE5KC
Photo of Wayne VK4ACN

Wayne VK4ACN

  • 17 Posts
  • 6 Reply Likes
Glad it worked for you Ken.
Cheers
Wayne
Photo of MH_Flexer

MH_Flexer

  • 65 Posts
  • 13 Reply Likes
You might try adding a 4 Port Switch between the Flex and the Router. I have an inexpensive Netgear Switch and am using a high end Netgear R8000 wireless router. The only times I have any audio stutter is when I am quite far from my router (> 100 feet). When I get on the edge of the wireless range, my latency goes high and eventually get the stutter and disconnect of the Flex.

Duane
Photo of Ken - VE5KC

Ken - VE5KC

  • 52 Posts
  • 14 Reply Likes
Official Response
Thanks to all who have replied and made suggestions..

The winner with the working solution is Wayne. VK4ACN.

The Intel integrated WiFi was the problem causing excessive Latency.

The solution - use add on USB non Intel WiFi..

In my case the Linksys AE3000 works great.

73 ..  Ken - VE5KC
Photo of Peter Kirsop

Peter Kirsop

  • 36 Posts
  • 4 Reply Likes
I also experience the drop-outs on my Lenovo ThinkPad when connected wirelessly.  This is when the laptop is close to the router and has excellent signal strength.  Video streams well with no buffering so I am sure that the router is working well.  If the problem is down to the Intel chipset it will affect a significant number of SSDR users.
There are no problems when I connect the laptop with ethernet.  It would be good if there is a fix for this issue, but at least there is a suggested workaround although I have not yet tried it as I do not have a WiFi stick.
Photo of Wayne VK4ACN

Wayne VK4ACN

  • 17 Posts
  • 6 Reply Likes
I have no problems with the wired ethernet to the laptop, just the inbuilt wireless, but the usb dongle seems to solve it.

This conversation is no longer open for comments or replies.