Anyone using new 6400-6600 with Acom 600S and have band sensing operational?

  • 1
  • Question
  • Updated 2 months ago
Asking if anyone has had success connecting the new 6400/6600 model to the Acom 600S amplifier and having the band sensing feature operational. The Acom 600S predates the new Flex 64/6600 units and does not list/ recognize Flex.
The few existing posts about this Acom 600S connection issue are all quite old and deal with the 65/6700 models.
Anyone have success with band sensing (freq counter in Acom) with the 6600 or have information/suggestions? Thank you.
Photo of sky

sky

  • 16 Posts
  • 3 Reply Likes

Posted 2 months ago

  • 1
Photo of K1SZO

K1SZO

  • 32 Posts
  • 0 Reply Likes
I sure hope so as this was the amp I was intending to purchase for my KX3, but would love to be able to hook it up to my 6400 also.
Photo of KK9W - Steve

KK9W - Steve

  • 632 Posts
  • 189 Reply Likes
Not me but my Palstar LA-1k works flawlessly with my HF Auto and flex. Just a quick 1 second hit of the tune button on the radio and you are good to go
Photo of WX7Y

WX7Y

  • 527 Posts
  • 97 Reply Likes
The 6600 /6400 will interface the exact same way as the 6700 / 6500's 
You will need the FTDI cable plugged into the USB port on the back of the Radio the same as the 6700/6500's and it is in the FLEX 6600/6400's.
Found this VERY QUICKLY doing a Google search https://morsetutor.com/2016/12/flex-6500-usb-serial-to-acom-600s/

Looks like you can use RS-232 cable to talk to the AMP in order to BAND steer the AMP  so be sure to buy the right cable for the type in interfacing you wish to do.

the Flex radios ONLY work with the official FTDI chipset cables. 

73's
Bret
WX7Y
(Edited)
Photo of sky

sky

  • 16 Posts
  • 3 Reply Likes
Thanks for your assistance Bret.