Antenna Genius

  • 3
  • Question
  • Updated 4 months ago
Are there plans to integrate Antenna Genius controls into Version 3, similar to the integration of PGXL?
Photo of WA5YOM

WA5YOM

  • 64 Posts
  • 2 Reply Likes

Posted 5 months ago

  • 3
Photo of Kari Gustafsson SM0HRP

Kari Gustafsson SM0HRP, Elmer

  • 285 Posts
  • 36 Reply Likes
To my experience the AG 8 x 2 works fine with v.3.0 but I have found some issues when running remote. But you may have an other AG like 6x2 or ?  
Photo of WA5YOM

WA5YOM

  • 64 Posts
  • 2 Reply Likes
I have the 8x2.....the app to is only accessible through remote desktop....but I am hoping it will be integrated into v3....I have found that I need to run Remote Desktop when running Remote....which imho is not ideal...
Photo of Clay N9IO

Clay N9IO

  • 605 Posts
  • 161 Reply Likes
I follow what you are saying.
It really would be huge to incorporate AG control panel into SSDR 3. A plus is that it's a Signature Series device so really incorporating AG (and) PG is a great idea.
Photo of Kari Gustafsson SM0HRP

Kari Gustafsson SM0HRP, Elmer

  • 285 Posts
  • 36 Reply Likes
I use the AG windows app at my home PC that I direct to my remote AG IP-adress where the radio also is. No PC at remote radio site. It works well. Perhaps you have tried this.
Photo of WA5YOM

WA5YOM

  • 64 Posts
  • 2 Reply Likes
Your remote PC s on the same network?
Photo of Kari Gustafsson SM0HRP

Kari Gustafsson SM0HRP, Elmer

  • 285 Posts
  • 36 Reply Likes
I have no PC at radio where the AG is. From home I use PC with the application to choose antennas. And I can switch between several antennas for one band with BCD decoding with AG.
Perhaps this schematics clarifys my set-up.
Photo of Bob G   W1GLV

Bob G W1GLV

  • 790 Posts
  • 144 Reply Likes
If you run with the BCD protocol, Antenna Genius will switch programmed antennas according to the band your operating on.
Photo of WA5YOM

WA5YOM

  • 64 Posts
  • 2 Reply Likes
Well..that is a good way for remote without access to the application...but I have more than one antenna that can work on a band...thus the only way I can make a choice is with the application...unless I am missing something...
Photo of Bob G   W1GLV

Bob G W1GLV

  • 790 Posts
  • 144 Reply Likes
I hear you, that becomes a problem during remote operation. I use remote desktop to do that.
Photo of Mike - VE3CKO

Mike - VE3CKO, Elmer

  • 540 Posts
  • 273 Reply Likes
I also have a 6700 but after upgrading to AG v3.08 I have problems. Using the software app my AG 2 x 8 works fine in SO2R mode, I can switch A and B antennas that have been setup for each band. However with the 6700 anytime ANT2 get selected as in a 2nd panadapter or using DIV mode with ANT2 as 2nd antenna, all the B antenna on the display of app go red. The A side stays green and I can select A antennas no problem.
A support ticket was created and I made 4o3a aware on their forums. I've tried everything from reinstalling SmartSDR, reverting back to the AG to v3.0.0b. I've also did the DIP switch 8 flip so to reset AG. Still same result.
I do remember this, after loading and running the windows application, I did start SmartSDR and tested AG, then I remembered to update the AG firmware, maybe something got corrupt but you would think reverting to previous software would overwrite everything, unless there is an internal registry that got messed. Any suggestions?
Photo of WA5YOM

WA5YOM

  • 64 Posts
  • 2 Reply Likes
I had a similar problem after purchasing the AG...I contacted by the 4o3a team...but they never followed up.....eventually the problem went away...
(Edited)
Photo of Kari Gustafsson SM0HRP

Kari Gustafsson SM0HRP, Elmer

  • 285 Posts
  • 36 Reply Likes
Hi Mike, you say "Using the software app my AG 2 x 8 works fine in SO2R mode, I can switch A and B antennas that have been setup for each band." What differs this from the problem you encounter other than in DIV mode? I could not follow your thinking here.
(Edited)
Photo of Mike - VE3CKO

Mike - VE3CKO, Elmer

  • 540 Posts
  • 273 Reply Likes
Sorry, I should have explained more. What I meant by that statement is I can change antennas on both ports A and B as normal manually when SmartSDR is not open. The problem only occurs when using SmartSDR. See update below.
Photo of Mike - VE3CKO

Mike - VE3CKO, Elmer

  • 540 Posts
  • 273 Reply Likes
I had the AG unpowered overnight and found a recent post in the 4o3a forums regarding a possible corrupt config file with another issue, so I deleted that file and it created a new one below:

<?xml version="1.0" encoding="utf-8"?>
<Configuration xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"; xmlns:xsd="http://www.w3.org/2001/XMLSchema">;
  <FileName>C:\Users\Mike\AppData\Roaming\4O3A Signature\Antenna Genius\Configuration.xml</FileName>
  <Devices>
    <Device IsLocal="true" LocalIdent="1-1" Name="AntennaGenius" Address="192.168.219.140" Port="9007" Mode="Both - SO2R" Topmost="false" Location_X="-1904" Location_Y="-9" OML_X="0" OML_Y="0" OMR_X="0" OMR_Y="0">
      <FlexRadioA Active="true" SerialNumber="3714-4168-6700-xxxx" Antenna="ANT1" />
      <FlexRadioB Active="true" SerialNumber="3714-4168-6700-xxxx" Antenna="ANT2" />
    </Device>
  </Devices>
</Configuration>

FYE: I put "xxxx" to hide my serial #.
Then powered back up and it seemed to work kinda normal on all bands except 80m where any attempt to use ANT2 as in DIV or a 2nd panadapter, would turn all B port antennas red. On a couple bands it would cycle through a bunch of clicks on the AG before it would settle. I thought, hmmm some progress.

So overnight I again unplugged the AG and this morning plugged it back it in. Connected to AG, and now complete different behavior. Again any access to ANT2 via DIV or 2nd panadapter would turn all B ports antennas red. Some bands even had A port antenna all red for 10 seconds then go to normal. Quite bizarre.

Duplicated this behavior on my laptop where I installed a fresh v3.19 and new AG install. At first I could not access AG so I had to reinstall firmware, then behavior was duplicated. Then going back to the desktop I could not access the AG so I also had to reinstall the AG firmware, then got access but this bizarre behavior.

Again, this is only in SO2R mode. In Port A or Port B all seems to work fine, in fact to test the all the antenna ports I added 40m to all ports in the configuration. Connected first as port A and switched to 40m, all 8 antenna ports (green LEDs) showed up and was able to select all antenna ports as it should, repeated this for port B and again all antenna ports (red LEDs) were switched in as it should.

(Edited)
Photo of KF4HR

KF4HR

  • 795 Posts
  • 269 Reply Likes
Can someone fill me in on the availability of the Antenna Genius 8x2?  It looks like its available on the Flex website although its photo doesn't look like the latest V2 version on on the 4o3A website.  Is the AG V2 currently available direct from 4o3A or through FRS?   
(Edited)
Photo of John Langdon

John Langdon

  • 8 Posts
  • 0 Reply Likes
I have 2 AG V2 8x2 units, both purchased from Flexradio, set up in the master/slave configuration per the manual. They are hardware v4 and firmware 3.08 Apr 23, with a Flex 6700 and Smart SDR 3 usually remote via SmartLink. I can access all antennas and use any two for diversity reception, and manually switch between antenna choices if they are programmed for the same band. About once per day, the manual switching stops working and I have to reboot the AG from the "configure device" menu to restore it.  Also, if I am using Slice A on the Flex, which is normally associated with ANT1, and manually switch to ANT2 in the SmartSDR flag menu, the AG unit takes about 5 seconds to switch the antennas.  

I use Windows remote desktop connection to access the AG app on a PC at the remote site. It would be nice to have it all integrated within SmartSDR.

Is anyone successfully using an AG 8x2 with the Power Genius to do full power SO2R?

73 John N5CQ