Antenna Genius is awesome

  • 1
  • Praise
  • Updated 1 month ago
So, I got my antenna genius about a month ago.  Today mounted in its NEMA enclosure, its now on top of my tower where all the coax comes together.  Awesome performance!!  My tower is 365 ft away so CAT 6 was used to feed it.  The AG only pulls a few hundred miliamperes which made wiring that in a trivial task.  Software setup, well, never read the instructions and all is working !!  Tell the AG your radio serial number and it finds it on my LAN just great!! 

What I love is that their are no longer any USB hiccoughs, which is what I had with my prior system ...shortly to go on sale on Eham.  

Well done guys, this is bullet proof ....rock solid no matter how fast I zip around the bands.  

Hey I give you grief when you need it and high praise when you deserve it and you do!

Peter
Photo of W2PP

W2PP

  • 309 Posts
  • 42 Reply Likes

Posted 1 month ago

  • 1
Photo of Charles - K5UA

Charles - K5UA

  • 316 Posts
  • 88 Reply Likes
My antenna Genius 8x1 has very poor isolation between some of the ports(40 db on 3 of them).  Two weeks ago left a voice mail for VibroPlex and sent an email to 4O3A support, but have not been contacted.  Heard signals on empty ports so used a signal generator to check the isolation numbers.  Highest was 70 dB, 3 were about 40 dB).

As a check just connect one antenna on band with strong signals and listen on the other 7 ports.

Going back to my DX Engineering antenna switch unless VibroPlex or 4O3A support can contact me and tell me why thesei isolation numbers are so low.
Photo of K1UO - Larry

K1UO - Larry

  • 788 Posts
  • 126 Reply Likes
I have the new Version 2  8X2 switch and I hear absolutely nothing between ports as W2PP indicates.       Sorry...  I see where you mentioned the 8X1...  no experience with that one.
Photo of Charles - K5UA

Charles - K5UA

  • 316 Posts
  • 88 Reply Likes
Thanks Larry,

I was suspicious that the 8x2 would be better engineered than the 8X1 since it is designed as an SO2R switch and would really need a lot of isolation.  I was also suspicious when I saw there are no specifications given on the advertisements for the 8X1, the specifications are only shown on the 8X2 advertisement page. 

I am still waiting for 4O3A support to email me, or for VibroPlex to return my call concerning this poor isolation in my 8X1 unit.  If the 8X1 does not have the same specifications as the 8X2, it should have been made clear in the advertising. 

I see that VK4ACN has the same problem with his 8X1 Antenna Genius.  If there are any readers of this post that have the 8X1 Antenna Genius I would appreciate hearing from them concerning the port to port isolation that are experiencing.
Photo of Wayne VK4ACN

Wayne VK4ACN

  • 129 Posts
  • 20 Reply Likes
Charles
I noticed the same thing with my Antenna Genius switch.    I have the DXengineering switch as well, and I dont get strong signals coming through when it is off as I do with the genius.  I bought mine from Force12.
Photo of Wayne VK4ACN

Wayne VK4ACN

  • 129 Posts
  • 20 Reply Likes
Oh, forgot to say, its the 8x1
Photo of W2PP

W2PP

  • 309 Posts
  • 42 Reply Likes
I have the 8X2.  I just tried the test you suggest above.  I find that even with super strong signals
and with the wrong antenna port chosen, that is no antenna, nothing is coming through.

Maybe they changed the design????  I believe you guys absolutely.

Peter

Photo of W2PP

W2PP

  • 309 Posts
  • 42 Reply Likes
BTW I used a strong local AM station to test with.....
Photo of K1UO - Larry

K1UO - Larry

  • 788 Posts
  • 126 Reply Likes
I have the new Version 2  8X2 switch and I hear absolutely nothing between ports as W2PP indicates.       Sorry...  I see where you mentioned the 8X1...  no experience with that one.