All SDR CAT ports show error

  • 1
  • Question
  • Updated 3 years ago
  • Answered
The SDR CAT Com port list under V1.6 shows COM ports 4,5,6 and 7 have been created.  However, the red Error message appears on all ports.  When I hover over the error message for COM4, it says "has COM14 open which is needed by this port".  Could someone interpret the error message and what I need to do to eliminate it.  I have nothing connected to these ports at present.

Thanks, Bob, KN4HH
Photo of Bob  KN4HH

Bob KN4HH

  • 95 Posts
  • 21 Reply Likes

Posted 3 years ago

  • 1
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4017 Posts
  • 1243 Reply Likes
Are these hold-over ports from a previous installation?
If so, they may not have gotten translated properly.  You might need to delete them all, close CAT & SSDR, reboot, and recreate them.  It doesn't take long.  If that doesn't fix them, see Tim's excellent article about eliminating "Phantom" or "Ghost" COM Ports and Audio Channels.

Ken - NM9P
Photo of Bob  KN4HH

Bob KN4HH

  • 95 Posts
  • 21 Reply Likes
I tried your suggestion by deleting the com ports using SSDR CAT Remove command.  No success with creating new ports.  I then followed Tim's procedure for deleting phantom ports, of which there were several, and re-booted the computer and restarted SSDR.  Now when I try to Add a port in CAT, I get a message "VSP failed to create".  I suppose it wouldn't hurt to reinstall SSDR including VSP.

Bob, KN4HH
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4017 Posts
  • 1243 Reply Likes
On the Flex Net yesterday, Dudley told someone to go to the Windows>Programs and Features> and Find FlexRadio Systems FlexVSP and right click on it and select "Repair" and let it rebuild FlexVSP.  I would suggest a reboot before and after you do this.

See if that helps.  If not, then you might need a total removal and reinstallation.

Ken - NM9P
Photo of Al K0VM

Al K0VM, Elmer

  • 583 Posts
  • 95 Reply Likes
Or you could Select Com4 for edit ( or add) and then right click in the edit (add)  window to get advanced and then change com14 to com104. and save.

AL, K0VM
Photo of Al / NN4ZZ

Al / NN4ZZ

  • 1713 Posts
  • 581 Reply Likes
Bob,
I had the same error when trying to creating ports.  Discovered I had the old VSP driver 1.0.1 installed.  This may be worth a check.  You can see the version by using Windows control panel and the "uninstall or change a program" option.

Here is what I did that worked if you have the old version and I didn't have to reinstall all of SSDR. 

Stopped all Flex related programs CAT, SSDR, DDUtil, etc 

Use control panel to uninstall a program and remove VSP V1.0.1  

Reboot the PC

Re-install just the driver, using this link since my PC is  Win10 64 bit.

 C:\Program Files\FlexRadio Systems\SmartSDR v1.6.17\64-bit Drivers\VSP

The new version is now 1.0.2



Started up CAT and added a port Com10 / 110

No errors, started up all of my Flex related software (DDUtil, SSDR, SDR-Bridge, CW skimmer) 
 and everything seems to work, 

Then did a test on the new CAT port Com10 using the LOG option and tested using FA;.  Freq date returned as expected.






Regards, Al / NN4ZZ  
al (at) nn4zz (dot) com
6700 - HW.................... V 1.6.17.74
SSDR / DAX / CAT...... V 1.6.17.156
Win10
Photo of Al / NN4ZZ

Al / NN4ZZ

  • 1713 Posts
  • 581 Reply Likes
By the way, the reason I had the old version of the VSP driver is my habit is to install the new SSDR versions without "un-installing" the current one.  

Per Tim E., at some point in the past there was a VSP update as part of an SSDR release.  And the only way to get it was to un-install and re-install SSDR.  

So it's worth a check to see if you have the old version V 1.0.1

Regards, Al / NN4ZZ  
al (at) nn4zz (dot) com
6700 - HW.................... V 1.6.17.74
SSDR / DAX / CAT...... V 1.6.17.156
Win10
Photo of Bob  KN4HH

Bob KN4HH

  • 95 Posts
  • 21 Reply Likes
Official Response
Thanks, guys.  It was a combination of problems starting with old defined ports and old VSP driver.  All is well now.  I really appreciate all the helpful comments.

73, Bob, KN4HH

This conversation is no longer open for comments or replies.