All Ports Missing from SmartSDR CAT

  • 1
  • Problem
  • Updated 1 year ago
Yesterday all was good. Today, something went wrong. I do not shut down my computer or equipment in the evenings.

Today I fired up WSJT-X and it complained it could not control the radio. I opened SmartSDR CAT and Device Manager and this is what I see:



I have rebooted and still all my ports are gone but they all show up in Device Manager. They all worked OK yesterday.

The only Windows update installed in the last 24 hours is the typical Windows Malicious Software Removal Tool.

Kev K4VD
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes

Posted 1 year ago

  • 1
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9052 Posts
  • 3435 Reply Likes
This indicates that your CAT.settings file has become corrupted.

Open a HelpDesk ticket and we'll get CAT reset back to a default state in short order.
Photo of KM6XX

KM6XX

  • 2 Posts
  • 0 Reply Likes
What was the resolution?  I am having the same issue.  Filed a ticket
Photo of Paul Burton

Paul Burton

  • 96 Posts
  • 14 Reply Likes
i have the same problem.  I submitted a HelpDesk ticket also.  Is the solution to use the COM Name Arbiter Setter?
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes
Hi Paul:

No. That didn't work for me this time. I had a bunch of ghost com ports listed in Device Manager. Dudley (help desk) has a procedure to follow which involves uninstalling VSP and deleting ghost ports. It might be best to open a ticket and get his help though.

Kev
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9052 Posts
  • 3435 Reply Likes
There could be several issues from ghosted comports to a corrupted CAT.settings file to the ports being marked as reserved.  Like Kevin said, it is best to open a HelpDesk ticket to get one-on-one support to determine which issue you are experiencing and get the correct remedy  
(Edited)
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 3875 Posts
  • 1181 Reply Likes
There was a WIN 10 update released over the weekend that may have only just now filtered down to you.  It could have eaten your ports.  Help Desk will get you sorted...
Photo of Jay / NO5J

Jay / NO5J

  • 1406 Posts
  • 209 Reply Likes
Kev

I don't know if your aware of this one, so I'll repost it for everyone's benefit. In Win10 right click the start menu, select Run, and enter ... 

perfmon.exe /rel

  ,,, and hit the enter key.

If you like it and want to reuse it easier, Create a desktop shortcut to ...
 
"C:\Windows\System32\perfmon.exe" <br><br>... then change the shortcuts Target value to read ...

"C:\Windows\System32\perfmon.exe" /rel<br>
... Then you can get back to it easily.

Try it you might like it!

  SDRgadgets

#FlexRadio IRC chat

  73, Jay - NO5J

Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes
Results were pretty funny. The X's beside application failures were SmartSDR, DX Atlas and SmartSDR CAT (on 2/28!!!). 2/28's warning is VSP.

The DraculaTech Virtual Serial Port constant reinstall started on 2/27 at 9:15 right after a definition update for Windows Defender. One thing I do just prior to installing/updating SSDR is to make sure my computer is up to date first. So I'm not going to say that was the problem. It really looks to me like the new SSDR installation of VSP broke.

And now the plot thickens. I went back in time with this new tool (THANKS!!!!) and I see that almost every day - almost, not every - FabulaTech Virtual Serial Port is shows successful driver installations. Why? 

The history only goes back to 1/29/2017. The VSP successful driver installs go back to 1/31 but can't tell if it has been going on longer than that.

Very nice tool Jay. I didn't know it existed.

Photo of Jay / NO5J

Jay / NO5J

  • 1406 Posts
  • 209 Reply Likes
Kev

I'm seeing the repeated FabulaTech Virtual Serial Ports thing too, they might only be SmartCAT restarting, and reloading all the ports. I hasn't caused any problems, beside the repeated listings in the logs.

I reported this behavior to Dudley on my last HelpDesk ticket. So it's been submitted, but I'm not sure it got a Bug number assigned to it. 

  SDRgadgets

#FlexRadio IRC chat

  73, Jay - NO5J

Photo of Jay / NO5J

Jay / NO5J

  • 1406 Posts
  • 209 Reply Likes
Someday, maybe I'll learn how to post with raw </> html embedded in the post, The <br><br>, and <br> in my post above should be ignored, they weren't supposed to be visible in my post.

There I go again making messes!

  SDRgadgets

#FlexRadio IRC chat

  73, Jay - NO5J

Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes
Sounds good. Thanks for the follow up.