After registering a second radio, Smartlink fails to connect

  • 2
  • Problem
  • Updated 4 weeks ago
  • (Edited)
After registering a second radio, Smartlink fails to connect to either radio.

Both radios are running v2.4.9
Both radios are 6700’s
Radio one connected perfectly, prior to registering second radio.
Both radios are on discovery window and report available.
After radio two is shut down, still fails to connect.

Any ideas?

Thanks, in advance.

Mike wa6fxt

Photo of WA6FXT Mike

WA6FXT Mike

  • 216 Posts
  • 38 Reply Likes

Posted 4 weeks ago

  • 2
Photo of Watts - K4QJZ

Watts - K4QJZ

  • 73 Posts
  • 13 Reply Likes
I believe the smart link server is having technical issues. My radio currently also shows as being available but can’t connect to the server., per the error message. Tried Maestro, IPAD and PC versions. If I go in directly via my own VPN all works fine .
Watts
K4QJZ
Photo of WX7Y

WX7Y

  • 629 Posts
  • 114 Reply Likes
Same here on my IPAD
Bret
WX7Y

Photo of WW1SS - Steve

WW1SS - Steve

  • 694 Posts
  • 221 Reply Likes
I wish Flex would make their remote setup like Icom's and Kenwood's and not have to go through Flexs' smart link server. That and the NB bugs and my audio delay the whole thing gets downright frustrating. Radio's should not work like this!!
Photo of Watts - K4QJZ

Watts - K4QJZ

  • 73 Posts
  • 13 Reply Likes

I for one found the FLEX setup is the simplest and best solution for the average user who is not into networks and how to configure them and the least expensive.

If you have other reasons for not wanting to use the FELX approach you have other options.
You can easily communicate directly with your radio without going through the Smart link server. The best alternative, and one I still use if the server is down, used by many of us for over a year prior to the service they offer was by using a network capability know as a VPN. Basically, this is a software-based solution that can look like a direct connection over network cable to the radio from a remote PC.

For most folks this appears complicated and hard to set up when compared to setting of WIFI in your house. It’s not impossible to do but it is more complex than setting up your WIFI. There are step by step instruction on Tube on how to do this. In short it requires the purchase of two small computers called Raspberry PI and the programing of each. The instructions are truly step by step, “...type the following line....”

The down side of this approach is more equipment to buy (under 200.00 for 2 Raspberry PI units) and your time to setup. The ICOM approach don’t forget requires a computer on the radio end as well as the one talking to the radio. That’s a big expense as well.

And as David noted you will also have to setup a Dynamic DNS but many home routers have this capability if tuned on these days as well.

Hope this helps and offers some ideas for alternate approaches,

   Watts

   K4QJZ

Photo of Watts - K4QJZ

Watts - K4QJZ

  • 73 Posts
  • 13 Reply Likes
Mistype on my part, the ICOM approach requires a computer on each end of the link as is true for other approaches.
 
Photo of WX7Y

WX7Y

  • 629 Posts
  • 114 Reply Likes
If you have ANY Windows / Linux computer that you run all the time on the same network as your radio network as I do here you can install SoftEther VPN Server on it, it doesn't have to be two raspberry Pi's unless you need one for the Maestro because you can run the SoftEther client software on a laptop / PC or IOS Apple device using it's built in VPN to connect back to your shack. 
Cost added to build my VPN with added equipment was $ZERO but with the Maestro connectivity with Rasp-pi cost was $65.00. 

With a Raspberry Pi on a Maestro issue:  if you go to a motel that you have to Log in to there network you have to have there IT dept open it up for you or carry a monitor and keyboard for the Pi to do it, Pain in the neck, I always take my Verizon Jetpack when I go which the Pi is already configured for and works great.

To bad we don't have access to add a VPN client to the Maestro then that cost would also be $0. 
There are a LOT of YouTube videos and help here for people setting up a SoftEther VPN server. 

73's
Bret
WX7Y
Photo of Al K0VM

Al K0VM, Elmer

  • 591 Posts
  • 99 Reply Likes
With more than one radio, you may need to do manual port forwarding and assign different ports for each radio on your radio and router.
AL, K0VM
Photo of WA6FXT Mike

WA6FXT Mike

  • 216 Posts
  • 38 Reply Likes
Different locations
Photo of David Merchant

David Merchant

  • 31 Posts
  • 18 Reply Likes
Flex tries to make networking as simple as possible for its customers.  By using a centralized server, it can act as a proxy so customers don't have to worry about setting up dynamic DNS to reach their home network.  
Photo of Steve K9ZW

Steve K9ZW, Elmer

  • 1321 Posts
  • 668 Reply Likes
@ Al K0VM - can you give me a bit for detail or point me to something I could read on the separate port forwarding?

Makes sense.

@All - you can remote outside of SmartLink.  I've a pair of Raspberry Pi to use as a VPN setup.  Usually the Radio's end is just left running, and my Maestro travel case has the other end.  There are pros and cons to this method over SmartLink of course.

@FRS - it would be a useful service if FRS had a reference site where SmartLink users could check on FRS SmartLink status.  Reflecting whether there is any problems, or if any of the components are having troubles.  Even if it was only a list of user reports it would still be useful.

73

Steve
K9ZW
Photo of Al K0VM

Al K0VM, Elmer

  • 591 Posts
  • 98 Reply Likes
Steve,
    The first thing that you will want to do to make manual port forwarding work is to insure that each radio has a consistent and unique IP address on your LAN. I do that by reserving an IP address ( also called a static lease) for each of my radios in the DHCP section of my router.  
     After I verify that is working on the LAN with each radio then I verify that one radio will run on SL with the other radio off.
     Port  forwarding in the router maps a WAN ip & port number to a LAN radio ip & port number ( 4994/4993 ). There will need to be a  TCP port forward for each radio and a UDP port forward for each radio. Thus with two radio there are 4 port  forwards.
The port numbers used on the WAN side can be anything between 0-65535 that is not reserved or in use.  Most of the reserved or in use ports are in the 0-1024 range.

    Each router is different.  Some older, consumer routers may not support port forwarding properly.
    The port forwards on my router are found  under Advanced>Network>Firewall>Port Forwards. Each of my port forwards says something to the effect of  'forward all WAN port 15994 TCP  connections to ip 192.168.1.065  port 4994 on my LAN' ( my 6500 ).

    In server SSDR SmartLink Network Settings> Manual Port Forwarding, I have ' forward TCP port 15994 ( external) to 4994 (internal )'.  This will tell the SL client  what WAN port to use.

   Hope this helps a little.

AL, K0VM
Photo of WA6FXT Mike

WA6FXT Mike

  • 216 Posts
  • 38 Reply Likes
Of course I could create an OpenVPN setup and an access point for my Maestro, however, my license includes Smartlink, for WAN operation, and I would like to be able to use it.

Mike

PS: Is Smartlink working for anybody, yet?
Photo of WX7Y

WX7Y

  • 629 Posts
  • 114 Reply Likes
Yes mine is up and running finely
Connected about 30 Minutes ago
Bret
WX7Y

Photo of WA6FXT Mike

WA6FXT Mike

  • 216 Posts
  • 38 Reply Likes
Well, mine is still not connecting.




(Edited)
Photo of Watts - K4QJZ

Watts - K4QJZ

  • 73 Posts
  • 13 Reply Likes
Mine is still out, Tim is aware mine isn't working yet but his was today so it may be an isolated issue vs system wide.
  Watts
  K4QJZ
Photo of Matt - KD5FGE

Matt - KD5FGE, Employee

  • 125 Posts
  • 63 Reply Likes
I am sorry for the trouble you are experiencing! I would recommend opening a helpdesk ticket so that the support department can assist you. https://helpdesk.flexradio.com
Photo of WA6FXT Mike

WA6FXT Mike

  • 216 Posts
  • 38 Reply Likes
All ready did.
Photo of WA6FXT Mike

WA6FXT Mike

  • 216 Posts
  • 38 Reply Likes
Now it’s working!


Just created a Smartlink account and now I’m able to use Smartlink. Google account stopped working...


Oh! Well! As long as it works.


Thanks to all of you.
(Edited)