6600M connecting to SmartSDR CAT Application

  • 1
  • Problem
  • Updated 5 months ago
If the 6600M has a LAN connection to the PC that the SmartSDR CAT application is running on at the time the 6600M is booted, the CAT application connects normally.   If the 6600M is booted without a LAN connection and is later connected to the LAN, the SmartSDR CAT application running on the PC also connected the LAN will hang and not connect.
The solution is to force a shutdown of SmartSDR CAT on the PC and then shut down the 6600M and reboot it with the LAN connected at boot time.
Photo of Geoff - W8GNM

Geoff - W8GNM

  • 45 Posts
  • 4 Reply Likes

Posted 7 months ago

  • 1
Photo of Lee Swanson

Lee Swanson

  • 2 Posts
  • 0 Reply Likes
I run a Flex 6500 connected to a wireless wifi router which in turn is connected to the pc running Smart SDR.
On first boot up of the Flex when I try to connect to the wifi router, it will not connect.  I then power down the Flex and repower.  The radio boots up and I can then connect the radio to Smart SDR through the wifi router. This is the way I have had to start the Flex since I first purchased the radio.  I suspect that  a minor configuration change in the router will allow the Flex to connect on the first power up attempt once the router IP address is configured in away that the Flex is happy with.  Not a big concern of mine but I will attack this issue in the near future.  It is my feeling that when all is configured properly, the Flex should power up "first time, everytime".

After the initial successful connect attempt of the Flex to the network router, the radio performs flawlessly.

Lee NR5G
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3467 Reply Likes
Lee, your problem is not related to Geoff's post.  When the radio is powered on, because it is using a wired Ethernet connection, within a second, it sends a DHCP DISCOVERY packet to get an IP address.  When this happens, if the wireless link between the radio your router has not been properly established (sometimes it takes a router a few seconds to initialize a new connection), the DHCP DISCOVERY packet is dropped and the radio does not get an IP address in your LAN network subnet.  When you reboot, the links between the radio and your router had already been established so on the 2nd boot, the radio's DHCP DISCOVERY packet makes it through to the DHCP server, it get a proper IP address and the radio can connect to your PC. 

I have debugged literally dozens of issues with the same behavior as you have described, and in all cases, this was the reason.

I do not know of a setting in your router that would make a difference if the delay is due to something in your network not initializing fast enough.  A more detailed description of your network would be required to know fro certain.
Photo of Lee Swanson

Lee Swanson

  • 2 Posts
  • 0 Reply Likes
The Flex 6500 is connected to a Netgear router with a cat5e cable.  The  pc running Smart SDR is also connected directly to the same router with a cat5e cable.  On the other side of the house is the main router that is connected to the cable modem with internet access. So being that the pc and radio are both physically connected to the same router, I would think that the Flex does not depend on a wireless signal from the main router in order to operate the radio but just to furnish wireless internet service to my pc.  Networking is not one of my specialties.  I hope this might add some clarification to my issue.. Thanks for a speedy reply.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3467 Reply Likes
Geoff,  Sorry for the late reply, but I just tried replicating your issue on my 6600M with the latest version of SmartSDR and I cannot make it fail.  You may want to change the CAT start option to not automatically connect to the last radio used and show a chooser, by placing your mouse cursor over the Radio Connected (or not connected) text at the top of the CAT window and unchecking the two options to automatically connect.