6400 support

  • 1
  • Problem
  • Updated 6 months ago
  • Acknowledged
I guess Hamvention is more important than getting our broken radios fixed. Seems like they've taken the week off for a convention. not the way to treat customers............
Photo of M Evans

M Evans

  • 20 Posts
  • 0 Reply Likes
  • frustrated

Posted 6 months ago

  • 1
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2965 Posts
  • 644 Reply Likes
I don't believe Flex has closed their service department and help desk.
Tim is still here every day to help anyone and to answer questions.
Photo of Robbie - KI4TTZ

Robbie - KI4TTZ

  • 480 Posts
  • 77 Reply Likes
Running a convention is a LOT of work.  Give them a little break...
Photo of M Evans

M Evans

  • 20 Posts
  • 0 Reply Likes
Tim told me all service people are at the convention. I'll bet your radios are not waiting to be repaired as mine is :-(
Photo of Clay N9IO

Clay N9IO

  • 529 Posts
  • 123 Reply Likes
M,. FRS already stated this will be the case as it is every year. SOP.
Photo of Lewis Cheek

Lewis Cheek

  • 237 Posts
  • 41 Reply Likes
We all have a run of bad luck from time to time, however I'm sure FRS will repair and return your
rig ASAP. I have found FRS and Elecraft to be top notch with respect to customer service.

Not that this will easy your pain of being without your rig, think about how it might be with one of the
big three ( KIY) !

Lew
N4CO
Photo of Clay N9IO

Clay N9IO

  • 529 Posts
  • 123 Reply Likes
Lewis is right of course M, be patient.
I too just got my 6600 back from repair, trust me when I say they want to turn it around as quickly as possible.
I waited for the end of the 3B7A expedition to end before I sent it in. 5 bands and an ATNO was worth the wait.
The radio was gone I want to say 2 weeks 'ish.
Photo of Bill English

Bill English

  • 91 Posts
  • 8 Reply Likes

It's only a week, it will be over soon, just be patient. I remember in the late 1980's I save and saved and finally got enough cash together for my first new, high end rig, a TS930SAT.  It came in dead. Had to send it to California for repair. It probably took a week just to get it there from NC. It was gone a very long time. But when it came in working, it was worth the wait!

That is why I try and keep a backup.