6400 and wsjt-x 2.x

  • 1
  • Question
  • Updated 7 months ago
I'm having trouble configuring WSJT-X with my Flex-6400.  I had it working well until I tried configuring the program for a TS-940S.  Now I can't remember the settings I used.  (Ugh)  The attached photo shows what I have on the radio page.
The program is decoding FT-8 transmissions, but nothing appears on the WSJT-X waterfall, though it shows up in the SDR waterfall.  DAX was selected for RX and TX

Thanks and 73
John
W4KV
Photo of John Adkins

John Adkins

  • 16 Posts
  • 1 Reply Like

Posted 7 months ago

  • 1
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 4055 Posts
  • 979 Reply Likes
should the PTT be cat?
Photo of George Molnar, KF2T

George Molnar, KF2T, Elmer

  • 1680 Posts
  • 616 Reply Likes
PTT to CAT, Split to "Fake It." Not seeing stuff in the Wide Graph can be a matter of adjusting the sliders in that window. The "thermometer" audio meter reading 30+ and staying green? If so, your levels are set right.

Oh - assuming your Smart CAT is set for COM5 emulation and nothing else is trying to use COM5 at the same time.

Good luck!
(Edited)
Photo of David Warnberg

David Warnberg

  • 698 Posts
  • 91 Reply Likes
What does your AUDIO tab show for receive? 

FYI mine is quite a bit different... first I am network server 127.0.0.1:5003 and not a serial port... This is setup as a TCP port in your Smart SDR CAT settings, your PPT side looks correct as long as com5 is the proper port..  and audio tab I have it set to Input /  DAX Audio RX1 and output / DAX Audio TX

Hope this helps

Almost forgot.. MODE... DIGU
(Edited)
Photo of Rob G6EIH

Rob G6EIH

  • 116 Posts
  • 16 Reply Likes
I use the network connection as it just works so much better.
Photo of Roger,  W6VZV

Roger, W6VZV

  • 264 Posts
  • 122 Reply Likes
To echo another person on this thread, I'd like to see the audio settings for rx and tx.
Photo of Rob G6EIH

Rob G6EIH

  • 116 Posts
  • 16 Reply Likes
Hers the audio settings on a 6700 should be the same for others.
Photo of Rob G6EIH

Rob G6EIH

  • 116 Posts
  • 16 Reply Likes
Sorry forgot to add the Cat settings.
Photo of David Warnberg

David Warnberg

  • 698 Posts
  • 91 Reply Likes
port protocol CAT?  I used TCP
Photo of Rob G6EIH

Rob G6EIH

  • 116 Posts
  • 16 Reply Likes
Yea that's strange however it is set to TCP
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1490 Posts
  • 325 Reply Likes
No, it is CAT. You need CAT to send freq and band info. Look above CAT and you can see you have TCP instead of serial.

Dave wo2x
Photo of David Warnberg

David Warnberg

  • 698 Posts
  • 91 Reply Likes
Dave, you're correct.. my mistake... the Port Protocol is CAT, TCP is not even an option.
Photo of Jay / NO5J

Jay / NO5J

  • 1674 Posts
  • 263 Reply Likes
David Warnberg

(Sorry, too many Davids) 

(Just to clarify/nitpick) Regarding Rob G6EIH's Edit CAT Port screen capture above.

Your partially correct, The protocol is CAT, but the Port Type is TCP, as indicated by the blue highlighted TCP button, OPTION. 

AKA, a TCP CAT port.

So indeed TCP isn't an available option for the Protocol choice, since TCP isn't a protocol. However TCP is a Port Type, and it's the selected Port Type. 

So no need to pick sides, or argue further, it's all good. 

Rob's screen capture display is correct.

#FlexRadio IRC Chat

   73, Jay - NO5J

Photo of John Adkins

John Adkins

  • 16 Posts
  • 1 Reply Like
Audio side pic:


BTW--I have been following the recommendation to list the radio as the TS-2000.  It worked before, but now seems confused.  For PTT, I tried all the options, and I've finally settled on CAT.  "Thermometer" is green.  I have the mode set at Data/Pkt.  I gradually have moved the sliders from the extremes, but no waterfall.  Here's the decode page: 
Tnx

Photo of Roger,  W6VZV

Roger, W6VZV

  • 264 Posts
  • 122 Reply Likes
Your audio looks right.
I use the Flex selection, not the Kenwood, for my 6400M.
Photo of Pat - WH6HI

Pat - WH6HI

  • 455 Posts
  • 91 Reply Likes
The red window means you do not have any band frequencies set up in wsjt-x. You need to set up the frequencies to use. If you reset the frequency window it will install the currently used frequencies. You can also do them manually line by line. See the wsjt-x web page for more details.

“On the File | Settings | Frequencies tab, right-click any line in the Working
Frequencies table and press the Reset button. This action will pick up the
recommended working frequencies”
(Edited)
Photo of John Adkins

John Adkins

  • 16 Posts
  • 1 Reply Like
Also--if I use Flex 6xxx and a network connection, how do I find out what connection to use?  I tried localhost 68001 with no joy.
Photo of David Warnberg

David Warnberg

  • 698 Posts
  • 91 Reply Likes
John.. you set it... Smart SDR CAT... add... 

Example settings as follows:
I named mine "WSJT-X"
Port Protocol TCP
Port Type TCP
TCP Port.. your choice really I used 5003, on your example 68001
VFO Slice: I set mine to A
Enable it
Split mode "SO2R (normal)"

Then in WSJT-X... you would set under radio tab
look under Network Server, CAT Control... should be a 127.0.0.1:68001 available for you to select

The rest of the settings under that should then grey out as they are no longer needed
For reference time-to-update-the-recommended-wsjt-x-config
(Edited)
Photo of N8AUM

N8AUM

  • 125 Posts
  • 14 Reply Likes
I've noticed that after making changes to WSJT that I have to restart WSJT before the change goes into effect.