6400/6600M model's speaker

  • 1
  • Question
  • Updated 7 months ago
  • Answered
How is the speaker in the "M" models  and would one need to provide a powered speaker?
Photo of Reggie-k6xr

Reggie-k6xr

  • 413 Posts
  • 32 Reply Likes

Posted 7 months ago

  • 1
Photo of James Whiteway

James Whiteway

  • 877 Posts
  • 193 Reply Likes
It appears to be similar to the one in a Maestro. I plan to use my Bose speakers if my 6600M ever ships.
Photo of James Whiteway

James Whiteway

  • 877 Posts
  • 193 Reply Likes
Me too! What I was saying is the M models appear to use the same speaker as the Maestro. I had a Maestro and I really didn't care for the audio from its' speaker. The Bose Companion II powered speakers I used with the 6500 I had, were much better. Clearer audio etc.
Photo of Rick  WN2C

Rick WN2C

  • 268 Posts
  • 32 Reply Likes
Use the Bose for your listening enjoyment. You will hear more.
Photo of Reggie-k6xr

Reggie-k6xr

  • 413 Posts
  • 32 Reply Likes
what model Bose?
Photo of Rick  WN2C

Rick WN2C

  • 268 Posts
  • 32 Reply Likes
Bose Companion II or the Klipsch speaker. Not sure of the model for the Klipsch but if you do a search on here I am sure you will find it.
Photo of Craig - KØCF

Craig - KØCF

  • 133 Posts
  • 44 Reply Likes
I highly recommend the AudioEngine 2+ speakers. They sound great and are RFI-free. Available on Amazon in black or white for $249.
73,
Craig, KØCF
Photo of Jeff / KI0KB

Jeff / KI0KB

  • 17 Posts
  • 5 Reply Likes
The audio out of the 6600M speaker is acceptable but a pair of powered speakers is the way to go. I listened for a few days through the front speaker before my Bose companion II speakers arrived. For weaker signals you'll need headphones if all you are using is the front speaker. Good signals actually sound okay through the front speaker but as we all know, bigger is better. Jeff / ki0kb
Photo of Jeff / KI0KB

Jeff / KI0KB

  • 17 Posts
  • 5 Reply Likes
Also FYI: Having NEVER used Smart SDR/Flex before it was a new "computer/radio" experience when I powered up the 6600M for the first time. I had no sound out of the speaker and I had no speakers to plug in.  I finally figured out the front speaker was disabled by default under the audio menu. An easy fix with a touch of the finger.