6300 to Logger32 to SteppIR - Problem(s)

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
OK. I know there are 100’s of posts about this, and trust me, I’ve read them all, and tried countless solutions with no luck.

Many are years old referencing old software versions, or want me to use (and set-up) yet another program (DDUtil) that I should not have to do.


All I want to do is have the Steppir move along with the radio and the logging program. I do not need any ”advanced”  features, just fq control.


I am using a 6300,  SmartSDR (ver 1.10 beta). Everything seems to work!

I have SSDR running on one screen, and I fire up Logger32 (ver 3.49.3) on the other.


The SmartSDR Cat program opens with the following info:

 Serial COM 7, slice A, Process Logger 32.

TCP: Port 5002, Slice A

Serial Com 9 Slice A, Process none.


All works well! I click on a spot, the flex qsy’s, I click on the flex panadapter screen, the logger program enters the fq.


I should add that in Logger 32, I have it set for radio 2,  Com 7, Radio Kenwood all, (I have also tried radio choice powerSDR... no difference), 9600 baud 8, N, 1. Box: Set RTS high is checked.

As I mentioned, all works like it should. If I didn’t have a stepper, I’d be great here.

OK, time to interface the Steppir Controller. It is the older model controller, not the SDA100, but the data interface is the same. It works fine with all my other rigs in the station.

I change the controller to radio Knwd, 9600bd, yes to save settings, power cycle the box, and switch it to Gen mode. Routine stuff when changing radios.

 

I plug in the FTDI USB/SERIAL cable into the 6300. Going to USB settings I see NEW USB CABLE, the serial number, Type: CAT and the enabled box is lit.

 
From the female end of that cable I made the following cable with specs from the Flex USB data sheet.  Pin 2 to pin 3 on the controller. Pin 3 to pin 2 on the controller. Pins 7 & 9 shorted on the controller plug.  (I have read posts that said to connect pin 5 straight through, and to also short pins 7 & 9 on the Flex end also. I’ve tried all combos, all with the same results). This is plugged into DATA IN on the controller box. Flex also says that this cable can be used instead of the Steppir S12 cable. ( Tried to order this first, but Steppir hasn’t answered their phone in a few days so I figured I’d make my own to “flex specs.”).


Plug it in, and the controller doesn’t move. I check the USB cable menu in on the Flex screen, and the USB cable is there, but there is no new info.

 
To make matters worse, after about 30 sec with the cable plugged into the Ant controller, SmartSDR shuts down!  I get the message: Smart SDR has lost connection to the radio. OK, I go to reconnect, and I get the message, Radio in use. I go to click on the lit Disconnect user button, and nothing happens.

The only solution is to re-boot the 6300. I feel that this has to be related to my plugging the USB/SER cable from the flex via my adapter cable into the Steppir controller. This never happens when I disconnect the cable from the antenna controller. I have tried re-booting my computer many times. I’ve re-booted it more in the last 10 days than I have in the last 10 months. I am constantly re-booting the 6300 as well before and after every change.

 
This should be an easy solution, considering the logger32 and flex seem to be in sync, all I’d like to do is control the steppir.

Am I missing something simple here? I’ve done nothing with SDR Cat, except read what it says when it is connected. I would really prefer not to use DDUtil. It looks difficult to set up, and I don’t want to risk messing up the other ports on the computer.

I have contacted Flex, and all I get is to RTFM, (did that, made the cable) or email USB support at flex.


Needless to say I have checked and tested my cable many times.


Any ideas here?  I’m sure that this is an obvious problem in the ESO  (Equipment Superior to Operator) code of the flex.
I’ve wasted countless hours screwing with this and it’s time to reach out, or just move on from Flex. 

Bill, K1SM
Photo of Bill Hassan - K1SM

Bill Hassan - K1SM

  • 18 Posts
  • 1 Reply Like

Posted 2 years ago

  • 1
Photo of Bill Hassan - K1SM

Bill Hassan - K1SM

  • 18 Posts
  • 1 Reply Like
Official Response
Thanks all for the help! 
Got it all working. The magic combo was a dbl female DB9 cable with pin 2 to 3, Pin 3 to 2, pin 5 to 5, and pins 7 & 9 jumped on each end. This jumper cable connected between the USB/SER cable from the Flex and the Data In jack on the SteppIR controller.