1.4.0 radio freeze audio / panafall 0 dropped packet

  • 2
  • Problem
  • Updated 4 years ago
  • Solved
Hi  at fist V1.4 work good but since last 24 hour it radio freeze at random intervals
may freeze from 5 -15 second  2 to 3 time in a minute (same in TX !!!  )

if do a cold reboot seem to fix for some time then restart 

when freeze audio cut and panafall to ,but latency was < 1ms  whit 0 dropped packet
and my audio come from back of the radio 

any idea ?

Radio was flex 6500 / Win7   on a quad core I7  3.0Ghz

Marc L. VE2OLM
Photo of Marc Lalonde

Marc Lalonde

  • 368 Posts
  • 91 Reply Likes

Posted 4 years ago

  • 2
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9186 Posts
  • 3541 Reply Likes
Are you receiving a disconnect popup message at any point?
Photo of Sergey, R5AU

Sergey, R5AU

  • 858 Posts
  • 116 Reply Likes
i think   "but latency was < 1ms  whit 0 dropped packet" is a trigger for message pop up 
Photo of Sergey, R5AU

Sergey, R5AU

  • 858 Posts
  • 116 Reply Likes
Seems like Ethernet or CPU can be overloaded with third party with highest priority - updates, special backup etc, Marc check you network traffic and CPU usage simultaneously during this issue
Photo of Marc Lalonde

Marc Lalonde

  • 368 Posts
  • 91 Reply Likes
Hi 

if it was PC the Audio take from the jack on back of the radio will stay on 

and no disconnect pop-up just freeze then restart

CPU on my PC still keep under 9%
Photo of Sergey, R5AU

Sergey, R5AU

  • 858 Posts
  • 116 Reply Likes
Overheat of the Video Card ? Temp is OK ? Active cooling i guess.
Photo of Marc Lalonde

Marc Lalonde

  • 368 Posts
  • 91 Reply Likes
Hi 

pc work good i use it for my day work while i monitor on second screen VHF weak signal 
and the system work 24/24 for last 6 Mont whit no issue 

i downgrade to 1.3.8 no freeze yet  
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9186 Posts
  • 3541 Reply Likes
Marc - did you load SmartSDR on any other PCs in your network?

I would also check to see if you have the latest video driver too.
Photo of Marc Lalonde

Marc Lalonde

  • 368 Posts
  • 91 Reply Likes
Hi TIM

for now Have SmartSDR only on 1 PC  ,still not got issue since downgrade to 1.3.8

just check and it last video driver  for intel 4600
(Edited)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9186 Posts
  • 3541 Reply Likes
I need to ask a few questions.  Sorry if these have been answered before:

1.) is the PC connected using a wired Ethernet connection?

2.) when the audio freezes, are you using speakers connected directly to the radio?

3.) Does the panadapter freeze at the same time?

4.) After the freeze does the Network Monitor show any packet loss or high RTTs?

5.) How long does it take after a radio reboot for this to start happening?
Photo of Marc Lalonde

Marc Lalonde

  • 368 Posts
  • 91 Reply Likes
1-)  yes trough my gigabit router  same as before
2-) speakers was connected to back of the radio (PWR-SPK jack label as 7  on documemtation) ,DAX also freeze on digital mode
3-) yes but Smart SDR GUI and PC still work 
4-) no 
5-) no more that a hour , sometime much less

still not have any freeze since downgrade back to 1.3.8
and 1.4 Have work for 2 day whit no issue before start freezing during local Net
(Edited)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9186 Posts
  • 3541 Reply Likes
Thank you.  And you are certain that SmartSDR is not loaded on any other PC on your network?  This behavior is difficult to figure out if the PC is the only one any version of SmartSDR has been loaded on.
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 3798 Posts
  • 917 Reply Likes
Hmm, if it was working something must have changed somewhere.
Photo of Marc Lalonde

Marc Lalonde

  • 368 Posts
  • 91 Reply Likes
only thing that have changed  was the mast mounted VHF pre-amp ,that extra gain may near overload DEMI L144-28 transverter input / but signal at XVRT  input was fine 
i also switch to HF and still have the freezing on ANT 1 and 2

putting back 1.4.0 now for see  since 1.3.8 seem working


Tim  yes only 1 pc running now on my LAN   ,have shut down all other
Photo of Marc Lalonde

Marc Lalonde

  • 368 Posts
  • 91 Reply Likes
Hi ok still start ti freeze just after in transmit 

image was better that word ;-)

http://youtu.be/HLymCeBrZyg
(Edited)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9186 Posts
  • 3541 Reply Likes
Open up the DAX control panel and disable all channels and see if that helps.
Photo of Marc Lalonde

Marc Lalonde

  • 368 Posts
  • 91 Reply Likes
Ok  TIM you put finger on something 

if if disable all my DAX seem to work 

i also notice that if DAX running during freeze it tell no data from radio  and icon turn orange

but how DAX may put off the radio and speaker out on the radio ?
(Edited)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9186 Posts
  • 3541 Reply Likes
We are making progress.  Another question.

1.) Does your computer have a Internet security program or fire wall running on it?
Photo of Marc Lalonde

Marc Lalonde

  • 368 Posts
  • 91 Reply Likes
Hi  yup NOD32  but that not changed  and radio IP was DMZ

the AL, K0VM suggestion to reboot PC seem good for now
but still not figure how that may affect the radio ?
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9186 Posts
  • 3541 Reply Likes
What I think is happening is that the network security suite is inspecting the streaming packets and that is slowing them down,  SmartSDR v1.4 uses a different mechanism to determine if the radio and PC are disconnected and NOD32 is interfering with that.

Can you disable it and put the radio and the PC on the same network, not in an DMZ and see if that makes a difference.
Photo of William Hemmingsen

William Hemmingsen

  • 573 Posts
  • 278 Reply Likes
I get this same behavior over wifi.  My gig connected PC does not do this.  However I can not find a reason for it over wifi.  The network utilization is very low and PC cpu never gets over 15%.  Mine freezes and stutters periodically.  This is obviously a network issue in my case, hence my gig connected PC does not do this.  But I would expect with the network utilization so low this would not happen with the new software.

My transmit audio is also very broken when on wifi.  Its really unusable over wifi fo me.  Tried it on several laptops all fairly high end.

When I get the stuttering/freezing, the PAN adapter and waterfall stutter also.  No packet loss seen.

Not complaining, just throwing out my experiences also, so it may help diagnosis.

Regards,

William
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9186 Posts
  • 3541 Reply Likes
William - your behavior over a wifi link is not unusual.  Some wi-fi routers have more trouble streaming data than others regardless of the utilization.  And the number of connected devices on the AP effects this too.  

See the following article for more info: https://helpdesk.flexradio.com/hc/en-us/articles/203469425-Reasons-for-Wireless-Network-Performance-...
(Edited)
Photo of Robbie - KI4TTZ

Robbie - KI4TTZ

  • 484 Posts
  • 78 Reply Likes
Generally speaking, I've had problems with about ever router I've owned (linksys, cisco, dlink) except for my current one which is an Asus RT-AC68U. It has been a very stable router with about 12+ devices always connected. There are newer models out now but I'm not sure how they compare. 
Photo of William Hemmingsen

William Hemmingsen

  • 573 Posts
  • 278 Reply Likes
Yes I figured it was my wifi.  That's why I ordered some cable and connectors to run hard lines.  Just mentioned it.
Photo of Howard Koenig

Howard Koenig

  • 24 Posts
  • 1 Reply Like
See my post from yesterday.

Solved the deep freeze? DAX
Photo of Al K0VM

Al K0VM, Elmer

  • 608 Posts
  • 102 Reply Likes
Marc, Tim,
  This is very similar to what I have seen and reported about 3 times before.. Everything from the radio pauses including speaker connected to the radio.  PC network activity and CPU usage drop significantly. The DAX CP button changes from blue to yellow and then recovers when the audio does..   Actions in SSDR ( band/mode change ) initiated during a pause  become effecting when the pause ends.  
 
Marc,
  for a test, next time it happens, reboot the PC ( not the radio ).


AL, K0VM
Photo of Steve Cook

Steve Cook

  • 15 Posts
  • 0 Reply Likes
I had the same issue on the 6700.  it happen only once a couple hours after my first install of SDR 1.4.  The system recovered with out an issue.  The radio keep the same frequency mode and band settings when it returned.


Steve, KD7IQL
Photo of Marc Lalonde

Marc Lalonde

  • 368 Posts
  • 91 Reply Likes
Official Response
since reboot the PC it seem good  
look like install program let some kind of residual of 1.3.8 running that radio not like ?
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9186 Posts
  • 3541 Reply Likes
OK.  If it starts again, open a HelpDesk ticket and we will figure out what is happening.