"Registration unsuccessful. Could not access smart link server".

  • 1
  • Problem
  • Updated 2 months ago
Good Morning!

I just got the Flex 6300, which I purchased from another ham. I've been connecting to the radio via wired ethernet and operating fine for a few weeks.  

The problem I'm having is registering the radio to my smartlink account. I created a smartlink account and can log into it fine. But I cannot get the radio to register to that account.

Here's what I've tried.  In SmartSDR, I click on my radio which shows as "available" to highlight it.  Then I click “Smart Link setup” beside the “Connect” button, to register the radio to my smartlink account.  After waiting for 10-20 seconds I perpetually get the error: "Registration unsuccessful. Could not access smartlink server”.  It never gets to the point where it asks me to press the mic. 

Troubleshooting I have done:
1) Updated Radio Firmware
2) Tried SmartSDR 2.4.9 on another computer (to which the radio is also hardwired via ethernet)
3) Tried connecting to another wifi network using another ISP
4) Factory reset the radio (to get blinking white light) multiple times
5) Restarted the radio many times (plus unplugged and replugged power) restarted computer many times. 

Nothing I do will fix the eternal error: "Registration unsuccessful. Could not access smart link server”.  This has been going on since I first started trying to register the radio to my smartlink account, several days ago. 

Any suggestions?

Thanks!
Randy Steffens
NC8U


Photo of Randall Steffens II

Randall Steffens II

  • 28 Posts
  • 1 Reply Like

Posted 2 months ago

  • 1
Photo of Mack McCormick

Mack McCormick, Elmer

  • 389 Posts
  • 135 Reply Likes
Randy,


It is likely that your router is blocking the registration. Please describe the network devices that are between the Flex and your Internet connection.


Do you have UPnP enabled on your router? That’s makes things very simple. Describe your networking situation a bit more and I’ll be able to help more.


73,


Mack

W4AX

Alpha Team
(Edited)
Photo of Randall Steffens II

Randall Steffens II

  • 28 Posts
  • 1 Reply Like
Thanks Mack,  really appreciate your reply.

I've tested this on two internet connections.

First is my home connection. The radio is plugged directly into my PC  using ethernet cable.  Then the PC is connected to internet via my wifi network (no physical connection between computer and internet).  My router is an Apple AirPort Express - I don't think it supports UPnP.  Then router is plugged directly into my internet modem.  That's all that's between the radio and the modem.

I also took the radio to my work office and tested it on the internet there.  Hardware setup is the same, although I'm not sure what comes after the wifi router.  I've never had any issue with any other pieces of software or hardware being blocked on my work network in the past.  

Also note that I'm only wanting to use the Radio on my LAN (on my home network).  I don't  want at this point to open up my router to allow access the radio from the outside world, beyond my home LAN.

Let me know what you think!
Thanks,
Randy
Photo of Michael Walker

Michael Walker, Employee

  • 608 Posts
  • 162 Reply Likes
Hi Randall

First, I see part of the problem is that your Radio is plugged right into the PC.  When you do this the radio is not able to connect to the internet, something you need to do to get SmartLink to work.

If you are not able to plug the radio LAN cable directly into the Apple AirPort Express, then you will need to turn on Internet Connection Sharing  on the PC.  This will allow the Radio to access the internet via your WiFi connection.

If you don't want to allow the radio access to the outside world, there there is no reason to have a SmartLink Connection/setup and no need to do any port forwarding on your Router.

If you just want to use the radio on your home network, you will still need have the radio connected to your home network somehow.  The way you have it now, the radio is not part of your home network.

You may want to follow this article:  https://helpdesk.flexradio.com/hc/en-us/articles/202118558-How-to-Connect-your-FLEX-6000-to-a-LAN

At some point to license future version of software, your radio will need Internet access to call home and validate its licensing.

Mike va3mw

Photo of Mack McCormick

Mack McCormick, Elmer

  • 389 Posts
  • 135 Reply Likes
Randy,

You must have two ports open on your Apple AirPort Express AND your internet modem. You do not need SmartLink to only use the radio on your home LAN. You can connect seamlessly. But to use it outside your LAN you will need to open two ports. On the Airport Extreme follow these instructions:

-----------------------------------------------------------

Apple's routers do not use UPnP.

They do offer a similar type of feature, which is called NAT-PMP, or NAT Port Mapping Protocol

Open AirPort Utility - Click Manual Setup

Click the Internet icon

Click the NAT tab below the icons

Insure that there is a check mark next to Enable NAT Port Mapping Protocol


Click the Configure Port Mappings button if you need to specify specific ports to use and set them up on the next window that appears
--------------------------------------------------

You will need to specify the manufacturer and model of your internet modem for me to help there. 

You defiantly have  port forwarding blocked in one or both devices between the radio and the Internet. 

Perhaps if this all seems too complicated then open a help ticket with FlexRadio for them to help you sort it out. SmartSDR User Guide starting page 26 describes this in some detail. Page 193 provides troubleshooting tips.

Mack
W4AX


Photo of Randall Steffens II

Randall Steffens II

  • 28 Posts
  • 1 Reply Like
Gentlemen, thank you very much!   I didn't realize that I needed to plug the radio into my router for it to have internet access (I thought it was getting it through the computer's WIFI connection).  Thanks for the very helpful article Mike, it answered a lot of questions.

  My apple router is an old model that only has one (1!) ethernet port (taken for connecting to the modem).  So I just bought an ethernet switch that will give me some additional ethernet ports. When it arrives, I will test again and hopefully that will solve my problems!

Thank you again very much!
Randy
Photo of Randall Steffens II

Randall Steffens II

  • 28 Posts
  • 1 Reply Like
Hi Gentlemen!  It worked!  You guys solved my problem.  Thank you so much!

Have a great day!
Randy