Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Has anyone successfully interfaced the PG XL with an ICOM 7610?

Wayne Schonfeld
Wayne Schonfeld Member ✭✭
I have had a PG XL for 10 months and use it flawlessly with a FLEX 6700.  I also have an ICOM 7610.  I have tried multiple times to get the data to transfer from the 7610 to the PG XL.  The data does but stops working after I cease to turn the maindial (PTO) on the 7610.  The linear only works by RF SENSING.  Has anyone successfully interfaced an ICOM 7610 or for that matter any ICOM transceiver with the PG XL.  If so, what were the transceiver's CiV settings?  Thanks

Best Answers

  • Dan-N7HQ
    Dan-N7HQ FlexRadio Employee, Community Manager admin
    Answer ✓

    Folks, the correct settings for an IC-7610 are 9600 baud, N81, and select the IC-7800 from the dropdown list in the PGXL Windows Utility. The 1/8" CI-V port must be used. Please make sure you use the correct PGXL port (A or B) for the connection. Do not use a higher baud rate.

    We understand configuring CI-V is confusing and will be doing away with the model selection dropdown in an upcoming release of the firmware and utility. The new configuration method will allow you to type in the actual CI-V address to be used.

    73,

    Dan, N7HQ

  • John KB4DU
    John KB4DU Member ✭✭✭
    Answer ✓

    FWIW, the data rate is insignificant, it just needs to match. The limited amount of data is transferred in milliseconds even at 1200 baud.

Answers

  • 4O3A Signature
    4O3A Signature Member ✭✭
    edited May 2020
    One of previous emails from N7HQ:
    There are three items to a successful integration between an ICOM 7610 and a PGXL.


    Connect a standard two-wire 1/8” -> 1/8” cable between the radio CI-V interface and the amplifiers. While some systems use a 3-pin connector, the CI-V specifies only tip and shield for the necessary connections. So a 2-wire will work just fine. Be sure to connect it to the correct port on the PGXL – I’ve seen other customers miss this.


    Change the CI-V address of the 7610 to a value that is used by the PGXL firmware. Currently, three ICOM radios (775, 7000, 7800) list in the drop-down menu in the PGXL Windows utility. Use the menu system on the 7610 change the CI-V address to either ($ = hexadecimal value: $46 - IC775, $70 - IC7000 or $6A – IC7800 ); this will allow the amplifier to receive band data from the 7610 over the CI-V interface.


    Connect a PTT cable between the radio and the amplifier. Again, double-check you are connecting to the correct PTT connector on the back of the amplifier. I’ve seen that gum up the works too.


    You will need to select the corresponding radio in the PGXL Windows utility for this to work. The data rate is really up to you – 9600 is just fine – please make sure both ends (radio and pgxl) are the same. Faster is not necessarily better. This connection is used soley for band/frequency data.


    73
  • Wayne Schonfeld
    Wayne Schonfeld Member ✭✭
    edited April 2020
    I have done all of that and every iteration imaginable as well.  The PG XL sees data and changes band BUT the data in the PG XL does "lock" and then the only was yo use it is with RF SENSE.  Tried all three ICOMs in the PG XL CAT/CiV menu with their appropriate addresses in Civ, tried all baud rates.  None of it works.  Do we have even one person who has successfully used an ICOM transceiver but specifically the 7610 and been successful?
  • 4O3A Signature
    4O3A Signature Member ✭✭
    edited April 2020
    Last HAM asked for help and fix it sucessfully was Stan - [email protected]
    Also Ria N2RJ uses 7610, I think.

    If you don't solve it, we can help with remote access to your desktop.

    73
    Ranko
  • Dan-N7HQ
    Dan-N7HQ FlexRadio Employee, Community Manager admin
    edited April 2020
    Hi Wayne,

    Yes, we have had successful integrations of the PGXL and ICOM transceivers.  Can you please describe what you mean by "the PGXL does "lock" and then the only way was to use it is with RF SENSE"

    73,
    Dan N7HQ
  • Wayne Schonfeld
    Wayne Schonfeld Member ✭✭
    edited May 2020
    The LCD window of the PG XL has two horizontal columns-A and B.  Also, for each column, is PTT, BAND,amplifier type, and an open window .  When you interface the Flex 6000 series-as soon as the radio is on and listening-the column assigned will show the band and the open window mentions the nickname of the Flex series radio.  PTT lights red on transmit.  The BAND is stable whether on receive or transmit until you switch bands and then the new band is displayed.  If you tune up and down that band, the BAND is locked and the BAND changes immediately if you switch to another band and then that locks.  Seemless!

    With the ICOM 7610, the PTT does turn red on transmit assuming you have connected the PTT cable.  The data from the 7610 shows up transiently in the open window when you tune the radio in receive.  The actual frequency is transiently shown and the BAND will transiently go to whatever band has been chosen on that column.  As soon as you stop tuning, the data and BAND disappear from the column on the LCD even if you key down.  This is what I refer to as "locked"  The Flex transceiver lock the data the minute you select the band.


    OK-hope you are understanding what happens.  If I choose to transmit after the data disappears, the PTT lights red but nothing happens in SSB.  If however you transmit a carrier such as CW, AM or FM then the LCD on the PG XL read PLEASE UNKEY.  When you do unkey, the BAND on the PG XL "locks" on the correct band you transmitted on and the windows which had shown the frequency before it disappears says RF SENSE.  This will lock then on that frequency until you tune to another frequency on that band  if you switch bands.  So the linear does work.  It requires this key and unkey to get the linear to work in the RF SENSE mode.  Having spoken to Flex they understand this but don't know why the CiV circuit isn't driving the BAND change and why the linear needs me to use RF SENSE everytime I change frequency.

    I hope you understand.  Thanks
  • Wayne Schonfeld
    Wayne Schonfeld Member ✭✭
    edited April 2020
    Here's the resolution thanks to Stan WA5RTG.  For the ICOM 7610 choose the IC 775 radio in the Power Genius Utility with a baud rate of 9600 and 8N1.  THE CORRECT ADDRESS FOR THE CIV ON THE 7610 IS 6Ah which I was told matched the Icom 7800 not the IC 755.  Now the data stays and locks!!!!!!

    Much thanks and I hope this info is put out for anyone else with the ICOM 7610.  Thanks to all

    Wayne
  • Dan-N7HQ
    Dan-N7HQ FlexRadio Employee, Community Manager admin
    edited April 2020
    Thank you, Wayne, it's time to submit a helpdesk request and we'll work with you on this. I'm not sure what is going on, but I am certain we will get to the bottom of it.   

    Do you need help with submitting the ticket? 

    73,
    Dan
  • Dan-N7HQ
    Dan-N7HQ FlexRadio Employee, Community Manager admin
    edited April 2020
    Wayne, very happy that is working. However, there must be a bug with either the firmware or the PGXL windows utility.  ICOM documentation clearly says the CI-V address for the 775 is 46h.  We will be reviewing the CI-V addresses the amplifier uses for ICOM gear. 

    73,
    Dan
  • Wayne Schonfeld
    Wayne Schonfeld Member ✭✭
    edited April 2020
    OK Dan-this was what WA5RTG has been using and it works also for me.  I saw a chart of CiV addresses online for all ICOM rigs (independent of Flex and ICOM) and I agree 6A isn't the one for the IC775-but it seems to work.  Let us know if you find a bug.  I have learned al ot about CiV-the wrong addresses can either lead to NO communication, error in communication or in my case transient communication.

    Stay safe and well

    Wayne
  • KD0RC
    KD0RC Broomfield, COMember, Super Elmer Moderator
    edited April 2020
    It uses the basic command set for the 775, but that does not change the CiV address for the 7610 which is x6A.
    73,
    Len, KD0RC
  • Presley, W5PD
    Presley, W5PD Member
    edited April 2020
    Wayne, Thank you very much. I have been trying for a while to get my IC 7610 to control my PGXL using CAT with no luck. Ended up using RF Sensing by sending a dash when changing bands. Now the CAT works as it should.
    Of course, the PGXL works great with my 6700.Never a problem there.
    73
    Presley W5PD
  • Wayne Schonfeld
    Wayne Schonfeld Member ✭✭
    edited May 2020
    Dan-not sure how to best contact you.  I received an email today about a new firmware upgrade for the PG XL.  Thanks to Flex for this.  My only concern is what you mentioned in your last email.  You said there might be a firmware quitch which would explain why I was only able to interface the 7610 with my PG XL using the ICOM 775 on the PG XL dropdown menu and setting the 7610 CiV address at 6A.  Does the new firmware correct this and will I need to adjust my settings on the 7610.  Thanks in advance.  Really don't want to go through all of that again if Flex changed the commands.

    Wayne WA4YDJ
  • Dan-N7HQ
    Dan-N7HQ FlexRadio Employee, Community Manager admin
    edited May 2020
    Hi Wayne,

    The problem is not in the firmware, it is in the Windows Utility application (a new version of that is coming soon).  So, no sir, there is nothing you need to do.  When the new utility comes out, you may need to select a different ICOM radio in the list, we're not 100% about that yet, the release notes will cover this issue and our goal is to not require additional changes to your ICOM settings. 

    I can always be reached at my desk (512) 535-4713 x225
  • Wayne Schonfeld
    Wayne Schonfeld Member ✭✭
    edited May 2020
    thanks-so I will download the new firmware tomorrow.  I appreciate splitting the SWR alarm-that will be very helpful.  Thanks again
  • W8ASA
    W8ASA Microwave Parts Guy Member ✭✭

    Did the new firmware solve the issue of having to use the 775 radio commands? The April 30 posts are the last I've seen on this matter. I'm about to order a PGXL for my Flex 6400 and IC-7610, but want to make sure there is no problem BEFORE I order. Ken W8ASA

  • I have the new firmware but it didn't fix the problem. Another ham on the board got back to me. He has interfaced a IC7600 with the PGXL. Here are the settings-and it work fine


    On the PGXL firmware: Pick the IC-755 as the radio, set the baud rate at 9600 and the port to 8N1


    On the ICOM 7610-in the settings menu:

    CiV Baud 9600

    CiV address 6ah

    Turn Civ Transceive on


    I don't know if this will be OK for your IC 6400


    Good luck😀

  • W8ASA
    W8ASA Microwave Parts Guy Member ✭✭

    Yesterday, a friend and I unboxed my new PGXL. Hooking it up to the Flex 6400 was plug and play simple. For the IC-7610, we had to connect the CI-V cable and change the hex addresses to 6A on the radio and the PGXL. Baud rate was set to 19200 on both, and now they work well together.

    I like to use N1MM for contesting with my 7610, and therein lies the real problem. To use the N1MM spectrum scope, the baud rate must be 115,200. The dropdown menu in the PGXL shows it as a choice, but if I select it, it actually takes me to 44464 or something like that, which is a strange number. That means I'm out of luck using the spectrum scope to display spots.

    I suggest that Flex Radio either implement 115,200 as a usable choice, or change the menu to show only the speeds it actually does support.

    This N1MM issue is pretty important, so I hope Flex increases the CI-V baud rate to at least 115,200. Other than that, the radios behave well with the PGXL, and my wife likes the looks of the PGXL.

    Ken, W8ASA

  • W2PP
    W2PP Member ✭✭

    I’m surprised you got it to work. I’ve tried that approach and it was a failure here.

    Meaning I couldn’t get the 7610 to talk to the amp

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    Ken

    I checked about the baud radio and adding 115,200 is not a trivial exercise, so it is something you won't likely see any time soon.

    73

  • k5go
    k5go Member
    Ken,

    I am using the IC-7610 with the PGXL and also using N1MM. The PGXL is connected using the CI-V cable and I have selected IC-7800, 9600 baud rate and 8N1. In the IC-7610 6aH is selected and the CI-V baud rate is 9600. In N1MM 6A is put in config for radio type. The radio is connected using 115,200 and the CI-V USB BAUD RATE is set at 115,200. So you can have a different baud rate in the radio for CI-V and for CI-V USB.

    Hopefully this helps.

    I had not read this discussion board before. I am the one referred to as WA5RTG (my original call sign). I noticed there were some posts having to do with how I managed to make the IC-7610 work with this amplifier. Some of the information was incorrect so I inlcuded that in the first paragraph.

    Regarding this amplifier, I definitely had buyers remorse in the beginning. Had a lot of problems, had to take it back from Cayman Islands and send in for some repairs or updates, etc. It has been working well since although I am very disappointed in the maximum power this thing will deliver. When the internal meter says 1500W, you are not getting 1500W. On 160M my amplifier rolls back power long before it gets close to 1500W. I put a bird wattmeter on it and on 160M I can get about 1150 watts out before the APC kicks in.

    73...Stan, K5GO/ZF9CW
  • NN4X
    NN4X Member
    OK - new PGXL owner here, also trying to make it work via CI-V with an IC-7610. The PGXL firmware 3.6.21. I've tried the suggested settings mentioned in this thread, and have had partial, but not full success.

    I didn't find that changing the IC-7610's CI-V address mattered, so have left it at the default. The PGXL *is* able to establish a CAT connection, and it tracks with the radio. HOWEVER, it loses communication every 2 or 3, or 6 or whatever seconds, only to reconnect. The result is that there's nearly constant background chatter from the relays clicking in / out. I've got the CI-V speed down to 4800 baud, having previously tried 9600 and 19,200 baud, but it hasn't really changed the symptoms.

    I *could* get away with using simple band data, but would like to get this properly sorted for the eventual purchase of the TGXL. Without the PGXL properly "talking" to the CI-V bus, I'm guessing the TGXL is useless.

    Any thoughts?
  • I have had the PGXL for some time and this is the best data capture I have gotten as you describe. When you turn the IC 7610 dial there is a delay and many times you hear the relay clicking endlessly. I tried to increase the baud rate but it didn't work. HOWEVER, the Tuner Genius utility and interface DOES NOT have this problem and the data transfer is smooth. I recently sent Flex these comments---it must be a firmware or utility problem in the PGXL. The TGXL utility has a different CiV setup for ICOM. Sorry I can't help further.

  • NN4X
    NN4X Member
    Hi Wayne -

    Thank you for that feedback. I'd tried the 19200 baud rate first, thinking that it would enable a faster refresh of the frequency, and reduce problems like this. Then I went the other way, thinking perhaps the higher rate was making it difficult to "copy" (lower SNR), so kept incrementally reducing the rate.

    I'll make sure I get my feedback directly to FlexRadio. For what these things cost, integration with other brands should be issue-free.

    73,
    Steve
    NN4X
  • Chris Aiken
    Chris Aiken Member
    Wayne,

    Did this ever get sorted out? I am having the same issues with interfacing the 7610. Sporadic band updates, which seem to be completely unstable.

    Tried every combination of settings described.. but with NO luck.

    I have just upgraded the firmware to the latest 3.6.24. No change.

    For the money this beast costs, it really needs to support CVI.

    Please advise when to expect a fix for this?

    73,
    Chris
    KN4FNI
  • Wayne Schonfeld
    Wayne Schonfeld Member ✭✭

    Set the PG CiV settings for:

    : IC775

    baud 9600

    8N1

    Set the 7610 for CiV 6Ah

    It is as good as you will get with some slight delays. The 7610 is flawless with the Antenna Genius so I believe Flex can further improve the Civ interface on the PG.

  • Arizona Mike
    Arizona Mike Member, Unconfirmed
    edited June 1
    Setting the IC-7610 per the above does work. However by changing the CI-V value it then renders SDR Control for Icom inoperable.

    One step forward, two back.
  • James Kennedy-WU5E
    James Kennedy-WU5E Member ✭✭

    hooking up my PGXL to my IC-7610 thanks for all the comments

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.