Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

6500 LOG4OM JTALERT Fatal Error

WA2SQQ Member ✭✭
edited August 2020 in Third-Party Software

I’ve been using LOG4OM V2 for about a week and decided
last night to get WSJT / JTALERT running. I upgraded both programs to their latest versions. My Flex 6500 was on and both WSJT and JTALERT were open and running. Proper operation was verified with Log4OM V1.

Ø  Started the installation procedure described in the LOG4OM manual (below)

Ø  When I get to Step #5 below, I get Fatal Error, "MY SQL Start Failure"

Ø  Posted the problem on the LOG4OM forum and was told that it is a known JTALERT bug.  I found this strange since I’ve seen others say it’s working fine.

Ø  Last night I got to thinking and now wonder if the radio needs to be off, and perhaps also LOG4OM?

Ø  LOG4OM needs to be run in an ADMIN mode – how about JTALERT?

I appreciate any suggestions on how to get this running.


(The steps below refer to page 142 in the latest LOG4OM manual dated 5 FEB 2020)

 1.Enable the Remote Control port in Log4OM V2 with a UDP Port number of 2241- OK

2.Create an "ADIF_MESSAGE" inbound connection in Log4OM V2 with a UDP Port number of 2235 - OK

3. Create a "JT_MESSAGE" inbound connection in Log4OM V2 called JTALERT REBROADCAST with a UDP Port number of 1240 - OK

4. In WSJT-X/WSJT-Z File/Settings/reporting check the boxes and set the ports as shown below. - OK

5.In JTAlert in settings/manage settings/Logging/Log4OM V2 in JTAlert, enable the "Send WSJT-X DX call to Log4OM" and "Enable Log4OM V2 Logging"

When I tried to do step #5 above, I got “Fatal Error, "MY SQL Start Failure"

I was unable to proceed beyond this point.

 6.Set the Control port in JTAlert to match the port used in Log4OM V2 (Step 1.)

 7.Set the ADIF_MESSAGE port in JTAlert to match the port used in Log4OM V2 (Step 2.)

 8. In settings/manage settings/applications/WSJT-X/JTDX in JTAlert enable "Rebroadcast WSJT-X UDP Packets (received only)" and set the IP Address to and UDP Port number to match that set in Log4OM V2 step 3


  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin
    edited February 2020
    I would ask this question in the Log4OM group or the WSJTx group.  You might find more people there who can comment.  BTW, you should not have to run anything in Admin mode.  If you do, there is another problem to address.


  • WA2SQQ
    WA2SQQ Member ✭✭
    edited February 2020
    V1 has a few configuration requirements for which you have to run in as in mode. I think I have the fix. I’ll try it tonight and share the info if it works. It’s a bug in JTALERT.
  • Patrick
    Patrick WH6HI KauaiMember ✭✭✭
    edited June 2020
    Just a note on current state of Log4om and JTAlert.  Recently did a conversion to Windows 10. And in the process resetting up Log4om and JTAlert.  I tried very hard following the instructions to get V2 of Log4om working and had to give up....for now.  Also latest version of JTAlert broke my connections to the radio and logging.  Had to reinstall the previous version to get it to work.  Seems that the latest versions of all these apps are not user friendly,  the documentation is poor and hard to follow.  I guess I am frustrated with all the changes and how they function with each other.   As well as the stress of dealing with all the changes including new computer.  I finally got it all stable again with the older versions, and will leave it that way.  New computer is the only bright spot and a definite improvement. No such thing with the latest SW and that includes Flex.....
  • WA2SQQ
    WA2SQQ Member ✭✭
    edited February 2020
    Please accept my apology for not sharing this sooner. I understand that JTALERT just released a new version which supposedly corrects this problem. I was using the previous version which was released to correct the MYSQL error. It did not. Someone in the JTALERT group figured out that you also needed a Microsoft Visual C++ update. I installed the update and it's working perfectly! I posted the info on the LOG4OM page. Reach out to me directly if anyone wants the links.
  • Patrick
    Patrick WH6HI KauaiMember ✭✭✭
    edited February 2020
    Sorry for the previous post.... I was very frustrated.  

    So here is an update:

    After a breather and getting Log4OM V1 up and running and getting the newest JTAlert installed and everything running stable.  I started a methodical install of Log4OM V2.  Following each UDP connection to the letter as well as the directed configuration changes to WSJT-x and JTAlert.  Did full shut down of the computer and restart.  The full restart is important as it clears out any junk.  Checked my registry for errors and cleansed up as needed.   Voila! It functioned all working.  Procedure to do fldigi and PstRotator followed and all is working.  Finished by getting maps, and other service’s like LOTW functioning.  I am at 99.9% now and fully recovered from the adventure.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.