Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

6700 losing IP LAN connection requiring reset

Dick Illman
Dick Illman Member ✭✭
edited July 2019 in SmartSDR for Windows
3 times in the last 3 days my 6700 has lost its IP LAN connection and  been unreachable for a connection. I have had to restart the radio with a long shutdown. Using V1.10.16.91 SW with radio and PC connected to a gigabit switch. Using DHCP from a WiFi router. No other devices on the LAN are having a problem.


  • Mike va3mw
    Mike va3mw Member ✭✭
    edited February 2018
    Hi ****

    Some of the Alpha team have experienced this same type of failure occasionally.  It 'seems' that it is related to Gigabit switches when it happens.  Flex is still working on isolating this and a possible solution.

    Is there any chance you might have a 100mb/s switch you can try, just as a test?

    (I haven't had the problem, but all my switches are 100mb/s)

    Mike va3mw

  • Les Tucker K6ZF
    edited March 2017
    **** - Did you work for Motorola (a few years ago)?  If so I just want to say hello, but I too also have a 6700 that had a network problem.  The solution was to chuck the PC that I was using.

    Les Tucker - K6ZF
  • N6OIL
    N6OIL Member ✭✭
    edited September 2018
    If you have CLI or GUI access try changing your port speed to 100mb full duplex.
  • Dick Illman
    Dick Illman Member ✭✭
    edited March 2017
    Yes I worked for the big M from 1974 to 2014. I have a 100 Mb switch to try.. I completely rebuilt the PC a month ago and it has been ok until the last couple of days.
  • Dick Illman
    Dick Illman Member ✭✭
    edited March 2017
    I do not think I have access to the switch but I have a 100 mb switch to try.
  • Tony Scandurra K4QE
    edited November 2018
    I experienced the same symptoms as the original poster.  I ran all of the 1.10.x Beta releases with no problem.  1.10.16 Production was installed the day it was released, and it ran fine until yesterday.  Once the problem started, I was unable to maintain a stable connection to the radio.  I reverted back to 1.9.13, and now all is well once again.
  • Kevin
    Kevin Member
    edited July 2019
    My radio just disconnected. It wasn't the first time but enough times to realize it isn't just a glitch.

    A dialog popped up saying I lost connection to the radio. I had to hold the radio power button to get it to reboot but after reboot it connected up. It has happened a couple of times but this is the first time it happened when I wasn't really using the radio.

    I'm directly connected from radio to computer. I never have any indication of poor network quality as measured by the radio. Things are generally pretty stable.

    Looking in Windows 10 Programs and Features I notice that Intel Network Connections Drivers were updated on 2017-03-07 to version 20.4. This is a Dell system. I'm not sure whether the update came from Dell or from Microsoft. I suspect it's Dell's auto update.

    Intel Rapid Storage Technology also updated on the same day.

    I checked Event Viewer and note that Intel Ethernet Connection (2) I219-V Network link is disconnected. This event was recorded minutes ago. There are identical events recorded averaging about two per day but not at the same time each day. The first of these events occurred on 1/7/2017. The details of each event are identical: 

    Intel(R) Ethernet Connection (2) I219-V 0000040002003000000000001B0004A00000000000000000000000000000000000000000000000001B0004A0

    (I'm sure that's meaningful!)

    Ethernet Connection (2) specifically refers to the radio's connection. There is no other Ethernet connection made to this computer.

    For fun, I right-clicked the adapter to run diagnostics. No trouble was found but the radio disconnected. That's probably to be expected but unlike the reason for this post the radio did not need a reboot.

    Hope something here helps with the diagnosis.

    Kev K4VD
  • Mike va3mw
    Mike va3mw Member ✭✭
    edited March 2017
    Is that a 1G connection?
  • Kevin
    Kevin Member
    edited March 2017
    Yes. It is. Always has been set to 1G. I'll set it to 100 Mbps Full Duplex for a while to see if that helps.

    Is this an issue that FRS acknowledges and will correct?
  • Tony Scandurra K4QE
    edited March 2017
    I decided to give 1.10.16 another chance.  I did a full uninstall (as I always do), and then I re-deployed 1.10.16.  So far, so good...hope it stays that way.
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    Thanks for the issue reports.  This behavior is in our bug tracker as issue #4534 and is currently under investigation.
  • Kevin
    Kevin Member
    edited March 2017
    Just lost connection again. 
    Wireless LAN adapter Local Area Connection* 2:
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
    Ethernet adapter Ethernet:
       Connection-specific DNS Suffix  . :
       Link-local IPv6 Address . . . . . : fe80::c978:d5a9:2d3a:2a2b%18
       Autoconfiguration IPv4 Address. . :
       Subnet Mask . . . . . . . . . . . :
       Default Gateway . . . . . . . . . :
    On the Ethernet jack on the radio I see the amber light solid and the green light flashing. Similar on the computer. This is a direct connection - computer to radio.

    Recycle the radio and it shows back up in the chooser.

    Windows Event Viewer shows:
    The network interface "Intel(R) Ethernet Connection (2) I219-V" has begun resetting.  There will be a momentary disruption in network connectivity while the hardware resets.Reason: The network driver requested that it be reset.
    This network interface has reset 2 time(s) since it was last initialized.
    Not sure if this is helpful:
    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">    - <System>
      <Provider Name="Microsoft-Windows-NDIS" Guid="{CDEAD503-17F5-4A3E-B7AE-DF8CC2902EB9}" />
      <TimeCreated SystemTime="2017-03-13T19:32:59.059574000Z" />
      <Correlation ActivityID="{BDE957CA-EB96-40E8-9E19-EF85AE71C04E}" />
      <Execution ProcessID="4" ThreadID="5472" />
      <Security />

    - <EventData>
      <Data Name="IfGuid">{BDE957CA-EB96-40E8-9E19-EF85AE71C04E}</Data>
      <Data Name="IfIndex">18</Data>
      <Data Name="IfLuid">1689399632855040</Data>
      <Data Name="AdapterName">Intel(R) Ethernet Connection (2) I219-V</Data>
      <Data Name="ResetReason">3</Data>
      <Data Name="ResetCount">2</Data>

    The adapter is set to 100 Mbps.


  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    Kevin, that really doesn't shed much insight into root cause.  Can you open a HelpDesk ticket on your disconnects?  I'd like to work with you one-on-one to see if we might be able to glean some useful clues as to what might be happening.  If Dudley picks up the ticket before I do, please instruct him to assign the ticket to me.  Thanks.
  • Kevin
    Kevin Member
    edited March 2017
    Request #17496 submitted.
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.