Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Tuning with FlexControl keeps going and going and going and going.....

Michael - N5TGLMichael - N5TGL Member ✭✭
This has been a problem since the first release. When getting to the edge of the panadapter window, if you keep tuning with the knob, it appears to buffer tuning input and the window will continue to scroll/tune down the band for quite a while after you stop tuning input. Sometimes it seems that it will never stop until you tune back in the opposite direction. I haven't seen anyone else report this, so I wonder if I am the only lucky one? I would like tuning to stop when I stop supplying tuning input, and not continue to unload buffered tuning commands, as this results in overshoot 100% of the time and is very annoying. I can supply video if need be of the problem.

Completed · Last Updated

Answers

  • Ed_NZ1QEd_NZ1Q Member ✭✭
    edited March 2017
    I noticed this effect as well. In my case it turned out to be the fact that my PC is very slow (an old XP machine, single core, no separate video card) - far less than Flex recommends. To mitigate this tuning problem, I decreased the frame rate (fps) to about 5 fps. This freed up the processor enough to let the display pretty much keep up with the Flex control knob.
  • Ray Andrews, K9DURRay Andrews, K9DUR Member ✭✭
    edited January 2017
    Ed , I have noticed this also from day 1, & my PC is definitely NOT slow. 73, Ray, K9DUR
  • Michael - N5TGLMichael - N5TGL Member ✭✭
    edited December 2016
    Ed, I'm in the same boat with Ray here. I'm running a quad core at 2.9 GHz, so that shouldn't be the problem. I can see how a new PC would benefit you though! :)
  • Ken - NM9PKen - NM9P Member ✭✭
    edited June 23
    I have been told in other posts that it isn't a function of PC CPU speed anymore, but of the power and speed in the graphics card. The effect is magnified with multiple panadapters and higher FPS rates. You can verify this by turning FPS down to a very low rate and seeing if it changes things. I am currently shopping for a good, but inexpensive graphics card capable of three or four HDMI outputs at high speed. So far I haven't pulled the trigger on any of them. I hear from Neal and Steve that AMD video processors seem to work the best....
  • Asher - K0AUAsher - K0AU Member ✭✭
    edited June 23
    Just as an experiment, try minimizing the slice flag (by clicking on the letter) and see if the FlexControl responsiveness improves. I've notice in Windows Process Explorer a high background page fault rate in SSDR (under Windows 8 and 8.1, quad core i5, 16GB DRAM and HD5000 integrated graphics). The page fault rate drops close to zero when I minimize the flag. Curious if anyone else sees the same thing and what their configurations look like.
  • Michael - N5TGLMichael - N5TGL Member ✭✭
    edited October 2016
    Ken, Good suggestion, I put 'er down to 1 FPS and still had the "buffered tuning" problem. The slice keeps up perfectly fine when tuning about in the panadapter, the problems happen when the panadapter has to scroll. I was hoping for an improvement by setting the refresh down to 1 FPS, because then a new card would do the trick. I'm very interested to know what card you come up with. I am using the internal one in this computer, so I could do with an upgrade.
  • Michael - N5TGLMichael - N5TGL Member ✭✭
    edited October 2016
    I minimized the flag and still have the same "buffered tuning" issue. Not sure where to look for page faults...running win 7 here.
  • Ken - NM9PKen - NM9P Member ✭✭
    edited December 2016
    Also, you might check your data rate through the ethernet connection. I hae heard that a slow or collision rich ethernet environment can produce delays in the screen update when scrolling. (On this point, I am NOT an IT expert, so I will defer to others to make more comments.)
  • Reggie-k6xrReggie-k6xr Member ✭✭
    edited July 2016
    I have this isssue with my MacBook Air/Parallels but not with my Mac-Mini running win 7 and bootcamp.
  • Ray Andrews, K9DURRay Andrews, K9DUR Member ✭✭
    edited September 2016
    Ken, I use a direct Ethernet connection (no switch or router), & still have the problem. So, that is probably not the issue. 73, Ray, K9DUR
  • George KF2TGeorge KF2T Member ✭✭✭
    edited December 2016
    Interesting, I see a drop is CPU utilization with the flag minimized. Not that my system is overtaxed (Win 8.1, Quad core 3 GHz, 16 GB RAM) but the drop is bigger than I expected- about 3% utilization difference. In addition to the occasional runaway tuning, have you noticed that adjusting the RF power slider while in transmit creates a nasty, irregular output? Not sure why...
  • Ken - NM9PKen - NM9P Member ✭✭
    edited December 2016
    On my Lenovo K410 with i3 and 6 Gb RAM, I have two pans with one slice each on my 6500... FPS of 25 on each and averaging 25 on each... CPU load of 45%. When I drop the FPS to 8 on each slice, it drops to 30%. Closing the slice flag lowers it to about 26-27%. I have DAX screen, Audacity, Internet explorer, and K9DUR's clock/timer and Voice Keyer open with all of this. Not too bad. If I close one of the pans CPU load drops to 30-32% with the FPS on 25, and drops to about 22% with FPS at 8.. This is also with two monitors, and SSDR on about 3/4 of one screen. Maximizing SSDR on my 22 inch monitor raises the single slice CPU load about 5%.
  • Chris Tate  - N6WMChris Tate - N6WM Member ✭✭
    edited May 8
    I am also having problems with this.  I am a serious contester and losing control of tuning frequencies in a slice is a serious challenge.  I have a good computer (NUC) and 8 gb of RAM.  hope to hear from more on this...  Flex 6500.
  • Stu Phillips - K6TUStu Phillips - K6TU Member ✭✭
    edited August 2016
    Two things to check...

    1. make sure that the FlexControl isn't overlapping with a virtual serial port.  Windoze is notorious for ignoring virtual ports when selecting the port to assign to a physical COM device.  You can use the Device Manager and the Advanced Option under Properties to assign a port to the FlexControl.  I usually put the COM port for the FlexControl up high - like around 40 or 50.


    2. Using the Advanced Properties, make sure you set the FIFO depth to 1 for both RX and TX.

    If it still keeps going, check the CPU utilization and also check that you have a decent graphics card AND that SmartSDR says that its using Maximum Hardware Acceleration.

    Stu K6TU
  • WW1SS - SteveWW1SS - Steve Member ✭✭
    edited December 2016
    I have the same issue. When getting to the edge of the pan and tuning it keeps going. I was told it is " adaptive tuning" and normal. Tune slower i was told. I wish it could be turned off
  • Bob G   W1GLVBob G W1GLV Member ✭✭
    edited June 16
    This has been a problem since day one. FRS seems to wash their hands about this problem. It works well in PSDR.
  • Chris Tate  - N6WMChris Tate - N6WM Member ✭✭
    edited May 2016

    Stu I didn't see any visible overlap.  I had resolved some of that since I am controlling a remote rig to K6LRG from this pc as well.. it takes up some port real estate in the ol device manager. 

    I did however move it up to a crazy high port and subsequently made the FIFO depth adjustments and it does seem to be greatly improved.  so maybe something was overlapping something.

    This seems to have worked.  The computing in question has some good resources.. but not the super best video card. 

    Maybe some of the other commenters will find this useful as well..

    Thanks Stu.. you rock.

    ~C. N6WM





  • Dave KD5FXDave KD5FX Member ✭✭
    edited March 2017
    It's doing it on my PC too, Mike. Quad core XEON at 3GHZ  with 16 GB of RAM and Win 7 Pro.
    Very interested to see if there is a solution for this...
    73, Dave KD5FX
  • Steve W6SDMSteve W6SDM Member ✭✭
    edited December 2014
    Add me to the "me too" crowd.  I have fast everything (Intel i7, etc.) and it does it.  I wonder if there is a way to moderate the buffer using software?  In other words, control how much memory the flex control can grab to scroll?  I have had to sit and wait patiently to keep mine from scrolling out of the band sometimes.

    Steve
    W6SDM
  • Steve W6SDMSteve W6SDM Member ✭✭
    edited March 2017
    Add me to the "me too" crowd.  I have fast everything (Intel i7, etc.) and it does it.  I wonder if there is a way to moderate the buffer using software?  In other words, control how much memory the flex control can grab to scroll?  I have had to sit and wait patiently to keep mine from scrolling out of the band sometimes.

    Steve
    W6SDM
  • Steve W6SDMSteve W6SDM Member ✭✭
    edited December 2014
    Sorry for the double post.  Maybe I should lay off the coffee.
  • Michael - N5TGLMichael - N5TGL Member ✭✭
    edited December 2016
    I've found that getting a decent video card helps, but does not eliminate the problem.  I just installed an Nvdia GTX 750 Ti and it helps, but it still does it.  I'll try Stu's suggestion of a crazy high port + adjusting the FIFO buffers and see what happens.

    Also, I would encourage everyone who is experiencing this to hit the "ME TOO" button at the top of the post.  This helps visibility of the problem
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    I wonder if there is a way to moderate the buffer using software?

    We do not know if there is a way to do this programically.  We have a defect in your bug tracker to look at it for a future release of SmartSDR.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    We are aware of the issues with the FlexControl, but currently it is working as designed.  The FlexControl sends tune commands to the radio when the knob is rotated and the amount of frequency tuned is dependent on the slice tune step size.  The radio is properly tuning when it receives a tune command from the FlexControl.  Tuning the radio is not an instantaneous action, as the radio hardware has to tune and the GUI must update the high resolution panadapters and the slice position.  When you are at the edge of the panadapter, even more GUI operations are taken because both the panadapter and the slice are being tuned.  More on this in a minute.

    As Stu has noted, the FlexControl uses an emulated com port on a USB interface.  Comports have deep FIFO buffers by default that can store a lot of tune commands.  If you rotate the knob quickly, it senses that it is being turned quickly and informs SmartSDR which will tune in larger tune steps; this is the accelerated tuning algorithm.  Buffers have to partially fill before being emptied.  By making the com port FIFO buffer smaller, there is less "queuing" of tune commands which mitigates the radio getting tune commands after you have physically stopped turning the knob.

    Also, as Michael noted, a fast graphics card also helps, since the GUI is having to do a lot of multiple display renderings as your tune quickly and even more that happen at the edge of the panadapter (pan edge tuning).  Several people have compared this to PowerSDR and say it works better.  The logic in SmartSDR is essentially the same as what is used in PowerSDR.  The only difference is that there is a lot more radio tuning actions happening with a 6000 since there are "two degrees" of tuning freedom (slice and panadapter) and the GUI is having to perform a lot more rendering operations per tune command.

    We have several issues logged in our bug tracker to look at this operation and see if there is anything that can be done to make tuning smoother at the band edges and when tuning wide jumps in frequency when the knob is quickly rotated.  In the mean time, to mitigate the run on tuning, refrain from spinning the knob and set the FIFO buffer to a smaller size (http://helpdesk.flexradio.com/hc/en-us/articles/202118458-How-to-Mitigate-FlexControl-Latency

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.