Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

New 6600M User - Network communications issues - everything Link Local

Doug Wilson
Doug Wilson Member ✭✭
edited December 2021 in Networking
I'm having trouble using SmartSDR. I've connected the ethernet cable from the radio to the computer. I see the flex serial ports on the device manager. But I keep getting the no radios found message when launching 3.2.39 SmartSDR. I've tried to set the ip address on ipv4 on the ethernet adapter to match the radio address but that didn't work. I'm sharing the ethernet adapter with the wifi adapter. I've read and searched but I'm missing something. Thanks for any help.

Answers

  • [{"insert":"Have you verified that the Ethernet adapter actually works and that the cable is good? \n"}]
  • Doug Wilson
    Doug Wilson Member ✭✭
    It's the adapter built into the computer. It appears to be working and the cable is new from Flex. I see com port 5 and 105 when it's plugged in to the computer.
  • Doug Wilson
    Doug Wilson Member ✭✭
    I used TPLink ethernet connectors and everything is working great.
  • I assume this means that your built in ethernet adptr is bad?
  • KD0RC
    KD0RC Broomfield, COMember, Super Elmer Moderator

    @Halobiont , So you are now able to use SmartSDR with your 6600?

  • Doug Wilson
    Doug Wilson Member ✭✭
    Yes. I'm using one of those Ethernet Link devices that work through the house wires. One plugs in at the router location and one at the radio. My router is in another part of the house. I'm connected through SmartLink. I never figured out why I couldn't direct link with the computer. I tried to change the IPV4 to the radio IP, also tried auto IP with DHCP. I was doing something wrong there.

    So yes, I'm up and running. Thx.
  • John KB4DU
    John KB4DU Member ✭✭✭

    Are you saying the radio is connected through smartlink on the local lan?

  • Doug Wilson
    Doug Wilson Member ✭✭
    Yes. I think so.
  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    If you are using SmartLink (somehow) in your house, you are not doing yourself any performance favours.

    It would help if you posted the IP address of the Radio and the Computer as that will help identify what is going on.

    This video might help give you some background on how it works.


  • Doug Wilson
    Doug Wilson Member ✭✭
    Ok. Thank you.

    When I run ethernet from the radio to the computer ethernet plug and start SmartSdr I see "No Radio Available" Of course I can use the standalone radio but I can't use SmartSDR.

    Here are the IP addresses I get from the radio menu:

    Front Panel 169.254.6.176 (This is just the IP address to the front panel display?)
    Radio 169.254.1.76

    I tried going into the ethernet network adapter properties (where the radio is plugged into the computer) to change the ipv4 address to the radio ip address with a subnet mask of 255.255.0.0...same result, no radio available. It doesn't matter what I put in for gateway either. The computer is connected via wifi to the router.

    -------------------
    Since the router is in another part of the house and I start thinking that I'm not going to get this working without Smartlink I connected TPLink Powerline adapters and Smartlink starts working and I have a radio to select.

    Radio----TP Powerline Ethernet Connector---TP Powerline Ethernet Connecter at Router----Router

    This works and I see my radio when logged into Smartlink and can login and use SmartSDR.

    ----------------
    What is the best way to direct connect to my computer and have the radio online when my radio and computer are not near the router?
  • Doug Wilson
    Doug Wilson Member ✭✭
    This?

    https://www.flexradio.com/products/flexradio-wi-fi-network-bridge/
  • Doug Wilson
    Doug Wilson Member ✭✭
    Actually that wifi bridge looks like an inferior way to connect to the lan. I'm using this to connect to my lan and it's working.

    I think I need a switch and wire it as in this diagram where the link from the router to the switch is the Powerline connector.
  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin
    edited December 2021

    GM

    If you can't see the radio on your local lan, then you are running 2 different networks or subnets. You will need to solve this and you may want to review turning on Bridge mode on your network equipment.

    You have addresses that are starting with 169. These are what is called LinkLocal addresses and you really need to solve that. What is happening is the radio and the computer are not getting a valid IP address from your DHCP server (one of the main traffic cops).

    Link local IP addresses are subject to change as well. This is why you are dropping off SmartLink and registrations are failing. An IP address in the range from 169.254.1.0 to 169.254.254.255. It is used to automatically assign an IP address to a device in an IP network when there is no other assignment method available, such as a DHCP server.  169 addresses are non-routable meaning your traffic won't go where you need it to go.

    At this point, it would be helpful for you to reach out to someone locally who understands networking and can work to get things setup correctly. You do not want to be guessing and you do need to understand how the ethernet communications is working. This will also affect the performance of all other devices on your network.

    73

  • Dan-N7HQ
    Dan-N7HQ FlexRadio Employee, Community Manager admin
    edited December 2021


    Automatic Private IP Addressing (APIPA), aka "Link-local" IPv4 networks 169.254.0.0/12 (169.254.x.x), cannot be used for SmartLink under any circumstance. They are non-routable on the Internet and will never be.

    Link-local address - Wikipedia

    IPv4 Private Networks 10.0.0.0/8 (10.x.x.x), 172.16.0.0/12 (172.16.x.x) and 192.168.0.0/12 (192.168.x.x) are also non-routable.

    Private network - Wikipedia

    Shared Address Space (aka Carrier Grade NAT) networks are allocated 100.64.0.0/10 (100.64.0.0 - 100.127.255.255); those addresses are also non-routable.

    Carrier-grade NAT - Wikipedia

    SmartLink requires the radio to be "connectable" from the Internet, and this is your routable public IPv4 address and two configured (manual or automatic - UPnP) "port forwards" through your edge router.

    SmartLink will not work if your radio is not connected to a LAN that provides a route to Internet resources.

    Please consult our YouTube channel for lots of videos on networks:

    FlexRadioSystems - YouTube

    73,

    Dan, N7HQ

  • K0FLY
    K0FLY Gayle-K0FLY Member ✭✭✭

    Good Morning:

    Dan's post jogged my memory. It appears that Halobiont do not have a private network.

    Halobiont go to the 6600M front panel SELECT "Network".

    In the RADIO SECTION, SELECT the "ADVANCED" button. The button will be highlighted

    There is a button for "ENFORCE PRIVATE IP CONNECTIONS" which is probably highlighted and displaying "ENABLED"

    DESELECT this function. You will get a warning and the button will display "DISABLED".

    SSDR should connect to your radio. with the 169.**** address.

    If it does I urge you to set your internal LAN to a PRIVATE NETWORK", a Windows Function and reset the Enforce function back to enabled.

    Hope this helps.

    Gayle K0FLY

  • Doug Wilson
    Doug Wilson Member ✭✭
    Hi,

    Thank you all for your help!

    I installed a switch connecting the radio, router (via TP Powerlink) and the computer. Just as in the guide. Everything is working well. I can connect to my computer without Smartlink and Smartlink is working also. I'm going to work on a direct link to the router.

    The only thing I couldn't get working is the direct connection from the radio to the computer without involving a lan. I think Gayle has that answer.

    Really enjoying the radio!

    Thanks again,
    Doug N1KB

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.